aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-12-16 00:17:46 +0800
committerwg <wg@FreeBSD.org>2013-12-16 00:17:46 +0800
commit2a2657433c0cd564b2a2da9e60eb35d412a019f2 (patch)
treedf8d35c07101d44b5dce5e65141f5f309f0f5e97 /misc
parent1cd391ac2fd1b41be5f34dcd4756d1a5d156308c (diff)
downloadfreebsd-ports-gnome-2a2657433c0cd564b2a2da9e60eb35d412a019f2.tar.gz
freebsd-ports-gnome-2a2657433c0cd564b2a2da9e60eb35d412a019f2.tar.zst
freebsd-ports-gnome-2a2657433c0cd564b2a2da9e60eb35d412a019f2.zip
misc/cuecat: fix python usage
Reported by: exp-run (PR 184591) Approved by: portmgr (blanket)
Diffstat (limited to 'misc')
-rw-r--r--misc/cuecat/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/misc/cuecat/Makefile b/misc/cuecat/Makefile
index 62bf2bd32daa..1cf24ed2f25d 100644
--- a/misc/cuecat/Makefile
+++ b/misc/cuecat/Makefile
@@ -26,18 +26,18 @@ WRKSRC= ${WRKDIR}/cuecat
NO_STAGE= yes
pre-install:
@${MV} ${WRKSRC}/cuecat.py ${WRKSRC}/cuecat.py-orig
- @${SED} 's;/usr/opt;${PREFIX};' ${WRKSRC}/cuecat.py-orig >${WRKSRC}/cuecat.py
+ @${SED} 's;/usr/opt/bin/python;${PYTHON_CMD};' ${WRKSRC}/cuecat.py-orig >${WRKSRC}/cuecat.py
@${MV} ${WRKSRC}/barcode.py ${WRKSRC}/barcode.py-orig
- @${SED} 's;/usr/opt;${PREFIX};' ${WRKSRC}/barcode.py-orig >${WRKSRC}/barcode.py
+ @${SED} 's;/usr/opt/bin/python;${PYTHON_CMD};' ${WRKSRC}/barcode.py-orig >${WRKSRC}/barcode.py
.if !defined(WITHOUT_X11)
@${MV} ${WRKSRC}/xcuecat.py ${WRKSRC}/xcuecat.py-orig
- @${SED} 's;/usr/opt;${PREFIX};' ${WRKSRC}/xcuecat.py-orig >${WRKSRC}/xcuecat.py
+ @${SED} 's;/usr/opt/bin/python;${PYTHON_CMD};' ${WRKSRC}/xcuecat.py-orig >${WRKSRC}/xcuecat.py
.endif
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/cuecat.py ${PYTHON_SITELIBDIR}
${INSTALL_SCRIPT} ${WRKSRC}/barcode.py ${PYTHON_SITELIBDIR}
- python -O -c "import barcode, cuecat"
+ ${PYTHON_CMD} -O -c "import barcode, cuecat"
${LN} -sf ${PYTHON_SITELIBDIR}/cuecat.py ${PREFIX}/bin/cuecat
${INSTALL_MAN} ${WRKSRC}/cuecat.1 ${PREFIX}/man/man1
.if !defined(WITHOUT_X11)