aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-05-09 00:11:52 +0800
committertcberner <tcberner@FreeBSD.org>2017-05-09 00:11:52 +0800
commit4480b5627175f7481b3054e5b7743e408c7d833e (patch)
tree80194e2df8ee876b208d6180a6eeb9a7cfbdf71e /misc
parent73a7a9267073e1ba92752975ffddfb0cf88a3d4c (diff)
downloadfreebsd-ports-gnome-4480b5627175f7481b3054e5b7743e408c7d833e.tar.gz
freebsd-ports-gnome-4480b5627175f7481b3054e5b7743e408c7d833e.tar.zst
freebsd-ports-gnome-4480b5627175f7481b3054e5b7743e408c7d833e.zip
Fix shebangs
* For this, make the implicit run-time dependency on python explicit. Reported by: miwi Approved by: rakuco (mentor, implicit)
Diffstat (limited to 'misc')
-rw-r--r--misc/tellico-kde4/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/misc/tellico-kde4/Makefile b/misc/tellico-kde4/Makefile
index ef46673815a4..475a4af1b5d1 100644
--- a/misc/tellico-kde4/Makefile
+++ b/misc/tellico-kde4/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tellico
PORTVERSION= 2.3.12
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc kde
MASTER_SITES= http://tellico-project.org/files/
@@ -20,11 +20,17 @@ LIB_DEPENDS= libexempi.so:textproc/exempi \
libtag.so:audio/taglib \
libyaz.so:net/yaz
-USES= cmake gettext kde:4 pkgconfig shared-mime-info tar:bzip2
+USES= cmake gettext kde:4 pkgconfig python:run \
+ shared-mime-info shebangfix tar:bzip2
USE_GNOME= libxml2 libxslt
USE_KDE= kdelibs libksane pimlibs soprano \
automoc4 qimageblitz libkcddb libkcompactdisc
USE_QT4= corelib dbus gui network phonon svg xml \
qmake_build moc_build uic_build rcc_build
+SHEBANG_FILES= src/fetch/scripts/bedetheque.py \
+ src/fetch/scripts/dark_horse_comics.py \
+ src/fetch/scripts/fr.allocine.py \
+ src/fetch/scripts/ministerio_de_cultura.py
+
.include <bsd.port.mk>