aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-09-11 05:31:33 +0800
committerantoine <antoine@FreeBSD.org>2013-09-11 05:31:33 +0800
commit67f0c1ae295da5f9c6346b1ceb657dd2f1faf070 (patch)
tree64d1dd939e0e8960c2c5620ed1e135ca08c1fd33 /misc
parent8a8f767a247d47f6100b5946d98c7aa7267bf6cc (diff)
downloadfreebsd-ports-gnome-67f0c1ae295da5f9c6346b1ceb657dd2f1faf070.tar.gz
freebsd-ports-gnome-67f0c1ae295da5f9c6346b1ceb657dd2f1faf070.tar.zst
freebsd-ports-gnome-67f0c1ae295da5f9c6346b1ceb657dd2f1faf070.zip
Add an explicit dependency on pkgconf
Approved by: portmgr (bapt)
Diffstat (limited to 'misc')
-rw-r--r--misc/gkrellm-helium/Makefile7
-rw-r--r--misc/gkrellm-xkb/Makefile7
-rw-r--r--misc/gkrellmbgchg2/Makefile1
-rw-r--r--misc/gkrellmlaunch2/Makefile1
-rw-r--r--misc/gkrellshoot2/Makefile1
-rw-r--r--misc/gkrellweather2/Makefile8
6 files changed, 9 insertions, 16 deletions
diff --git a/misc/gkrellm-helium/Makefile b/misc/gkrellm-helium/Makefile
index 9130b361d31c..27f063b608bb 100644
--- a/misc/gkrellm-helium/Makefile
+++ b/misc/gkrellm-helium/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gkrellm-helium
-# Date Created: 19 Apr 2003
-# Whom: Pav Lucistnik <pav@oook.cz>
-#
+# Created by: Pav Lucistnik <pav@oook.cz>
# $FreeBSD$
-#
PORTNAME= gkrellm-helium
PORTVERSION= 2.3.1
@@ -19,6 +15,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkre
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+USES= pkgconfig
PLIST_FILES= libexec/gkrellm2/plugins/helium.so
CFLAGS+= -fPIC -I${LOCALBASE}/include
diff --git a/misc/gkrellm-xkb/Makefile b/misc/gkrellm-xkb/Makefile
index 92f20c42e611..831104827712 100644
--- a/misc/gkrellm-xkb/Makefile
+++ b/misc/gkrellm-xkb/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gkrellm-xkb
-# Date Created: Jun 24 2003
-# Whom: Pav Lucistnik <pav@oook.cz>
-#
+# Created by: Pav Lucistnik <pav@oook.cz>
# $FreeBSD$
-#
PORTNAME= gkrellm-xkb
PORTVERSION= 1.05
@@ -17,6 +13,7 @@ COMMENT= X keyboard layout plugin for GKrellM
BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+USES= pkgconfig
PLIST_FILES= libexec/gkrellm2/plugins/xkb.so
MAKE_ENV= PLUGIN_DIR=${PREFIX}/libexec/gkrellm2/plugins
ALL_TARGET= xkb.so
diff --git a/misc/gkrellmbgchg2/Makefile b/misc/gkrellmbgchg2/Makefile
index db41a3e3a79b..68bb3a46e03d 100644
--- a/misc/gkrellmbgchg2/Makefile
+++ b/misc/gkrellmbgchg2/Makefile
@@ -15,6 +15,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+USES= pkgconfig
USE_GNOME= gtk20
PLIST_FILES= libexec/gkrellm2/plugins/gkrellmbgchg.so
diff --git a/misc/gkrellmlaunch2/Makefile b/misc/gkrellmlaunch2/Makefile
index 80fccc82036e..874e1a91a18b 100644
--- a/misc/gkrellmlaunch2/Makefile
+++ b/misc/gkrellmlaunch2/Makefile
@@ -14,6 +14,7 @@ COMMENT= Application launcher plugin for GKrellM2
BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
+USES= pkgconfig
PLIST_FILES= libexec/gkrellm2/plugins/gkrellmlaunch.so
ALL_TARGET= ${PORTNAME}.so
diff --git a/misc/gkrellshoot2/Makefile b/misc/gkrellshoot2/Makefile
index 6ab4cc7b3c0c..5111de430622 100644
--- a/misc/gkrellshoot2/Makefile
+++ b/misc/gkrellshoot2/Makefile
@@ -15,6 +15,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkre
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2 \
import:${PORTSDIR}/graphics/ImageMagick
+USES= pkgconfig
PLIST_FILES= libexec/gkrellm2/plugins/gkrellshoot.so
WRKSRC= ${WRKDIR}/gkrellShoot-${PORTVERSION}
diff --git a/misc/gkrellweather2/Makefile b/misc/gkrellweather2/Makefile
index 68c57aea6170..14c579d2535e 100644
--- a/misc/gkrellweather2/Makefile
+++ b/misc/gkrellweather2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gkrellweather2
-# Date Created: 24 Nov 2002
-# Whom: Jean-Yves Lefort <jylefort@brutele.be>
-#
+# Created by: Jean-Yves Lefort <jylefort@brutele.be>
# $FreeBSD$
-#
PORTNAME= gkrellweather
PORTVERSION= 2.0.7
@@ -18,7 +14,7 @@ COMMENT= GKrellWeather is a weather plugin for GKrellM
BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
-USE_GMAKE= yes
+USES= gmake pkgconfig
ALL_TARGET= gkrellweather.so
MAKE_ENV= enable_nls=1 PTHREAD_LIBS=${PTHREAD_LIBS}