aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2018-04-13 17:29:09 +0800
committernetchild <netchild@FreeBSD.org>2018-04-13 17:29:09 +0800
commit8e921dee382473a404ce5e520732bcb1b811398b (patch)
treee7306265201f15f6e61c4f9e5dadbbb5f5432df6 /misc
parent4a7457f6a5dd59e8f823e3a139746219f60dd599 (diff)
downloadfreebsd-ports-gnome-8e921dee382473a404ce5e520732bcb1b811398b.tar.gz
freebsd-ports-gnome-8e921dee382473a404ce5e520732bcb1b811398b.tar.zst
freebsd-ports-gnome-8e921dee382473a404ce5e520732bcb1b811398b.zip
Add openhab2-addons.
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/openhab2-addons/Makefile34
-rw-r--r--misc/openhab2-addons/distinfo3
-rw-r--r--misc/openhab2-addons/pkg-descr3
4 files changed, 41 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 2817e30c36fb..22b120cd13ca 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -300,6 +300,7 @@
SUBDIR += ondir
SUBDIR += opencyc
SUBDIR += openhab2
+ SUBDIR += openhab2-addons
SUBDIR += openmvg
SUBDIR += openr2
SUBDIR += orville-write
diff --git a/misc/openhab2-addons/Makefile b/misc/openhab2-addons/Makefile
new file mode 100644
index 000000000000..59706ddbb478
--- /dev/null
+++ b/misc/openhab2-addons/Makefile
@@ -0,0 +1,34 @@
+# Created by: Alexander Leidinger
+# $FreeBSD$
+
+PORTNAME= openhab2-addons
+PORTVERSION= 2.2.0
+CATEGORIES= misc java
+MASTER_SITES= https://bintray.com/openhab/mvn/download_file?file_path=org%2Fopenhab%2Fdistro%2Fopenhab-addons%2F${PORTVERSION}/
+DISTNAME= openhab-addons-${PORTVERSION}
+EXTRACT_SUFX= .kar
+
+MAINTAINER= netchild@FreeBSD.org
+COMMENT= Addons for openhab2
+
+LICENSE= EPL
+
+RUN_DEPENDS= ${LOCALBASE}/libexec/openhab2/addons/README:misc/openhab2
+
+USERS= openhab
+GROUPS= openhab
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS="-v"
+EXTRACT_AFTER_ARGS="${EXTRACT_WRKDIR}"
+
+PLIST_FILES= libexec/openhab2/addons/openhab-addons-2.2.0.kar
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/openhab2
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/openhab2/addons
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${DISTNAME}${EXTRACT_SUFX} ${STAGEDIR}${PREFIX}/libexec/openhab2/addons/)
+
+.include <bsd.port.mk>
diff --git a/misc/openhab2-addons/distinfo b/misc/openhab2-addons/distinfo
new file mode 100644
index 000000000000..dd25741156ea
--- /dev/null
+++ b/misc/openhab2-addons/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1523474521
+SHA256 (openhab-addons-2.2.0.kar) = a7e6e8251489e64c22402973b550aa5436e8a23c38ab143e15a287bd32494206
+SIZE (openhab-addons-2.2.0.kar) = 145161902
diff --git a/misc/openhab2-addons/pkg-descr b/misc/openhab2-addons/pkg-descr
new file mode 100644
index 000000000000..bd522495b0ea
--- /dev/null
+++ b/misc/openhab2-addons/pkg-descr
@@ -0,0 +1,3 @@
+Addons for the openHAB msart-home software.
+
+WWW: http://www.openhab.org/