aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2008-03-06 20:58:20 +0800
committerwxs <wxs@FreeBSD.org>2008-03-06 20:58:20 +0800
commita092915722b8ea70dba2197b35a14ddae51b10c1 (patch)
treec343fa1a1b3426b085e65c7bd96de8f6859d722b /misc
parent2fc066fcb86db114880e3223b15321f561949adf (diff)
downloadfreebsd-ports-gnome-a092915722b8ea70dba2197b35a14ddae51b10c1.tar.gz
freebsd-ports-gnome-a092915722b8ea70dba2197b35a14ddae51b10c1.tar.zst
freebsd-ports-gnome-a092915722b8ea70dba2197b35a14ddae51b10c1.zip
A python script which allows you to use pastebin websites from the
command line. PR: ports/120955 Submitted by: comperr <comperr.extra@gmail.com> Approved by: garga (mentor)
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/pastebinit/Makefile29
-rw-r--r--misc/pastebinit/distinfo3
-rw-r--r--misc/pastebinit/pkg-descr3
4 files changed, 36 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 7356f17edee1..efa6c8110486 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -380,6 +380,7 @@
SUBDIR += p5-Tie-DxHash
SUBDIR += p5-Zen-Koans
SUBDIR += pantry
+ SUBDIR += pastebinit
SUBDIR += patanjali
SUBDIR += patchutils
SUBDIR += pauker
diff --git a/misc/pastebinit/Makefile b/misc/pastebinit/Makefile
new file mode 100644
index 000000000000..5c77a63c0c6b
--- /dev/null
+++ b/misc/pastebinit/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: pastebinit
+# Date created: Thu Feb 21 00:21:23 EST 2008
+# Whom: comperr <comperr.extra@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pastebinit
+PORTVERSION= 0.9
+CATEGORIES= misc python
+MASTER_SITES= http://www.stgraber.org/download/projects/pastebin/
+
+MAINTAINER= comperr.extra@gmail.com
+COMMENT= A command line utility for pastebing
+
+USE_PYTHON= yes
+
+NO_BUILD= yes
+
+PLIST_FILES= bin/pastebinit
+
+post-patch:
+ ${REINPLACE_CMD} -e 's#/usr/bin/python#${PYTHON_CMD}#' \
+ ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/misc/pastebinit/distinfo b/misc/pastebinit/distinfo
new file mode 100644
index 000000000000..7e5cdb3f6744
--- /dev/null
+++ b/misc/pastebinit/distinfo
@@ -0,0 +1,3 @@
+MD5 (pastebinit-0.9.tar.gz) = 16c3e6ae00cf689465a4fde2d3b20757
+SHA256 (pastebinit-0.9.tar.gz) = e437880db7811727c9330b1947a27ab9df1ae01fe22e3ad8ed35db45b99250ec
+SIZE (pastebinit-0.9.tar.gz) = 12645
diff --git a/misc/pastebinit/pkg-descr b/misc/pastebinit/pkg-descr
new file mode 100644
index 000000000000..c0668da1249b
--- /dev/null
+++ b/misc/pastebinit/pkg-descr
@@ -0,0 +1,3 @@
+A command line pastebin utility.
+
+WWW: http://www.stgraber.org/download/projects/pastebin/