aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-10-27 16:49:51 +0800
committerpav <pav@FreeBSD.org>2005-10-27 16:49:51 +0800
commitbec36aec4e9ac3ee2c5e74e78f25aba08b892a14 (patch)
treea82837c53ac9d28511df2491671b696a3eb8d94f /misc
parent564bf9a9ea929501ef04dcde4237bfdb6033b348 (diff)
downloadfreebsd-ports-gnome-bec36aec4e9ac3ee2c5e74e78f25aba08b892a14.tar.gz
freebsd-ports-gnome-bec36aec4e9ac3ee2c5e74e78f25aba08b892a14.tar.zst
freebsd-ports-gnome-bec36aec4e9ac3ee2c5e74e78f25aba08b892a14.zip
- Use fetch(1) instead of wget
Submitted by: Yarema <yds@CoolRat.org>
Diffstat (limited to 'misc')
-rw-r--r--misc/gkrellweather2/Makefile2
-rw-r--r--misc/gkrellweather2/files/patch-GrabWeather18
2 files changed, 19 insertions, 1 deletions
diff --git a/misc/gkrellweather2/Makefile b/misc/gkrellweather2/Makefile
index 1df659f7de57..02bae7b94d04 100644
--- a/misc/gkrellweather2/Makefile
+++ b/misc/gkrellweather2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gkrellweather
PORTVERSION= 2.0.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc
MASTER_SITES= http://kmlinux.fjfi.cvut.cz/~makovick/gkrellm/
EXTRACT_SUFX= .tgz
diff --git a/misc/gkrellweather2/files/patch-GrabWeather b/misc/gkrellweather2/files/patch-GrabWeather
new file mode 100644
index 000000000000..aa1cdc3c8b22
--- /dev/null
+++ b/misc/gkrellweather2/files/patch-GrabWeather
@@ -0,0 +1,18 @@
+--- GrabWeather.orig Sun Feb 27 08:54:47 2005
++++ GrabWeather Sun Feb 27 08:54:47 2005
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl
++#!/usr/bin/env perl
+
+ #
+ # Grabs the latest local weather conditions from the
+@@ -40,8 +40,7 @@
+ # Is LWP installed?
+ eval { require LWP::UserAgent };
+ if ($@) {
+- my $cmd = qq{wget --proxy=off --passive-ftp --tries=0 --quiet } .
+- qq{--output-document=$home/$ReportDir/$HTMLFileName $URL};
++ my $cmd = qq{fetch -d -p -1 -q -o $home/$ReportDir/$HTMLFileName $URL};
+ `$cmd` == 0 or die "unable to fetch weather: $?";
+ } else {
+ $ENV{FTP_PASSIVE} = 1; # LWP uses Net::FTP internally.