aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-09-24 00:45:35 +0800
committerbapt <bapt@FreeBSD.org>2014-09-24 00:45:35 +0800
commitd9d0423b4f035aed62096cedbca8d218206d6f65 (patch)
tree7bca8025361a679ac757241a16b366bc0766debf /misc
parent1e6952bbb33c8148c39252655033f15a60d85e86 (diff)
downloadfreebsd-ports-gnome-d9d0423b4f035aed62096cedbca8d218206d6f65.tar.gz
freebsd-ports-gnome-d9d0423b4f035aed62096cedbca8d218206d6f65.tar.zst
freebsd-ports-gnome-d9d0423b4f035aed62096cedbca8d218206d6f65.zip
Convert to USES=pear
Diffstat (limited to 'misc')
-rw-r--r--misc/pear-Services_Weather/Makefile34
-rw-r--r--misc/pear-Text_Figlet/Makefile9
2 files changed, 9 insertions, 34 deletions
diff --git a/misc/pear-Services_Weather/Makefile b/misc/pear-Services_Weather/Makefile
index 203b9fd23d8b..7d23833bd03e 100644
--- a/misc/pear-Services_Weather/Makefile
+++ b/misc/pear-Services_Weather/Makefile
@@ -9,13 +9,10 @@ CATEGORIES= misc www pear geography
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR interface to various online weather-services
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS:= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
+RUN_DEPENDS= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
USE_PHP= ctype pcre
-LATEST_LINK= pear-Services_Weather
OPTIONS_DEFINE= PEAR_NET_FTP PEAR_CACHE PEAR_DB PEAR_SOAP PEAR_XML_SERIALIZER
PEAR_NET_FTP_DESC= PEAR::Net::FTP support
PEAR_CACHE_DESC= PEAR::Cache support
@@ -23,29 +20,12 @@ PEAR_DB_DESC= PEAR::DB support
PEAR_SOAP_DESC= PEAR::SOAP support
PEAR_XML_SERIALIZER_DESC= PEAR::XML::Serializer support
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.options.mk>
+PEAR_NET_FTP_BUILD_DEPENDS= ${PEARDIR}/Net/FTP.php:${PORTSDIR}/ftp/pear-Net_FTP
+PEAR_CACHE_BUILD_DEPENDS= ${PEARDIR}/Cache.php:${PORTSDIR}/sysutils/pear-Cache
+PEAR_DB_BUILD_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+PEAR_SOAP_BUILD_DEPENDS= ${PEARDIR}/SOAP/Base.php:${PORTSDIR}/net/pear-SOAP
+PEAR_XML_SERIALIZER_BUILD_DEPENDS= ${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer
-.if ${PORT_OPTIONS:MPEAR_NET_FTP}
-BUILD_DEPENDS+= ${PEARDIR}/Net/FTP.php:${PORTSDIR}/ftp/pear-Net_FTP
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_CACHE}
-BUILD_DEPENDS+= ${PEARDIR}/Cache.php:${PORTSDIR}/sysutils/pear-Cache
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_DB}
-BUILD_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_SOAP}
-BUILD_DEPENDS+= ${PEARDIR}/SOAP/Base.php:${PORTSDIR}/net/pear-SOAP
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_XML_SERIALIZER}
-BUILD_DEPENDS+= ${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer
-.endif
-
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.mk>
diff --git a/misc/pear-Text_Figlet/Makefile b/misc/pear-Text_Figlet/Makefile
index bb146cc13027..826ba2c76db3 100644
--- a/misc/pear-Text_Figlet/Makefile
+++ b/misc/pear-Text_Figlet/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= misc www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Render text using FIGlet fonts
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>