aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-06-18 08:37:52 +0800
committeryuri <yuri@FreeBSD.org>2018-06-18 08:37:52 +0800
commite470e5499228231abdbe81fc47f3094c6ada380d (patch)
tree3f36c17af9461d4a1ec553910d5ed727708661f4 /misc
parent19ce19fcaa9139aa6c9cc917b7e62ac2576d5e3f (diff)
downloadfreebsd-ports-gnome-e470e5499228231abdbe81fc47f3094c6ada380d.tar.gz
freebsd-ports-gnome-e470e5499228231abdbe81fc47f3094c6ada380d.tar.zst
freebsd-ports-gnome-e470e5499228231abdbe81fc47f3094c6ada380d.zip
New port: misc/urh: Universal Radio Hacker: investigate wireless protocols like a boss
Diffstat (limited to 'misc')
-rw-r--r--misc/urh/Makefile33
-rw-r--r--misc/urh/distinfo3
-rw-r--r--misc/urh/pkg-descr21
3 files changed, 57 insertions, 0 deletions
diff --git a/misc/urh/Makefile b/misc/urh/Makefile
new file mode 100644
index 000000000000..165a36245989
--- /dev/null
+++ b/misc/urh/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= urh
+DISTVERSION= 2.1.1
+CATEGORIES= misc python
+MASTER_SITES= CHEESESHOP
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Universal Radio Hacker: investigate wireless protocols like a boss
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${PYNUMPY}
+LIB_DEPENDS= libomp.so:devel/openmp
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}psutil>0:sysutils/py-psutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyzmq>0:net/py-pyzmq@${PY_FLAVOR}
+
+USES= fortran python:3.4+ localbase pyqt:5
+USE_PYQT= core gui test widgets
+USE_PYTHON= distutils autoplist
+
+PLIST_FILES= bin/urh.shadow
+
+post-install:
+ @${MV} ${STAGEDIR}${PREFIX}/bin/urh ${STAGEDIR}${PREFIX}/bin/urh.shadow
+ @(echo "#!/bin/sh"; \
+ echo ""; \
+ echo "LD_PRELOAD=${PREFIX}/lib/gcc6/libgcc_s.so ${PREFIX}/bin/urh.shadow \"$$@\"" \
+ ) > ${STAGEDIR}${PREFIX}/bin/urh
+ @${CHMOD} +x ${STAGEDIR}${PREFIX}/bin/urh
+
+.include <bsd.port.mk>
diff --git a/misc/urh/distinfo b/misc/urh/distinfo
new file mode 100644
index 000000000000..ebd46e04224e
--- /dev/null
+++ b/misc/urh/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1529279220
+SHA256 (urh-2.1.1.tar.gz) = fd66d3f3c054eb9ebef62425cc5289627b93b19e3d9cd155ed02866660c06228
+SIZE (urh-2.1.1.tar.gz) = 2904518
diff --git a/misc/urh/pkg-descr b/misc/urh/pkg-descr
new file mode 100644
index 000000000000..69aa658d961b
--- /dev/null
+++ b/misc/urh/pkg-descr
@@ -0,0 +1,21 @@
+The Universal Radio Hacker (URH) is a software for investigating unknown
+wireless protocols.
+
+Features include:
+* hardware interfaces for common Software Defined Radios
+* easy demodulation of signals
+* assigning participants to keep overview of your data
+* customizable decodings to crack even sophisticated encodings like CC1101
+ data whitening
+* assign labels to reveal the logic of the protocol
+* fuzzing component to find security leaks
+* modulation support to inject the data back into the system
+* simulation environment to perform stateful attacks
+
+In order to use this software, you need SDR hardware, for example
+* HackRF One (can send and receive on frequencies 1 MHz to 6 GHz)
+* SDRplay RSP2pro (can receive on frequencies 1 kHz to 2 GHz)
+
+See the user guide: https://github.com/jopohl/urh/raw/master/data/userguide.pdf
+
+WWW: https://github.com/jopohl/urh