aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /misc
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'misc')
-rw-r--r--misc/cdcollect/Makefile3
-rw-r--r--misc/demoniac/Makefile4
-rw-r--r--misc/display/Makefile2
-rw-r--r--misc/findutils/Makefile4
-rw-r--r--misc/getopt/Makefile2
-rw-r--r--misc/gnome-icon-theme-extras/Makefile4
-rw-r--r--misc/gnome-icon-theme/Makefile4
-rw-r--r--misc/gnome-mime-data/Makefile4
-rw-r--r--misc/gnome-osd/Makefile5
-rw-r--r--misc/gregexp/Makefile4
-rw-r--r--misc/gtktalog/Makefile4
-rw-r--r--misc/hello/Makefile2
-rw-r--r--misc/kcd/Makefile4
-rw-r--r--misc/lingoteach/Makefile3
-rw-r--r--misc/linm/Makefile2
-rw-r--r--misc/mc-light/Makefile2
-rw-r--r--misc/mc/Makefile3
-rw-r--r--misc/metalink-tools/Makefile6
-rw-r--r--misc/misterproper/Makefile4
-rw-r--r--misc/pinfo/Makefile4
-rw-r--r--misc/podsleuth/Makefile2
-rw-r--r--misc/quick-lounge-applet/Makefile4
-rw-r--r--misc/shared-mime-info/Makefile2
-rw-r--r--misc/terraform/Makefile5
-rw-r--r--misc/toilet/Makefile4
-rw-r--r--misc/uf-view/Makefile4
-rw-r--r--misc/wmcalendar/Makefile4
-rw-r--r--misc/wmpal/Makefile4
-rw-r--r--misc/wmwork/Makefile1
-rw-r--r--misc/xbiso/Makefile4
-rw-r--r--misc/xsw/Makefile4
31 files changed, 53 insertions, 55 deletions
diff --git a/misc/cdcollect/Makefile b/misc/cdcollect/Makefile
index d689757819b2..de118d4a449b 100644
--- a/misc/cdcollect/Makefile
+++ b/misc/cdcollect/Makefile
@@ -23,7 +23,8 @@ USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack libgnome gnomesharp20
GCONF_SCHEMAS= cdcollect.schemas
USE_GETTEXT= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
post-extract:
${REINPLACE_CMD} -e 's,SqliteClient,Sqlite,' \
diff --git a/misc/demoniac/Makefile b/misc/demoniac/Makefile
index 8d4d7da77f0d..72c7fcb0b942 100644
--- a/misc/demoniac/Makefile
+++ b/misc/demoniac/Makefile
@@ -20,8 +20,8 @@ LIB_DEPENDS= gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
USE_GL= yes
USE_GNOME= gtk12
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" \
- LDFLAGS="${PTHREAD_LIBS}"
+CPPFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
PLIST_FILES= bin/demoniac share/demoniac/pixmaps/logo.xpm
PLIST_DIRS= share/demoniac/pixmaps share/demoniac
diff --git a/misc/display/Makefile b/misc/display/Makefile
index d8d923d47c94..2ce4709a7de2 100644
--- a/misc/display/Makefile
+++ b/misc/display/Makefile
@@ -28,7 +28,7 @@ CONFLICTS= ImageMagick-[0-9]* goblin-*
.endif
CONFIGURE_ARGS+= --program-prefix=${DISPLAY_PROGRAM_PREFIX}
-CONFIGURE_ENV+= LDFLAGS="${STRIP}"
+LDFLAGS+= ${STRIP}
MAN1= ${DISPLAY_PROGRAM_PREFIX}display.1
PLIST_FILES= bin/${DISPLAY_PROGRAM_PREFIX}display
diff --git a/misc/findutils/Makefile b/misc/findutils/Makefile
index fa0391cc5358..54b833f4fc77 100644
--- a/misc/findutils/Makefile
+++ b/misc/findutils/Makefile
@@ -19,8 +19,8 @@ COMMENT= The GNU find utilities
SIG_FILES= ${DISTNAME}${EXTRACT_SUFX}.sig
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
USE_GMAKE= yes
diff --git a/misc/getopt/Makefile b/misc/getopt/Makefile
index bd4df4baafdc..a97dc61a277c 100644
--- a/misc/getopt/Makefile
+++ b/misc/getopt/Makefile
@@ -19,7 +19,7 @@ USE_GMAKE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-MAKE_ENV= LIBCGETOPT=0 LDFLAGS="${LDFLAGS}"
+MAKE_ENV= LIBCGETOPT=0
MAN1= getopt.1
DOCS= Changelog README
diff --git a/misc/gnome-icon-theme-extras/Makefile b/misc/gnome-icon-theme-extras/Makefile
index 95e7f63f08ed..edce4e7ed480 100644
--- a/misc/gnome-icon-theme-extras/Makefile
+++ b/misc/gnome-icon-theme-extras/Makefile
@@ -24,7 +24,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomehack intlhack gtk20
INSTALLS_ICONS= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.mk>
diff --git a/misc/gnome-icon-theme/Makefile b/misc/gnome-icon-theme/Makefile
index f300e4ff1330..3933a9d68f45 100644
--- a/misc/gnome-icon-theme/Makefile
+++ b/misc/gnome-icon-theme/Makefile
@@ -25,7 +25,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomehack intlhack gtk20
INSTALLS_ICONS= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.mk>
diff --git a/misc/gnome-mime-data/Makefile b/misc/gnome-mime-data/Makefile
index 12d033ff684d..f2ae701a85aa 100644
--- a/misc/gnome-mime-data/Makefile
+++ b/misc/gnome-mime-data/Makefile
@@ -21,8 +21,8 @@ USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack pkgconfig
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lintl"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -lintl"
+CPPFLAGS+= -I${LOCALBASE}/include
post-patch:
@${REINPLACE_CMD} -e 's|[(]datadir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
diff --git a/misc/gnome-osd/Makefile b/misc/gnome-osd/Makefile
index 9b3b3975f276..35ec178e1325 100644
--- a/misc/gnome-osd/Makefile
+++ b/misc/gnome-osd/Makefile
@@ -18,14 +18,13 @@ USE_GNOME= gnomehack gnomeprefix intlhack pygnome2
USE_PYTHON= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
GCONF_SCHEMAS= gnome-osd.schemas
MAN1= gnome-osd-client.1
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
post-install:
.if !defined(NOPORTDOCS)
diff --git a/misc/gregexp/Makefile b/misc/gregexp/Makefile
index 54041edd7102..b28c9eb4255c 100644
--- a/misc/gregexp/Makefile
+++ b/misc/gregexp/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
USE_GNOME= gnomeprefix libgnomeui
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.mk>
diff --git a/misc/gtktalog/Makefile b/misc/gtktalog/Makefile
index 1f2e8d880324..836d4a43c79e 100644
--- a/misc/gtktalog/Makefile
+++ b/misc/gtktalog/Makefile
@@ -21,8 +21,8 @@ RUN_DEPENDS= plaympeg:${PORTSDIR}/multimedia/smpeg
USE_BZIP2= yes
USE_GNOME= gnomehack gnomelibs gnomeprefix
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= gtktalog.1
diff --git a/misc/hello/Makefile b/misc/hello/Makefile
index a3c341f628ef..9ad29c4a3c3d 100644
--- a/misc/hello/Makefile
+++ b/misc/hello/Makefile
@@ -25,8 +25,6 @@ USE_GETTEXT= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
- LDFLAGS="${LDFLAGS}"
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+= --disable-nls
diff --git a/misc/kcd/Makefile b/misc/kcd/Makefile
index a62fd1ca48dc..82dffad6732f 100644
--- a/misc/kcd/Makefile
+++ b/misc/kcd/Makefile
@@ -20,8 +20,8 @@ USE_GETTEXT= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lintl
MAN1= kcd.1
diff --git a/misc/lingoteach/Makefile b/misc/lingoteach/Makefile
index 50de493d65ae..24a91120d46f 100644
--- a/misc/lingoteach/Makefile
+++ b/misc/lingoteach/Makefile
@@ -26,7 +26,8 @@ USE_GNOME= gtk20
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
# sound version
SOUNDV= 0.3.9
diff --git a/misc/linm/Makefile b/misc/linm/Makefile
index 0ff57e44a9c3..8214f604e262 100644
--- a/misc/linm/Makefile
+++ b/misc/linm/Makefile
@@ -24,7 +24,7 @@ USE_OPENSSL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
# does not work now
#.if defined(WITHOUT_NLS)
#CONFIGURE_ARGS+=--disable-nls
diff --git a/misc/mc-light/Makefile b/misc/mc-light/Makefile
index 64aee125f1b3..e75c679da0e3 100644
--- a/misc/mc-light/Makefile
+++ b/misc/mc-light/Makefile
@@ -52,7 +52,7 @@ PLIST_SUB+= NLS="@comment "
.endif
.if defined(WITH_MC_IN_MC)
-CONFIGURE_ENV+= CPPFLAGS=-DMC_IN_MC_ALLOWED
+CPPFLAGS+= -DMC_IN_MC_ALLOWED
.endif
post-install:
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index e127e285bcb0..24245cf37ef7 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -61,7 +61,8 @@ PLIST_SUB= CHARSETS="@comment "
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.else
-CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
_MANLANG= es hu it pl ru sr
diff --git a/misc/metalink-tools/Makefile b/misc/metalink-tools/Makefile
index 68c8936d8d1c..ff4d28bc222c 100644
--- a/misc/metalink-tools/Makefile
+++ b/misc/metalink-tools/Makefile
@@ -25,9 +25,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USE_GNOME= glib20
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= AWK="${AWK}" \
- CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+CONFIGURE_ENV+= AWK="${AWK}"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_SAFE= yes
# Documents to install
diff --git a/misc/misterproper/Makefile b/misc/misterproper/Makefile
index 4d542cad1511..f63b7f9b6eb9 100644
--- a/misc/misterproper/Makefile
+++ b/misc/misterproper/Makefile
@@ -18,7 +18,7 @@ COMMENT= A GNOME application designed to manage cyclic tasks
USE_GNOME= gnomehack gnomelibs gnomeprefix
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.mk>
diff --git a/misc/pinfo/Makefile b/misc/pinfo/Makefile
index bf3daee5fd5d..60f434444a7f 100644
--- a/misc/pinfo/Makefile
+++ b/misc/pinfo/Makefile
@@ -15,8 +15,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Ncurses based, lynx style info documentation browser
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-readline \
--with-localedir=${PREFIX}/share/locale
diff --git a/misc/podsleuth/Makefile b/misc/podsleuth/Makefile
index 20cc6220a821..0178d28e21cb 100644
--- a/misc/podsleuth/Makefile
+++ b/misc/podsleuth/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/mono:${PORTSDIR}/lang/mono \
${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-1.0.pc:${PORTSDIR}/devel/ndesk-dbus
CONFIGURE_ARGS+=--with-hal-callouts-dir=${PREFIX}/libexec
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
+LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gnomehack pkgconfig
diff --git a/misc/quick-lounge-applet/Makefile b/misc/quick-lounge-applet/Makefile
index 9e5eede931dd..6cdce6b2436e 100644
--- a/misc/quick-lounge-applet/Makefile
+++ b/misc/quick-lounge-applet/Makefile
@@ -21,8 +21,8 @@ INSTALLS_ICONS= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack gnomepanel
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
GCONF_SCHEMAS= quick-lounge.schemas
diff --git a/misc/shared-mime-info/Makefile b/misc/shared-mime-info/Makefile
index 33a409b67519..56944c218531 100644
--- a/misc/shared-mime-info/Makefile
+++ b/misc/shared-mime-info/Makefile
@@ -20,7 +20,7 @@ USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= glib20 libxml2 intltool gnomehack intlhack
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
MAN1= update-mime-database.1
diff --git a/misc/terraform/Makefile b/misc/terraform/Makefile
index 9b36a1693c88..16dd88b21514 100644
--- a/misc/terraform/Makefile
+++ b/misc/terraform/Makefile
@@ -28,11 +28,10 @@ USE_GETTEXT= yes
USE_GMAKE= yes
USE_AUTOTOOLS= automake:env
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
MAKE_JOBS_SAFE= yes
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS/s| desktop-links docs | |' \
diff --git a/misc/toilet/Makefile b/misc/toilet/Makefile
index 7ee41ba7bb65..d2407fbf414e 100644
--- a/misc/toilet/Makefile
+++ b/misc/toilet/Makefile
@@ -17,8 +17,8 @@ LIB_DEPENDS= caca.0:${PORTSDIR}/graphics/libcaca
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-transform-name=""
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -fno-strength-reduce
MAN1= ${PORTNAME}.1
PORT_VERBS= ${PORTNAME} caca2tlf share/figlet/*tlf
diff --git a/misc/uf-view/Makefile b/misc/uf-view/Makefile
index 837e5c88a95f..374758782083 100644
--- a/misc/uf-view/Makefile
+++ b/misc/uf-view/Makefile
@@ -17,8 +17,8 @@ COMMENT= A gTK+ viewer for the User Friendly and several other popular comics
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomehier gnomevfs2 gnomedesktop libgnomeui
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
pre-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
diff --git a/misc/wmcalendar/Makefile b/misc/wmcalendar/Makefile
index 9018f80b87c5..e012c4b233a5 100644
--- a/misc/wmcalendar/Makefile
+++ b/misc/wmcalendar/Makefile
@@ -26,8 +26,8 @@ MAKE_ARGS= CC="${CC}" \
INCDIR="`pkg-config --cflags gtk+-2.0` -I${LOCALBASE}/include" \
LIBDIR="" \
LIBS="-lical -lXpm"
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= wmCalendar.1
PLIST_FILES= bin/wmCalendar
diff --git a/misc/wmpal/Makefile b/misc/wmpal/Makefile
index 0a2dcfd95c8f..a60b23906ad6 100644
--- a/misc/wmpal/Makefile
+++ b/misc/wmpal/Makefile
@@ -15,8 +15,8 @@ COMMENT= A one of the most useless dockapps in the world
USE_XORG= xpm
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= README
PLIST_FILES= bin/wmpal
diff --git a/misc/wmwork/Makefile b/misc/wmwork/Makefile
index b4f2183b4ce9..231d64e35712 100644
--- a/misc/wmwork/Makefile
+++ b/misc/wmwork/Makefile
@@ -21,7 +21,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
USE_XORG= xpm
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= wmwork.1
PLIST_FILES= bin/wmwork
diff --git a/misc/xbiso/Makefile b/misc/xbiso/Makefile
index 03649e5984ff..8405ac312d25 100644
--- a/misc/xbiso/Makefile
+++ b/misc/xbiso/Makefile
@@ -17,8 +17,8 @@ COMMENT= XBox xdvdfs iso extraction utility
LIB_DEPENDS= ftp.3:${PORTSDIR}/ftp/ftplib
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/xbiso
diff --git a/misc/xsw/Makefile b/misc/xsw/Makefile
index ce553b44b33d..1d2a4f3d45b8 100644
--- a/misc/xsw/Makefile
+++ b/misc/xsw/Makefile
@@ -21,8 +21,8 @@ USE_SDL= sdl ttf image gfx
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPLAGS="${CPPPLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.if !defined(NO_INSTALL_MANPAGES)
MAN1= xsw.1 \