aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2018-08-31 15:24:05 +0800
committerjhale <jhale@FreeBSD.org>2018-08-31 15:24:05 +0800
commiteade5353cfcedecb68e5ee5cd99a5dd1468291c6 (patch)
tree87738d0b30f00c731970e3bfa3aaf0d7e08412d2 /misc
parente913e29eb60eab0442b6a6f884ede95642fc2e43 (diff)
downloadfreebsd-ports-gnome-eade5353cfcedecb68e5ee5cd99a5dd1468291c6.tar.gz
freebsd-ports-gnome-eade5353cfcedecb68e5ee5cd99a5dd1468291c6.tar.zst
freebsd-ports-gnome-eade5353cfcedecb68e5ee5cd99a5dd1468291c6.zip
Fix build with Qt 5.11 [1]
While here, remove CRLF from all installed text files (I had to change DOS2UNIX_FILES anyways to make a clean patch) [2] Bump PORTREVISION so that the UNIX-style text files are installed PR: 230884 [1] Approved by: portmgr (blanket - trivial runtime fix) [2]
Diffstat (limited to 'misc')
-rw-r--r--misc/crosti/Makefile3
-rw-r--r--misc/crosti/files/patch-src_usrhcpp_mainwindow.h12
2 files changed, 14 insertions, 1 deletions
diff --git a/misc/crosti/Makefile b/misc/crosti/Makefile
index c61a611d8d50..d345d728fc58 100644
--- a/misc/crosti/Makefile
+++ b/misc/crosti/Makefile
@@ -3,6 +3,7 @@
PORTNAME= crosti
DISTVERSION= 1.13.3
DISTVERSIONSUFFIX= -source
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= SF/crosti/crosti%20${DISTVERSION}/
@@ -15,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/gpl.txt
USES= desktop-file-utils dos2unix qmake qt:5 shared-mime-info zip
USE_GL= gl
USE_QT= concurrent core gui printsupport svg widgets buildtools_build
-DOS2UNIX_FILES= ${PORTNAME}.pro
+DOS2UNIX_GLOB= *.cpp *.csc *.h *.pro *.txt *.xml
NO_WRKSUBDIR= yes
.include <bsd.port.mk>
diff --git a/misc/crosti/files/patch-src_usrhcpp_mainwindow.h b/misc/crosti/files/patch-src_usrhcpp_mainwindow.h
new file mode 100644
index 000000000000..b77185ad8048
--- /dev/null
+++ b/misc/crosti/files/patch-src_usrhcpp_mainwindow.h
@@ -0,0 +1,12 @@
+Fix build with Qt 5.11
+
+--- src/usrhcpp/mainwindow.h.orig 2018-08-31 06:10:35 UTC
++++ src/usrhcpp/mainwindow.h
+@@ -40,6 +40,7 @@ along with crosti. If not, see <http://www.gnu.org/li
+ #include <QPrinter>
+ #endif
+
++#include <QActionGroup>
+ #include <QFileInfo>
+
+ class CMiniMap;