aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authortabthorpe <tabthorpe@FreeBSD.org>2009-09-29 02:01:54 +0800
committertabthorpe <tabthorpe@FreeBSD.org>2009-09-29 02:01:54 +0800
commitf326dc38ef7e2a14686b9381a381f81e6af2ff68 (patch)
treece310383ffe9630723d3cbd7e4b57aa5e7ade031 /misc
parent9ff98d76ab1da78d9bb84440288f3048f7b780a5 (diff)
downloadfreebsd-ports-gnome-f326dc38ef7e2a14686b9381a381f81e6af2ff68.tar.gz
freebsd-ports-gnome-f326dc38ef7e2a14686b9381a381f81e6af2ff68.tar.zst
freebsd-ports-gnome-f326dc38ef7e2a14686b9381a381f81e6af2ff68.zip
- Switch to libxul
- Bump PORTREVISION Requested by: gecko@ via beat Feature safe: yes
Diffstat (limited to 'misc')
-rw-r--r--misc/xiphos/Makefile14
-rw-r--r--misc/xiphos/files/patch-src__gecko__gecko-utils.cpp13
2 files changed, 21 insertions, 6 deletions
diff --git a/misc/xiphos/Makefile b/misc/xiphos/Makefile
index 72051a9256d2..200b96275c63 100644
--- a/misc/xiphos/Makefile
+++ b/misc/xiphos/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xiphos
PORTVERSION= 3.1.1
+PORTREVISION= 1
CATEGORIES= misc gnome
MASTER_SITES= SF/gnomesword/Xiphos/${PORTVERSION}
@@ -27,22 +28,23 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS+= --disable-maintainer-mode --enable-paratab
-OPTIONS= XULRUNNER "Build with xulrunner (default)" off \
+OPTIONS= LIBXUL "Build with libxul (default)" off \
GTKHTML "Build with gtkhtml" off
.include <bsd.port.pre.mk>
-.if defined(WITH_XULRUNNER) && defined(WITH_GTKHTML)
-IGNORE= choose only one of XULRUNNER or GTKHTML
+.if defined(WITH_LIBXUL) && defined(WITH_GTKHTML)
+IGNORE= choose only one of LIBXUL or GTKHTML
.endif
-.if defined(WITH_GTKHTML) || defined(WITHOUT_XULRUNNER)
+.if defined(WITH_GTKHTML) || defined(WITHOUT_LIBXUL)
CONFIGURE_ARGS+= --enable-gtkhtml --disable-gecko
.endif
-.if !defined(WITHOUT_XULRUNNER) || !defined(WITH_GTKHTML)
-USE_GECKO= xulrunner
+.if !defined(WITHOUT_LIBXUL) || !defined(WITH_GTKHTML)
+USE_GECKO= libxul
CONFIGURE_ARGS+= --with-gecko=${GECKO} --disable-gtkhtml
+GTKHTML_CFLAGS+="-DXPCOM_GLUE"
.endif
.include <bsd.port.post.mk>
diff --git a/misc/xiphos/files/patch-src__gecko__gecko-utils.cpp b/misc/xiphos/files/patch-src__gecko__gecko-utils.cpp
new file mode 100644
index 000000000000..31e4f3216306
--- /dev/null
+++ b/misc/xiphos/files/patch-src__gecko__gecko-utils.cpp
@@ -0,0 +1,13 @@
+--- ./src/gecko/gecko-utils.cpp.orig 2009-08-09 18:52:26.000000000 -0400
++++ ./src/gecko/gecko-utils.cpp 2009-09-28 13:36:48.000000000 -0400
+@@ -38,10 +38,6 @@
+ # undef NS_EXPORT_
+ #endif
+
+-#ifdef HAVE_GECKO_1_9
+-#include <gtkmozembed_glue.cpp>
+-#endif
+-
+ #include <gtkmozembed.h>
+ #include <gtkmozembed_internal.h>
+ #include <nsCOMPtr.h>