aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2005-11-05 10:51:21 +0800
committerlofi <lofi@FreeBSD.org>2005-11-05 10:51:21 +0800
commitf3e29ba44935cd6ce4ae60f5c059e69c6c25619c (patch)
tree94da184cb1e17b9880bebcb8379fd90af45fb35e /misc
parentc25d88ffc838644a5731b4ff6e025a6b6fcc5952 (diff)
downloadfreebsd-ports-gnome-f3e29ba44935cd6ce4ae60f5c059e69c6c25619c.tar.gz
freebsd-ports-gnome-f3e29ba44935cd6ce4ae60f5c059e69c6c25619c.tar.zst
freebsd-ports-gnome-f3e29ba44935cd6ce4ae60f5c059e69c6c25619c.zip
Make PREFIX-safe.
Diffstat (limited to 'misc')
-rw-r--r--misc/kdeedu3/Makefile7
-rw-r--r--misc/kdeedu4/Makefile7
2 files changed, 14 insertions, 0 deletions
diff --git a/misc/kdeedu3/Makefile b/misc/kdeedu3/Makefile
index 28284dbc46a7..f53f5fa42e75 100644
--- a/misc/kdeedu3/Makefile
+++ b/misc/kdeedu3/Makefile
@@ -41,4 +41,11 @@ CONFIGURE_ARGS+=--disable-kig-python-scripting
PLIST_SUB+= BOOST_PYTHON="@comment "
.endif
+PYTHON_LIBDIR!= ${LOCALBASE}/bin/python -c 'import sys;print sys.prefix'
+
+pre-configure:
+ ${REINPLACE_CMD} \
+ -e 's|pylibdir in.*|pylibdir in "${PYTHON_LIBDIR}/lib" \\|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.post.mk>
diff --git a/misc/kdeedu4/Makefile b/misc/kdeedu4/Makefile
index 28284dbc46a7..f53f5fa42e75 100644
--- a/misc/kdeedu4/Makefile
+++ b/misc/kdeedu4/Makefile
@@ -41,4 +41,11 @@ CONFIGURE_ARGS+=--disable-kig-python-scripting
PLIST_SUB+= BOOST_PYTHON="@comment "
.endif
+PYTHON_LIBDIR!= ${LOCALBASE}/bin/python -c 'import sys;print sys.prefix'
+
+pre-configure:
+ ${REINPLACE_CMD} \
+ -e 's|pylibdir in.*|pylibdir in "${PYTHON_LIBDIR}/lib" \\|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.post.mk>