aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorrse <rse@FreeBSD.org>2004-11-10 03:44:14 +0800
committerrse <rse@FreeBSD.org>2004-11-10 03:44:14 +0800
commitf92e3489c174ecd46c15d1fe1b9d5f57f5817dd8 (patch)
tree7f36eacc38941631e1131e1090a282550c02535c /misc
parentd3cba5b94c7c7e08a7c9707e358e6d33c953950c (diff)
downloadfreebsd-ports-gnome-f92e3489c174ecd46c15d1fe1b9d5f57f5817dd8.tar.gz
freebsd-ports-gnome-f92e3489c174ecd46c15d1fe1b9d5f57f5817dd8.tar.zst
freebsd-ports-gnome-f92e3489c174ecd46c15d1fe1b9d5f57f5817dd8.zip
- portlint: reduces COMMENT to less than 70 chars
- build Perl API no longer by default (but allow WITH_PERL to enable it) - IGNORE package on WITH_PERL and installed Perl is not 5.8.0 or higher
Diffstat (limited to 'misc')
-rw-r--r--misc/ossp-uuid/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/misc/ossp-uuid/Makefile b/misc/ossp-uuid/Makefile
index 9f4c8327b300..117b8c41563b 100644
--- a/misc/ossp-uuid/Makefile
+++ b/misc/ossp-uuid/Makefile
@@ -13,7 +13,7 @@ MASTER_SITE_SUBDIR= lib/${PORTNAME}
PKGNAMEPREFIX= ossp-
MAINTAINER= ports@FreeBSD.org
-COMMENT= An ISO-C & Perl API and CLI for generating Universally Unique Identifiers (UUID)
+COMMENT= ISO-C & Perl API and CLI for generating Universally Unique Identifiers
CONFLICTS= e2fsprogs-[0-9]*
@@ -24,7 +24,7 @@ CONFIGURE_ARGS+= --disable-shared --enable-static
MAN1= uuid-config.1 uuid.1
MAN3= uuid.3
-.if !defined(WITHOUT_PERL)
+.if defined(WITH_PERL)
USE_PERL5= yes
CONFIGURE_ENV+= PERL=${PERL5}
CONFIGURE_ARGS+= --with-perl
@@ -38,4 +38,10 @@ PLIST_SUB+= WITH_PERL='@comment '
test:
cd ${WRKSRC}; ${MAKE} check
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PERL) && ${PERL_LEVEL} < 500800
+IGNORE= supports Perl 5.8.0 or above only
+.endif
+
+.include <bsd.port.post.mk>