aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2010-06-15 02:13:15 +0800
committerfjoe <fjoe@FreeBSD.org>2010-06-15 02:13:15 +0800
commit4492f9540ce287b39602afac4c113fa9866dac3e (patch)
treee3584f36968c232ae9f336cfacd46024df2cf5a4 /misc
parent1c07153977f62fdc9f9585acd3430cd083e66576 (diff)
downloadfreebsd-ports-gnome-4492f9540ce287b39602afac4c113fa9866dac3e.tar.gz
freebsd-ports-gnome-4492f9540ce287b39602afac4c113fa9866dac3e.tar.zst
freebsd-ports-gnome-4492f9540ce287b39602afac4c113fa9866dac3e.zip
Add OS version check.
Diffstat (limited to 'misc')
-rw-r--r--misc/dahdi-kmod/Makefile4
-rw-r--r--misc/dahdi/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/misc/dahdi-kmod/Makefile b/misc/dahdi-kmod/Makefile
index f4541128e651..ed61a62cf3fa 100644
--- a/misc/dahdi-kmod/Makefile
+++ b/misc/dahdi-kmod/Makefile
@@ -43,6 +43,10 @@ OPTIONS= EXPERIMENTAL "Enable experimental drivers" off
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 703000 || (${OSVERSION} >= 800000 && ${OSVERSION} < 800108)
+IGNORE= requires firmware(9) support for kernel modules with hyphens
+.endif
+
.if ${ARCH} == "i386" || ${ARCH} == "amd64"
PLIST_SUB+= X86=""
.else
diff --git a/misc/dahdi/Makefile b/misc/dahdi/Makefile
index f4541128e651..ed61a62cf3fa 100644
--- a/misc/dahdi/Makefile
+++ b/misc/dahdi/Makefile
@@ -43,6 +43,10 @@ OPTIONS= EXPERIMENTAL "Enable experimental drivers" off
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 703000 || (${OSVERSION} >= 800000 && ${OSVERSION} < 800108)
+IGNORE= requires firmware(9) support for kernel modules with hyphens
+.endif
+
.if ${ARCH} == "i386" || ${ARCH} == "amd64"
PLIST_SUB+= X86=""
.else