aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorphantom <phantom@FreeBSD.org>2004-12-24 15:16:12 +0800
committerphantom <phantom@FreeBSD.org>2004-12-24 15:16:12 +0800
commit5d29b26e91a3999765285cc6ccae8321c34e7adb (patch)
treee7119a680900ccf804238e9c7e4f7013d8b0e329 /misc
parent09f38e636d6db68f9e274e14ccf5ab1f92d7e127 (diff)
downloadfreebsd-ports-gnome-5d29b26e91a3999765285cc6ccae8321c34e7adb.tar.gz
freebsd-ports-gnome-5d29b26e91a3999765285cc6ccae8321c34e7adb.tar.zst
freebsd-ports-gnome-5d29b26e91a3999765285cc6ccae8321c34e7adb.zip
Respect PTHREAD_LIBS by default
PR: ports/62919 Submitted by: Craig Rodrigues <rodrigc@crodrigues.org>
Diffstat (limited to 'misc')
-rw-r--r--misc/posixtestsuite/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/misc/posixtestsuite/Makefile b/misc/posixtestsuite/Makefile
index 94d729f72452..da62512410ea 100644
--- a/misc/posixtestsuite/Makefile
+++ b/misc/posixtestsuite/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 1.3.0
PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= posixtest
+MASTER_SITE_SUBDIR= posixtest
MAINTAINER= phantom@FreeBSD.org
COMMENT= Open POSIX Test Suite
@@ -26,9 +26,9 @@ USE_GMAKE= YES
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-REGR_LOG= log.run-4stable
+REGR_LOG= log.run-4stable
.else
-REGR_LOG= log.run-5current
+REGR_LOG= log.run-5current
.endif
RUN_RESULT= ${WRKSRC}/run.result
@@ -43,7 +43,7 @@ THEPIPE= | tee 2>&1
.if defined(WITH_THRLIB)
THRLIB=${WITH_THRLIB}
.else
-THRLIB= -lpthread
+THRLIB= ${PTHREAD_LIBS}
.endif
pre-everything::
@@ -58,7 +58,7 @@ pre-everything::
@${ECHO} ""
@${ECHO} " * QUIET - don't print progress messages while running"
@${ECHO} " * WITH_THRLIB - choose thread library to run test against"
- @${ECHO} " (NB: by default 'libpthread' is used)"
+ @${ECHO} " (NB: by default '"${PTHREAD_LIBS}"' is used)"
@${ECHO} ""
@${ECHO} "Examples:"
@${ECHO} ""