aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-01-16 01:03:40 +0800
committersobomax <sobomax@FreeBSD.org>2001-01-16 01:03:40 +0800
commit6da7ac726ea9424b6d7ac12cf07c9b33bffeb06e (patch)
tree0a3dbbfab36713f9d9472c0226cf79db36a9d573 /misc
parent37c66ab2d7a0f0952a9b6af63361c7c53df174e6 (diff)
downloadfreebsd-ports-gnome-6da7ac726ea9424b6d7ac12cf07c9b33bffeb06e.tar.gz
freebsd-ports-gnome-6da7ac726ea9424b6d7ac12cf07c9b33bffeb06e.tar.zst
freebsd-ports-gnome-6da7ac726ea9424b6d7ac12cf07c9b33bffeb06e.zip
Add aureal-kmod - a port to provide convinient way for building FreeBSD driver
for Aureal based soundcards. This driver could not be added to the base system because it's uses binary-only Linux Vortex Core object modules. The port supports 4-STABLE and 5-CURRENT, however 4-STABLE isn't tested, so please report your mileage to me.
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/aureal-kmod/Makefile48
-rw-r--r--misc/aureal-kmod/distinfo2
-rw-r--r--misc/aureal-kmod/files/patch-10_Makefile10
-rw-r--r--misc/aureal-kmod/files/patch-20_Makefile10
-rw-r--r--misc/aureal-kmod/files/patch-30_Makefile10
-rw-r--r--misc/aureal-kmod/files/patch-Makefile9
-rw-r--r--misc/aureal-kmod/files/patch-Makefile.inc15
-rw-r--r--misc/aureal-kmod/files/patch-au88x0.c14
-rw-r--r--misc/aureal-kmod/pkg-comment1
-rw-r--r--misc/aureal-kmod/pkg-descr3
-rw-r--r--misc/aureal-kmod/pkg-message23
-rw-r--r--misc/aureal-kmod/pkg-plist4
13 files changed, 150 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 0e30c7c51655..59deb227c6ef 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -21,6 +21,7 @@
SUBDIR += ari-yahoo
SUBDIR += asbutton
SUBDIR += astrolog
+ SUBDIR += aureal-kmod
SUBDIR += bb
SUBDIR += bbjd
SUBDIR += biblereader
diff --git a/misc/aureal-kmod/Makefile b/misc/aureal-kmod/Makefile
new file mode 100644
index 000000000000..afcce3345fd3
--- /dev/null
+++ b/misc/aureal-kmod/Makefile
@@ -0,0 +1,48 @@
+# Ports collection makefile for: aureal-kmod
+# Date created: 15 January 2001
+# Whom: Maxim Sobolev <soobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aureal-kmod
+PORTVERSION= 1.5
+CATEGORIES= misc
+MASTER_SITES= http://www.cis.ohio-state.edu/~matey/au88x0/
+DISTNAME= au88x0-${PORTVERSION}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+NO_PACKAGE= package doesn't make any sense, because kld's should be in sync with running kernel to work correctly
+
+WRKSRC= ${WRKDIR}
+
+PKGMESSAGE= ${WRKSRC}/.MESSAGE
+
+MAKE_ENV= WRKSRC="${WRKSRC}"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 400000
+BROKEN= "FreeBSD 3.* isn't supported"
+.elif ${OSVERSION} < 500000
+PORTVERSION= 1.3
+.endif
+
+pre-build:
+ @if [ ! -d /sys -o ! -d /usr/src/sys ]; then \
+ ${ECHO} "****************************************" ; \
+ ${ECHO} " You need to extract kernel source tree" ; \
+ ${ECHO} " before you build this package..." ; \
+ ${ECHO} "****************************************" ; \
+ ${FALSE} ; \
+ fi
+
+pre-install:
+ @${SED} 's|%%PREFIX%%|${PREFIX}|g' ${PKGDIR}/pkg-message > ${PKGMESSAGE}
+ ${MKDIR} ${PREFIX}/lib/au88x0
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/misc/aureal-kmod/distinfo b/misc/aureal-kmod/distinfo
new file mode 100644
index 000000000000..acab6b1e35d1
--- /dev/null
+++ b/misc/aureal-kmod/distinfo
@@ -0,0 +1,2 @@
+MD5 (au88x0-1.3.tar.gz) = fe88b877286aea052af96fc5a37f9af1
+MD5 (au88x0-1.5.tar.gz) = c0e781dde9624eb1213deb84aeb9d099
diff --git a/misc/aureal-kmod/files/patch-10_Makefile b/misc/aureal-kmod/files/patch-10_Makefile
new file mode 100644
index 000000000000..f53fd9442836
--- /dev/null
+++ b/misc/aureal-kmod/files/patch-10_Makefile
@@ -0,0 +1,10 @@
+
+$FreeBSD$
+
+--- 10/Makefile.orig Mon Jan 15 18:45:58 2001
++++ 10/Makefile Mon Jan 15 18:46:31 2001
+@@ -0,0 +1,4 @@
++KMOD = snd_au8810
++SRCS += asp10.o
++
++.include <bsd.kmod.mk>
diff --git a/misc/aureal-kmod/files/patch-20_Makefile b/misc/aureal-kmod/files/patch-20_Makefile
new file mode 100644
index 000000000000..974ca87c082b
--- /dev/null
+++ b/misc/aureal-kmod/files/patch-20_Makefile
@@ -0,0 +1,10 @@
+
+$FreeBSD$
+
+--- 20/Makefile.orig Mon Jan 15 18:45:59 2001
++++ 20/Makefile Mon Jan 15 18:46:34 2001
+@@ -0,0 +1,4 @@
++KMOD = snd_au8820
++SRCS += asp20.o
++
++.include <bsd.kmod.mk>
diff --git a/misc/aureal-kmod/files/patch-30_Makefile b/misc/aureal-kmod/files/patch-30_Makefile
new file mode 100644
index 000000000000..e23040a13fe0
--- /dev/null
+++ b/misc/aureal-kmod/files/patch-30_Makefile
@@ -0,0 +1,10 @@
+
+$FreeBSD$
+
+--- 30/Makefile.orig Mon Jan 15 18:45:59 2001
++++ 30/Makefile Mon Jan 15 18:46:37 2001
+@@ -0,0 +1,4 @@
++KMOD = snd_au8830
++SRCS += asp30.o
++
++.include <bsd.kmod.mk>
diff --git a/misc/aureal-kmod/files/patch-Makefile b/misc/aureal-kmod/files/patch-Makefile
new file mode 100644
index 000000000000..795b1e286dba
--- /dev/null
+++ b/misc/aureal-kmod/files/patch-Makefile
@@ -0,0 +1,9 @@
+
+$FreeBSD$
+
+--- Makefile.orig Mon Jan 15 18:44:49 2001
++++ Makefile Mon Jan 15 18:44:49 2001
+@@ -0,0 +1,3 @@
++SUBDIR = 10 20 30
++
++.include <bsd.subdir.mk>
diff --git a/misc/aureal-kmod/files/patch-Makefile.inc b/misc/aureal-kmod/files/patch-Makefile.inc
new file mode 100644
index 000000000000..5662c830ea79
--- /dev/null
+++ b/misc/aureal-kmod/files/patch-Makefile.inc
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- Makefile.inc.orig Mon Jan 15 18:44:49 2001
++++ Makefile.inc Mon Jan 15 18:44:49 2001
+@@ -0,0 +1,9 @@
++.PATH: /sys/dev/sound/pci ${WRKSRC}
++
++KMODDIR = ${PREFIX}/lib/au88x0
++SRCS = device_if.h bus_if.h isa_if.h pci_if.h
++SRCS += au88x0.c
++.if ${OSVERSION} > 500000
++SRCS += ac97_if.h channel_if.h feeder_if.h mixer_if.h
++.endif
++CFLAGS += -I${WRKSRC}
diff --git a/misc/aureal-kmod/files/patch-au88x0.c b/misc/aureal-kmod/files/patch-au88x0.c
new file mode 100644
index 000000000000..8c5b59f1c707
--- /dev/null
+++ b/misc/aureal-kmod/files/patch-au88x0.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- au88x0.c.orig Mon Jan 15 18:44:49 2001
++++ au88x0.c Mon Jan 15 18:44:49 2001
+@@ -32,7 +32,7 @@
+ */
+
+ #include <dev/sound/pcm/sound.h>
+-#include <dev/sound/pci/au88x0.h>
++#include "au88x0.h"
+
+ #include <pci/pcireg.h>
+ #include <pci/pcivar.h>
diff --git a/misc/aureal-kmod/pkg-comment b/misc/aureal-kmod/pkg-comment
new file mode 100644
index 000000000000..b754b1b52cd9
--- /dev/null
+++ b/misc/aureal-kmod/pkg-comment
@@ -0,0 +1 @@
+A FreeBSD Driver for Aureal Vortex based soundcards
diff --git a/misc/aureal-kmod/pkg-descr b/misc/aureal-kmod/pkg-descr
new file mode 100644
index 000000000000..069914179cf3
--- /dev/null
+++ b/misc/aureal-kmod/pkg-descr
@@ -0,0 +1,3 @@
+FreeBSD Driver for Aureal Vortex based soundcards.
+
+WWW: http://www.cis.ohio-state.edu/~matey/au88x0/
diff --git a/misc/aureal-kmod/pkg-message b/misc/aureal-kmod/pkg-message
new file mode 100644
index 000000000000..e6dee4bc3e84
--- /dev/null
+++ b/misc/aureal-kmod/pkg-message
@@ -0,0 +1,23 @@
+-------------------------------------------------------------------------------
+You can load the module by typing (as root of course):
+
+# kldload %%PREFIX%%/lib/au88x0/snd_au88X0.ko
+
+where X is 1, 2 or 3 depending on which Auread chipset do you have - au8810,
+au8820 or au8830 correspondingly.
+
+Please note that you are also need to have a `snd_pcm.ko' module either already
+loaded or placed into appropriate location for modules on your system (default
+is /modules/ on 4-STABLE and /boot/kernel/ on 5-CURRENT). You can compile and
+install snd_pcm by doing:
+
+# cd /sys/modules/sound/pcm/ && make all install
+
+Please also note that module for 4-STABLE system is untested, so please use it
+with caution and if possible please report if it work for you or not to
+Maxim Sobolev <sobomax@FreeBSD.org>.
+
+Thanks and enjoy!
+
+-Maxim
+-------------------------------------------------------------------------------
diff --git a/misc/aureal-kmod/pkg-plist b/misc/aureal-kmod/pkg-plist
new file mode 100644
index 000000000000..168d6b9cf81b
--- /dev/null
+++ b/misc/aureal-kmod/pkg-plist
@@ -0,0 +1,4 @@
+lib/au88x0/snd_au8810.ko
+lib/au88x0/snd_au8820.ko
+lib/au88x0/snd_au8830.ko
+@dirrm lib/au88x0