aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-08-15 15:40:36 +0800
committersobomax <sobomax@FreeBSD.org>2001-08-15 15:40:36 +0800
commit90e1ff34038d03772d559f71984ae2195a5ec182 (patch)
treeafb9d572184d681491bfd314f7dee378b0e253c5 /misc
parent9eca9782ddb831336afb70ecd8c346e0af95f428 (diff)
downloadfreebsd-ports-gnome-90e1ff34038d03772d559f71984ae2195a5ec182.tar.gz
freebsd-ports-gnome-90e1ff34038d03772d559f71984ae2195a5ec182.tar.zst
freebsd-ports-gnome-90e1ff34038d03772d559f71984ae2195a5ec182.zip
Use other way to disconnect compatX ports from the bento build.
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile6
-rw-r--r--misc/compat22/Makefile4
-rw-r--r--misc/compat3x/Makefile4
-rw-r--r--misc/compat4x/Makefile4
4 files changed, 15 insertions, 3 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 66a22b3218b9..d728e3f19890 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -32,9 +32,9 @@
SUBDIR += cmatrix
SUBDIR += colorls
SUBDIR += colortail
-# SUBDIR += compat22
-# SUBDIR += compat3x
-# SUBDIR += compat4x
+ SUBDIR += compat22
+ SUBDIR += compat3x
+ SUBDIR += compat4x
SUBDIR += cpuid
SUBDIR += crosspad
SUBDIR += cstream
diff --git a/misc/compat22/Makefile b/misc/compat22/Makefile
index 5c0a18d6dcf1..98fdd06fed8e 100644
--- a/misc/compat22/Makefile
+++ b/misc/compat22/Makefile
@@ -35,6 +35,10 @@ INSTALLS_SHLIB= yes
LDCONFIG= /sbin/ldconfig -aout
LDCONFIG_DIRS= %%PREFIX%%/lib/compat/aout
+.if defined(BATCH) || defined(PACKAGE_BUILDING)
+IGNORE= "does damage to bento cluster"
+.endif
+
do-extract:
${MKDIR} ${WRKDIR}
cd ${_DISTDIR} && ${CAT} ${DISTFILES} | ${TAR} -xzf - -C ${WRKDIR}
diff --git a/misc/compat3x/Makefile b/misc/compat3x/Makefile
index 3aae1f19c0fb..486f86afe52b 100644
--- a/misc/compat3x/Makefile
+++ b/misc/compat3x/Makefile
@@ -34,6 +34,10 @@ TARGET_DIR= ${PREFIX}/lib/compat
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib/compat
+.if defined(BATCH) || defined(PACKAGE_BUILDING)
+IGNORE= "does damage to bento cluster"
+.endif
+
do-extract:
${MKDIR} ${WRKDIR}
cd ${_DISTDIR} && ${CAT} ${DISTFILES} | ${TAR} -xzf - -C ${WRKDIR}
diff --git a/misc/compat4x/Makefile b/misc/compat4x/Makefile
index a3cbe289b938..b5f948224e3c 100644
--- a/misc/compat4x/Makefile
+++ b/misc/compat4x/Makefile
@@ -26,6 +26,10 @@ TARGET_DIR= ${PREFIX}/lib/compat
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib/compat
+.if defined(BATCH) || defined(PACKAGE_BUILDING)
+IGNORE= "does damage to bento cluster"
+.endif
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500000