aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2005-09-11 21:30:18 +0800
committerdes <des@FreeBSD.org>2005-09-11 21:30:18 +0800
commitabdb8de9e9d6858954956506aee05d6d51c925ee (patch)
tree8606c50da873050ff168c45f04c28c1acd331e1c /misc
parent38ea251fca604745f04feaf8d84e8a944e0a480d (diff)
downloadfreebsd-ports-gnome-abdb8de9e9d6858954956506aee05d6d51c925ee.tar.gz
freebsd-ports-gnome-abdb8de9e9d6858954956506aee05d6d51c925ee.tar.zst
freebsd-ports-gnome-abdb8de9e9d6858954956506aee05d6d51c925ee.zip
While I'm here, tweak the master port detection code and comment out a
warning which is more annoying than useful.
Diffstat (limited to 'misc')
-rw-r--r--misc/porteasy/src/porteasy.pl8
1 files changed, 4 insertions, 4 deletions
diff --git a/misc/porteasy/src/porteasy.pl b/misc/porteasy/src/porteasy.pl
index ba7e1b0b6a7a..a1c4da3e39c7 100644
--- a/misc/porteasy/src/porteasy.pl
+++ b/misc/porteasy/src/porteasy.pl
@@ -581,21 +581,21 @@ sub find_master($) {
while (<FILE>) {
my $master; # Master directory
- if (/^(?:MAIN|MASTER)DIR\s*=\s*(\S+)\s*$/) {
+ if (/^MASTERDIR\s*=\s*(\S+)\s*$/) {
$master = $1;
- } elsif (/^\.?include \"([^\"]+)\/Makefile(?:[^\/\"]*)\"\s*$/) {
+ } elsif (/^\.?include \"([^\s\"]+)\/(?:[^\s\/\"]*)\"\s*$/) {
$master = $1;
}
if (defined($master) && $master !~ m/WRKDIRPREFIX/) {
$master =~ s/^\$\{.CURDIR\}//;
- $master =~ s/^\$\{PORTSDIR}/..\/../;
+ $master =~ s/^\$\{PORTSDIR\}/..\/../;
$master = "/$port/$master";
$master =~ s|/+|/|g;
1 while ($master =~ s|/[^\./]*/\.\./|/|);
$master =~ s|^/||;
$master =~ s|/$||;
if ($master eq $port) {
- bsd::warnx("master port heuristics failed for %s", $port);
+ #bsd::warnx("master port heuristics failed for %s", $port);
next;
}
if ($master !~ m|^[^/]+/[^/]+$|) {