aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2005-11-30 22:10:25 +0800
committerflz <flz@FreeBSD.org>2005-11-30 22:10:25 +0800
commitc5de023ae724864b497106327e4e56523ef78074 (patch)
treefeaed202c3ba8b639c2c5b0aea3972739a39c921 /misc
parentd281323e3a9f697562861a38690f26fec7842c97 (diff)
downloadfreebsd-ports-gnome-c5de023ae724864b497106327e4e56523ef78074.tar.gz
freebsd-ports-gnome-c5de023ae724864b497106327e4e56523ef78074.tar.zst
freebsd-ports-gnome-c5de023ae724864b497106327e4e56523ef78074.zip
- Fix mtx on 64bits archs.
PR: ports/82599 Submitted by: Morten A. Middelthon <morten@coretrek.no> Approved by: maintainer timeout (3 months)
Diffstat (limited to 'misc')
-rw-r--r--misc/mtx/Makefile8
-rw-r--r--misc/mtx/files/patch-Makefile.in22
2 files changed, 13 insertions, 17 deletions
diff --git a/misc/mtx/Makefile b/misc/mtx/Makefile
index 7efcc4340fe8..3fdb065fab22 100644
--- a/misc/mtx/Makefile
+++ b/misc/mtx/Makefile
@@ -19,10 +19,4 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
MAN1= loaderinfo.1 mtx.1 tapeinfo.1 scsitape.1
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64" || ${ARCH} == "sparc64" || ${ARCH} == "amd64"
-BROKEN= "Does not compile on ia64, sparc64 and amd64"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/mtx/files/patch-Makefile.in b/misc/mtx/files/patch-Makefile.in
index a2b0d367bcef..eb173fcb055b 100644
--- a/misc/mtx/files/patch-Makefile.in
+++ b/misc/mtx/files/patch-Makefile.in
@@ -1,14 +1,16 @@
---- Makefile.in.orig Fri Feb 7 09:29:39 2003
-+++ Makefile.in Fri Feb 7 09:31:26 2003
-@@ -43,7 +43,11 @@
- # FreeBSD on x86...
+--- Makefile.in.orig Wed Oct 2 18:55:29 2002
++++ Makefile.in Thu Jun 23 17:50:34 2005
+@@ -40,11 +40,10 @@
+ endif
+
+ #
+-# FreeBSD on x86...
++# FreeBSD
#
ifeq ($(TARGET),freebsd86)
-+ifeq ($(ARCH), alpha)
-+CFLAGS +=
-+else
- CFLAGS += -m486
-+endif
- CPPFLAGS += -I/usr/src/linux/include -DLONG_PRINT_REQUEST_SENSE=1
+-CFLAGS += -m486
+-CPPFLAGS += -I/usr/src/linux/include -DLONG_PRINT_REQUEST_SENSE=1
++CPPFLAGS += -DLONG_PRINT_REQUEST_SENSE=1
LIBS += -lcam
endif
+