aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2005-04-19 17:03:11 +0800
committerdanfe <danfe@FreeBSD.org>2005-04-19 17:03:11 +0800
commitcb4d54c59886f7ab597dca597445b14974409b88 (patch)
treee981bd0ed38b35fea2d028782bba2ad7c27a7732 /misc
parentc89c4ba8f84b41ef08f6fa257b38a3043a401520 (diff)
downloadfreebsd-ports-gnome-cb4d54c59886f7ab597dca597445b14974409b88.tar.gz
freebsd-ports-gnome-cb4d54c59886f7ab597dca597445b14974409b88.tar.zst
freebsd-ports-gnome-cb4d54c59886f7ab597dca597445b14974409b88.zip
Update to 4.2.20, latest from GNU.
PR: ports/78961 Submitted by: Jason Harris <jharris(at)widomaker.com> Approved by: maintainer timeout
Diffstat (limited to 'misc')
-rw-r--r--misc/findutils/Makefile65
-rw-r--r--misc/findutils/distinfo12
-rw-r--r--misc/findutils/files/patch-aa15
-rw-r--r--misc/findutils/files/patch-ab10
-rw-r--r--misc/findutils/pkg-plist33
5 files changed, 60 insertions, 75 deletions
diff --git a/misc/findutils/Makefile b/misc/findutils/Makefile
index 2f42337d6911..5c37815fa659 100644
--- a/misc/findutils/Makefile
+++ b/misc/findutils/Makefile
@@ -6,69 +6,38 @@
#
PORTNAME= findutils
-PORTVERSION= 4.1
-PORTREVISION= 3
+PORTVERSION= 4.2.20
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= findutils
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.sig
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= cyrille.lefevre@laposte.net
COMMENT= The GNU find utilities
-# Global variables
-#
-
-USE_REINPLACE= yes
+USE_GPG?= yes
+SIG_FILES= ${DISTNAME}${EXTRACT_SUFX}.sig
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
USE_GMAKE= yes
-CONFIGURE_ARGS= --program-prefix=g # --localstatedir=${LOCALSTATEDIR}
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+CONFIGURE_ARGS+= --program-prefix=g --localstatedir=${LOCALSTATEDIR}
MAKE_ARGS= INSTALL_SCRIPT="${INSTALL_SCRIPT}"
INFO= find
MAN1= gfind.1 gxargs.1 glocate.1 gupdatedb.1
MAN5= glocatedb.5
-# Local variables
-#
-
LOCALSTATEDIR?= /var/db
-INSTALL_INFO?= install-info
-
-# Post-extract
-#
-
-post-extract:
- @${RM} -f ${WRKSRC}/doc/${PORTNAME:S/utils//}.info*
-
-# Post-patch
-#
-
-post-patch:
- @${REINPLACE_CMD} -e 's|makeinfo|makeinfo --no-split|g' \
- ${WRKSRC}/doc/Makefile.in
-
-# Post-configure
-#
-
-# --localstatedir= isn't handled right now, so, do it manually.
-post-configure:
- @${REINPLACE_CMD} -e 's|\$$\(prefix\)/var|${LOCALSTATEDIR}|g' \
- ${WRKSRC}/Makefile ${WRKSRC}/locate/Makefile
-
-# Post-install
-#
-
-post-install: install-info remove-catman
-
-install-info:
- @${INSTALL_INFO} ${PREFIX}/info/${PORTNAME:S/utils//}.info ${PREFIX}/info/dir
-
-remove-catman:
-.for mansect in 1 5
-.for man in ${MAN${mansect}}
- @${RM} -f ${MAN1PREFIX}/man/cat${mansect}/${man}
-.endfor
-.endfor
-
.include <bsd.port.mk>
diff --git a/misc/findutils/distinfo b/misc/findutils/distinfo
index 3c115c6f37d2..1ade3221fa20 100644
--- a/misc/findutils/distinfo
+++ b/misc/findutils/distinfo
@@ -1,2 +1,10 @@
-MD5 (findutils-4.1.tar.gz) = 3ea8fe58ef5386da75f6c707713aa059
-SIZE (findutils-4.1.tar.gz) = 294494
+MD5 (findutils-4.2.20.tar.gz) = 7c8e12165b221dd67a19c00d780437a4
+SHA1 (findutils-4.2.20.tar.gz) = c34deb417bddf16ad88436723f7d7fd509335536
+RMD160 (findutils-4.2.20.tar.gz) = 6237a29deb24037750b9b2ccc5fabe6a3a70181f
+SHA256 (findutils-4.2.20.tar.gz) = 4e4d72a4387fcc942565c45460e632001db6bde0a46338a6a1b59b956fd3e031
+SIZE (findutils-4.2.20.tar.gz) = 1044129
+MD5 (findutils-4.2.20.tar.gz.sig) = abffce506f8eddbc163433b067b0c99d
+SHA1 (findutils-4.2.20.tar.gz.sig) = 45c39f84a9d97d5f7502591f6e29a93a6ab4cba3
+RMD160 (findutils-4.2.20.tar.gz.sig) = 8d77fcfe2c55508d56da7d228bdb72437febe816
+SHA256 (findutils-4.2.20.tar.gz.sig) = abab1781099959b745c69d35b2eb77684c5ba57b973cec3b932cd32d9b130743
+SIZE (findutils-4.2.20.tar.gz.sig) = 65
diff --git a/misc/findutils/files/patch-aa b/misc/findutils/files/patch-aa
deleted file mode 100644
index 38e8a58da3a0..000000000000
--- a/misc/findutils/files/patch-aa
+++ /dev/null
@@ -1,15 +0,0 @@
---- locate/Makefile.in.orig Sat Nov 5 09:44:08 1994
-+++ locate/Makefile.in Wed Mar 29 19:49:11 2000
-@@ -96,8 +96,11 @@
-
- install-programs: $(PROGRAMS) $(SCRIPTS)
- $(top_srcdir)/mkinstalldirs $(bindir)
-- for p in $(PROGRAMS) $(SCRIPTS); do \
-+ for p in $(PROGRAMS); do \
- $(INSTALL_PROGRAM) $$p $(bindir)/`echo $$p|sed '$(transform)'`; \
-+ done
-+ for p in $(SCRIPTS); do \
-+ $(INSTALL_SCRIPT) -m 555 $$p $(bindir)/`echo $$p|sed '$(transform)'`; \
- done
-
- uninstall:: uninstall-programs
diff --git a/misc/findutils/files/patch-ab b/misc/findutils/files/patch-ab
deleted file mode 100644
index 546f317d9ea2..000000000000
--- a/misc/findutils/files/patch-ab
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib/regex.h.orig Thu Feb 10 12:27:41 2000
-+++ lib/regex.h Thu Feb 10 12:26:55 2000
-@@ -23,6 +23,7 @@
- /* POSIX says that <sys/types.h> must be included (by the caller) before
- <regex.h>. */
-
-+#include <sys/syslimits.h>
- #ifdef VMS
- /* VMS doesn't have `size_t' in <sys/types.h>, even though POSIX says it
- should be there. */
diff --git a/misc/findutils/pkg-plist b/misc/findutils/pkg-plist
index b98f6450f99e..dc922a69f693 100644
--- a/misc/findutils/pkg-plist
+++ b/misc/findutils/pkg-plist
@@ -5,3 +5,36 @@ bin/gupdatedb
libexec/gfrcode
libexec/gcode
libexec/gbigram
+%%NLS%%share/locale/be/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/da/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/de/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/el/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/es/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/et/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/id/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/it/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/lg/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/findutils.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/findutils.mo