aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-09-26 02:34:45 +0800
committermnag <mnag@FreeBSD.org>2005-09-26 02:34:45 +0800
commitd5f75d5efaa8dc05a086307a18685264838a8dac (patch)
tree1d803f65d7f0b4d999bf1b479e1e32d9900bf14a /misc
parenta761e4a4ccac6788e7efbaa9b885f462f0ed5478 (diff)
downloadfreebsd-ports-gnome-d5f75d5efaa8dc05a086307a18685264838a8dac.tar.gz
freebsd-ports-gnome-d5f75d5efaa8dc05a086307a18685264838a8dac.tar.zst
freebsd-ports-gnome-d5f75d5efaa8dc05a086307a18685264838a8dac.zip
Add message about COMPAT_FREEBSD4 in kernel
PR: ports/83924 Submitted by: Scot W. Hetzel <swhetzel@gmail.com> Approved by: pav (mentor)
Diffstat (limited to 'misc')
-rw-r--r--misc/compat4x/Makefile3
-rw-r--r--misc/compat4x/pkg-install20
2 files changed, 23 insertions, 0 deletions
diff --git a/misc/compat4x/Makefile b/misc/compat4x/Makefile
index 62871db2db82..d29fe17aa65b 100644
--- a/misc/compat4x/Makefile
+++ b/misc/compat4x/Makefile
@@ -120,4 +120,7 @@ do-install:
.endif
${INSTALL_SCRIPT} ${WRKDIR}/000.${PORTNAME}.sh ${PREFIX}/etc/rc.d/
+post-install:
+ @${SH} ${PKGINSTALL} ${PORTNAME} POST-INSTALL
+
.include <bsd.port.post.mk>
diff --git a/misc/compat4x/pkg-install b/misc/compat4x/pkg-install
new file mode 100644
index 000000000000..3b23fcfaaffa
--- /dev/null
+++ b/misc/compat4x/pkg-install
@@ -0,0 +1,20 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+case $2 in
+ POST-INSTALL)
+ echo ""
+ echo "*******************************************************************************"
+ echo "* *"
+ echo "* Do not forget to add COMPAT_FREEBSD4 into *"
+ echo "* your kernel configuration (enabled by default). *"
+ echo "* *"
+ echo "* To configure and recompile your kernel see: *"
+ echo "* http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/kernelconfig.html *"
+ echo "* *"
+ echo "*******************************************************************************"
+ echo ""
+ ;;
+esac