aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2010-05-22 19:40:51 +0800
committerkuriyama <kuriyama@FreeBSD.org>2010-05-22 19:40:51 +0800
commite97c7148eb63f6f9483974855de1f48c7c1ecc6f (patch)
treeab1add937d569de28569e7c03b96c3c937303397 /misc
parent7a6cba0216cc159bf2c3c3fb86c00d691b26ccc5 (diff)
downloadfreebsd-ports-gnome-e97c7148eb63f6f9483974855de1f48c7c1ecc6f.tar.gz
freebsd-ports-gnome-e97c7148eb63f6f9483974855de1f48c7c1ecc6f.tar.zst
freebsd-ports-gnome-e97c7148eb63f6f9483974855de1f48c7c1ecc6f.zip
- Add workaround for glib-2.24 [1].
- Allow to choose samba port [2]. PR: ports/146768 [1], ports/146769 [2] Submitted by: Ricky Morse <remorse@partners.org> [1,2]
Diffstat (limited to 'misc')
-rw-r--r--misc/amanda-server/Makefile7
-rw-r--r--misc/amanda-server/files/patch-common-src::glib-util.c51
-rw-r--r--misc/amanda26-server/Makefile7
-rw-r--r--misc/amanda26-server/files/patch-common-src::glib-util.c51
-rw-r--r--misc/amanda32-server/Makefile7
-rw-r--r--misc/amanda32-server/files/patch-common-src::glib-util.c51
6 files changed, 165 insertions, 9 deletions
diff --git a/misc/amanda-server/Makefile b/misc/amanda-server/Makefile
index e7bcc8c7897a..f5a65f09d82e 100644
--- a/misc/amanda-server/Makefile
+++ b/misc/amanda-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME= amanda
PORTVERSION= 2.6.1p2
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= misc
MASTER_SITES= SF/amanda/amanda%20-%20stable/${PORTVERSION}
@@ -125,8 +125,9 @@ CONFIGURE_ARGS+= --without-gnuplot
.endif
.if defined (WITH_SAMBA)
-BUILD_DEPENDS+= smbclient:${PORTSDIR}/net/samba3
-RUN_DEPENDS+= smbclient:${PORTSDIR}/net/samba3
+SAMBA_PORT?= samba3
+BUILD_DEPENDS+= smbclient:${PORTSDIR}/net/${SAMBA_PORT}
+RUN_DEPENDS+= smbclient:${PORTSDIR}/net/${SAMBA_PORT}
CONFIGURE_ARGS+= --with-smbclient=${PREFIX}/bin/smbclient
.endif
diff --git a/misc/amanda-server/files/patch-common-src::glib-util.c b/misc/amanda-server/files/patch-common-src::glib-util.c
new file mode 100644
index 000000000000..c7450c7835eb
--- /dev/null
+++ b/misc/amanda-server/files/patch-common-src::glib-util.c
@@ -0,0 +1,51 @@
+
+--- common-src/glib-util.c.orig 2010-05-20 13:19:58.000000000 -0400
++++ common-src/glib-util.c 2010-05-20 13:24:40.000000000 -0400
+@@ -38,26 +38,15 @@
+ if (did_glib_init) return;
+ did_glib_init = TRUE;
+
+- /* Initialize glib's type system */
+- g_type_init();
+-
+ /* set up libcurl (this must happen before threading
+ * is initialized) */
+ #ifdef HAVE_LIBCURL
+ # ifdef G_THREADS_ENABLED
+- g_assert(!g_thread_supported());
++ g_assert(!g_thread_supported()); /* assert threads aren't initialized yet */
+ # endif
+ g_assert(curl_global_init(CURL_GLOBAL_ALL) == 0);
+ #endif
+
+- /* And set up glib's threads */
+-#if defined(G_THREADS_ENABLED) && !defined(G_THREADS_IMPL_NONE)
+- if (g_thread_supported()) {
+- return;
+- }
+- g_thread_init(NULL);
+-#endif
+-
+ /* do a version check */
+ #if GLIB_CHECK_VERSION(2,6,0)
+ {
+@@ -71,6 +60,17 @@
+ }
+ }
+ #endif
++
++ /* Initialize glib's type system. On glib >= 2.24, this will initialize
++ * threads, so it must be done after curl is initialized. */
++ g_type_init();
++
++ /* And set up glib's threads */
++#if defined(G_THREADS_ENABLED) && !defined(G_THREADS_IMPL_NONE)
++ if (!g_thread_supported())
++ g_thread_init(NULL);
++#endif
++
+ }
+
+ typedef enum {
+
+
diff --git a/misc/amanda26-server/Makefile b/misc/amanda26-server/Makefile
index e7bcc8c7897a..f5a65f09d82e 100644
--- a/misc/amanda26-server/Makefile
+++ b/misc/amanda26-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME= amanda
PORTVERSION= 2.6.1p2
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= misc
MASTER_SITES= SF/amanda/amanda%20-%20stable/${PORTVERSION}
@@ -125,8 +125,9 @@ CONFIGURE_ARGS+= --without-gnuplot
.endif
.if defined (WITH_SAMBA)
-BUILD_DEPENDS+= smbclient:${PORTSDIR}/net/samba3
-RUN_DEPENDS+= smbclient:${PORTSDIR}/net/samba3
+SAMBA_PORT?= samba3
+BUILD_DEPENDS+= smbclient:${PORTSDIR}/net/${SAMBA_PORT}
+RUN_DEPENDS+= smbclient:${PORTSDIR}/net/${SAMBA_PORT}
CONFIGURE_ARGS+= --with-smbclient=${PREFIX}/bin/smbclient
.endif
diff --git a/misc/amanda26-server/files/patch-common-src::glib-util.c b/misc/amanda26-server/files/patch-common-src::glib-util.c
new file mode 100644
index 000000000000..c7450c7835eb
--- /dev/null
+++ b/misc/amanda26-server/files/patch-common-src::glib-util.c
@@ -0,0 +1,51 @@
+
+--- common-src/glib-util.c.orig 2010-05-20 13:19:58.000000000 -0400
++++ common-src/glib-util.c 2010-05-20 13:24:40.000000000 -0400
+@@ -38,26 +38,15 @@
+ if (did_glib_init) return;
+ did_glib_init = TRUE;
+
+- /* Initialize glib's type system */
+- g_type_init();
+-
+ /* set up libcurl (this must happen before threading
+ * is initialized) */
+ #ifdef HAVE_LIBCURL
+ # ifdef G_THREADS_ENABLED
+- g_assert(!g_thread_supported());
++ g_assert(!g_thread_supported()); /* assert threads aren't initialized yet */
+ # endif
+ g_assert(curl_global_init(CURL_GLOBAL_ALL) == 0);
+ #endif
+
+- /* And set up glib's threads */
+-#if defined(G_THREADS_ENABLED) && !defined(G_THREADS_IMPL_NONE)
+- if (g_thread_supported()) {
+- return;
+- }
+- g_thread_init(NULL);
+-#endif
+-
+ /* do a version check */
+ #if GLIB_CHECK_VERSION(2,6,0)
+ {
+@@ -71,6 +60,17 @@
+ }
+ }
+ #endif
++
++ /* Initialize glib's type system. On glib >= 2.24, this will initialize
++ * threads, so it must be done after curl is initialized. */
++ g_type_init();
++
++ /* And set up glib's threads */
++#if defined(G_THREADS_ENABLED) && !defined(G_THREADS_IMPL_NONE)
++ if (!g_thread_supported())
++ g_thread_init(NULL);
++#endif
++
+ }
+
+ typedef enum {
+
+
diff --git a/misc/amanda32-server/Makefile b/misc/amanda32-server/Makefile
index e7bcc8c7897a..f5a65f09d82e 100644
--- a/misc/amanda32-server/Makefile
+++ b/misc/amanda32-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME= amanda
PORTVERSION= 2.6.1p2
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= misc
MASTER_SITES= SF/amanda/amanda%20-%20stable/${PORTVERSION}
@@ -125,8 +125,9 @@ CONFIGURE_ARGS+= --without-gnuplot
.endif
.if defined (WITH_SAMBA)
-BUILD_DEPENDS+= smbclient:${PORTSDIR}/net/samba3
-RUN_DEPENDS+= smbclient:${PORTSDIR}/net/samba3
+SAMBA_PORT?= samba3
+BUILD_DEPENDS+= smbclient:${PORTSDIR}/net/${SAMBA_PORT}
+RUN_DEPENDS+= smbclient:${PORTSDIR}/net/${SAMBA_PORT}
CONFIGURE_ARGS+= --with-smbclient=${PREFIX}/bin/smbclient
.endif
diff --git a/misc/amanda32-server/files/patch-common-src::glib-util.c b/misc/amanda32-server/files/patch-common-src::glib-util.c
new file mode 100644
index 000000000000..c7450c7835eb
--- /dev/null
+++ b/misc/amanda32-server/files/patch-common-src::glib-util.c
@@ -0,0 +1,51 @@
+
+--- common-src/glib-util.c.orig 2010-05-20 13:19:58.000000000 -0400
++++ common-src/glib-util.c 2010-05-20 13:24:40.000000000 -0400
+@@ -38,26 +38,15 @@
+ if (did_glib_init) return;
+ did_glib_init = TRUE;
+
+- /* Initialize glib's type system */
+- g_type_init();
+-
+ /* set up libcurl (this must happen before threading
+ * is initialized) */
+ #ifdef HAVE_LIBCURL
+ # ifdef G_THREADS_ENABLED
+- g_assert(!g_thread_supported());
++ g_assert(!g_thread_supported()); /* assert threads aren't initialized yet */
+ # endif
+ g_assert(curl_global_init(CURL_GLOBAL_ALL) == 0);
+ #endif
+
+- /* And set up glib's threads */
+-#if defined(G_THREADS_ENABLED) && !defined(G_THREADS_IMPL_NONE)
+- if (g_thread_supported()) {
+- return;
+- }
+- g_thread_init(NULL);
+-#endif
+-
+ /* do a version check */
+ #if GLIB_CHECK_VERSION(2,6,0)
+ {
+@@ -71,6 +60,17 @@
+ }
+ }
+ #endif
++
++ /* Initialize glib's type system. On glib >= 2.24, this will initialize
++ * threads, so it must be done after curl is initialized. */
++ g_type_init();
++
++ /* And set up glib's threads */
++#if defined(G_THREADS_ENABLED) && !defined(G_THREADS_IMPL_NONE)
++ if (!g_thread_supported())
++ g_thread_init(NULL);
++#endif
++
+ }
+
+ typedef enum {
+
+