aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2003-11-22 10:20:34 +0800
committerjeh <jeh@FreeBSD.org>2003-11-22 10:20:34 +0800
commitfc858d03111664c5ff50c08c1e0e257387613032 (patch)
treebaf9673259880536681a27d3930f8fe4b132de51 /misc
parent2a2eeb9671a54aa62645133b7a8c73a990e21b92 (diff)
downloadfreebsd-ports-gnome-fc858d03111664c5ff50c08c1e0e257387613032.tar.gz
freebsd-ports-gnome-fc858d03111664c5ff50c08c1e0e257387613032.tar.zst
freebsd-ports-gnome-fc858d03111664c5ff50c08c1e0e257387613032.zip
misc/brs stopped compiling on -CURRENT due to an obsolete header. Here's a fix, written by Volker Stolz. Thanks Volker!
PR: 59570 Submitted by: MAINTAINER
Diffstat (limited to 'misc')
-rw-r--r--misc/brs/Makefile4
-rw-r--r--misc/brs/files/patch-ad63
2 files changed, 63 insertions, 4 deletions
diff --git a/misc/brs/Makefile b/misc/brs/Makefile
index c18a82aaa9b1..4701c9053c8e 100644
--- a/misc/brs/Makefile
+++ b/misc/brs/Makefile
@@ -22,10 +22,6 @@ MAN1= bible.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
post-patch:
@${MV} ${WRKSRC}/brl.c ${WRKSRC}/brl.c.sed
${SED} -e "s=%%PREFIX%%=${PREFIX}=g" \
diff --git a/misc/brs/files/patch-ad b/misc/brs/files/patch-ad
new file mode 100644
index 000000000000..f13e8744e91d
--- /dev/null
+++ b/misc/brs/files/patch-ad
@@ -0,0 +1,63 @@
+*** tsl.c.orig Wed Aug 9 19:47:29 1995
+--- tsl.c Fri Nov 21 17:31:35 2003
+***************
+*** 106,112 ****
+ \*----------------------------------------------------------------------*/
+
+ #include <stdio.h>
+! #include <varargs.h>
+ #include "tsl.h"
+
+
+--- 106,112 ----
+ \*----------------------------------------------------------------------*/
+
+ #include <stdio.h>
+! #include <stdarg.h>
+ #include "tsl.h"
+
+
+***************
+*** 155,161 ****
+
+
+
+! tsl_error( fatal, va_alist )
+ /*----------------------------------------------------------------------
+ | NAME:
+ | tsl_error
+--- 155,161 ----
+
+
+
+! tsl_error( int fatal, ... )
+ /*----------------------------------------------------------------------
+ | NAME:
+ | tsl_error
+***************
+*** 172,184 ****
+ |
+ \*----------------------------------------------------------------------*/
+
+- int fatal;
+- va_dcl
+ {
+ va_list ap;
+ char *format;
+
+! va_start(ap);
+
+ format = va_arg(ap, char *);
+ vfprintf(stderr, format, ap);
+--- 172,182 ----
+ |
+ \*----------------------------------------------------------------------*/
+
+ {
+ va_list ap;
+ char *format;
+
+! va_start(ap, fatal);
+
+ format = va_arg(ap, char *);
+ vfprintf(stderr, format, ap);