aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2007-08-04 19:41:30 +0800
committergabor <gabor@FreeBSD.org>2007-08-04 19:41:30 +0800
commit1f31ff34b514d77244257a9a94391d3aae8edab0 (patch)
treea676504f8edaca31196a243aa7393f33f26078fa /misc
parentfb4c30cf2c9bc123dc0c05a0e070f2c48e83be57 (diff)
downloadfreebsd-ports-gnome-1f31ff34b514d77244257a9a94391d3aae8edab0.tar.gz
freebsd-ports-gnome-1f31ff34b514d77244257a9a94391d3aae8edab0.tar.zst
freebsd-ports-gnome-1f31ff34b514d77244257a9a94391d3aae8edab0.zip
- Remove the DESTDIR modifications from individual ports as we have a new,
fully chrooted DESTDIR, which does not need such any more. Sponsored by: Google Summer of Code 2007 Approved by: portmgr (pav)
Diffstat (limited to 'misc')
-rw-r--r--misc/nut/Makefile2
-rw-r--r--misc/ossp-uuid/Makefile2
-rw-r--r--misc/py-yolk/Makefile2
-rw-r--r--misc/table.el/Makefile4
-rw-r--r--misc/ttyrec/Makefile2
-rw-r--r--misc/utf8locale/Makefile4
6 files changed, 8 insertions, 8 deletions
diff --git a/misc/nut/Makefile b/misc/nut/Makefile
index 1e67689e91fe..c03a0310c194 100644
--- a/misc/nut/Makefile
+++ b/misc/nut/Makefile
@@ -30,7 +30,7 @@ post-patch:
-e 's|^CFLAGS=|CFLAGS+=|g;s|-Os||;s|gcc|$${CC}|' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${TARGETDIR}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
${INSTALL} -d ${DATADIR}
${INSTALL_DATA} ${RAW:S,^,${WRKSRC}/raw.data/,} ${DATADIR}/
${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1/
diff --git a/misc/ossp-uuid/Makefile b/misc/ossp-uuid/Makefile
index aa32d638fc0d..6e7557a5cee7 100644
--- a/misc/ossp-uuid/Makefile
+++ b/misc/ossp-uuid/Makefile
@@ -32,7 +32,7 @@ CONFIGURE_ENV+= PERL=${PERL5}
CONFIGURE_ARGS+= --with-perl
PLIST_SUB+= WITH_PERL=''
MAN3= OSSP::uuid.3
-MAN3PREFIX= ${TARGETDIR}/lib/perl5/${PERL_VERSION}
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
.else
PLIST_SUB+= WITH_PERL='@comment '
.endif
diff --git a/misc/py-yolk/Makefile b/misc/py-yolk/Makefile
index fe0b10764aa3..39cba03c817a 100644
--- a/misc/py-yolk/Makefile
+++ b/misc/py-yolk/Makefile
@@ -45,7 +45,7 @@ RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/elementtree/__init__.py:${PORTSDIR}/devel/py-
.endif
.if !defined (NOPORTEXAMPLES)
-EXAMPLESDIR= ${TARGETDIR}/share/examples/py-${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
.endif
.include <bsd.port.post.mk>
diff --git a/misc/table.el/Makefile b/misc/table.el/Makefile
index 775c9e80851a..13fe2c789479 100644
--- a/misc/table.el/Makefile
+++ b/misc/table.el/Makefile
@@ -19,8 +19,8 @@ COMMENT= Create and edit WYSIWYG text based embedded tables in Emacs
NO_BUILD= yes
NO_WRKSUBDIR= yes
-EMACSLISPDIR= ${TARGETDIR}/share/emacs/site-lisp
-XEMACSLISPDIR= ${TARGETDIR}/lib/xemacs/site-lisp
+EMACSLISPDIR= ${PREFIX}/share/emacs/site-lisp
+XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp
do-extract:
${MKDIR} ${WRKDIR}
diff --git a/misc/ttyrec/Makefile b/misc/ttyrec/Makefile
index 7219089552af..ed35941f44f6 100644
--- a/misc/ttyrec/Makefile
+++ b/misc/ttyrec/Makefile
@@ -24,7 +24,7 @@ post-patch:
do-install:
.for file in ttyrec ttyplay ttytime
- ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${TARGETDIR}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
.endfor
.for file in ${MAN1}
${INSTALL_MAN} ${WRKSRC}/${file} ${MAN1PREFIX}/man/man1
diff --git a/misc/utf8locale/Makefile b/misc/utf8locale/Makefile
index cd1cfdd7e59a..1be0e52324a3 100644
--- a/misc/utf8locale/Makefile
+++ b/misc/utf8locale/Makefile
@@ -21,14 +21,14 @@ LANGS= af_ZA be_BY bg_BG ca_ES cs_CZ da_DK de_AT de_CH de_DE el_GR \
fr_CA fr_CH fr_FR hr_HR hu_HU hy_AM is_IS it_CH it_IT ja_JP \
kk_KZ ko_KR lt_LT nl_BE nl_NL no_NO pl_PL pt_BR pt_PT ro_RO \
ru_RU sk_SK sl_SI sr_YU sv_SE tr_TR uk_UA zh_CN zh_HK zh_TW
-BASELOCALEDIR= ${DESTDIR}/usr/share/locale
+BASELOCALEDIR= /usr/share/locale
PLIST_SUB= BASELOCALEDIR=${BASELOCALEDIR} \
LANGS="${LANGS}"
PLIST= ${WRKDIR}/pkg-plist
.include <bsd.port.pre.mk>
-_HAVE_SWIDTH!= ${GREP} _CTYPE_SW ${DESTDIR}/usr/include/ctype.h 2>/dev/null \
+_HAVE_SWIDTH!= ${GREP} _CTYPE_SW /usr/include/ctype.h 2>/dev/null \
|| ${TRUE}
.if empty(_HAVE_SWIDTH)
PKGNAMESUFFIX= -without-swidth