aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-02-24 06:56:57 +0800
committerpav <pav@FreeBSD.org>2004-02-24 06:56:57 +0800
commit4d55dec4767a29bf146474ef22023e4645dbdc0d (patch)
treec94b062cb50ea77c865b6c7d67448cf15a331061 /misc
parent10636708b5dbbbaa3e1bcf98b616e0860fdfc364 (diff)
downloadfreebsd-ports-gnome-4d55dec4767a29bf146474ef22023e4645dbdc0d.tar.gz
freebsd-ports-gnome-4d55dec4767a29bf146474ef22023e4645dbdc0d.tar.zst
freebsd-ports-gnome-4d55dec4767a29bf146474ef22023e4645dbdc0d.zip
- Unbreak on gcc-3.3 (include assert.h)
PR: ports/63081 Submitted by: Willem van Engen <wvengen@stack.nl> (maintainer)
Diffstat (limited to 'misc')
-rw-r--r--misc/cheatah/Makefile8
-rw-r--r--misc/cheatah/files/patch-cheatah.cpp11
-rw-r--r--misc/cheatah/files/patch-cheatsig.cpp11
3 files changed, 23 insertions, 7 deletions
diff --git a/misc/cheatah/Makefile b/misc/cheatah/Makefile
index 850b5b7d39d8..dbf911754e5e 100644
--- a/misc/cheatah/Makefile
+++ b/misc/cheatah/Makefile
@@ -27,16 +27,10 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/apps/X11/cheatah
.include "${.CURDIR}/../sword/Makefile.common"
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile on FreeBSD ${OSVERSION}"
-.endif
-
post-patch:
@${CHMOD} a+x ${WRKSRC}/configure
post-install:
@${STRIP_CMD} ${PREFIX}/bin/cheatah
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/misc/cheatah/files/patch-cheatah.cpp b/misc/cheatah/files/patch-cheatah.cpp
new file mode 100644
index 000000000000..e6f07f99f7f3
--- /dev/null
+++ b/misc/cheatah/files/patch-cheatah.cpp
@@ -0,0 +1,11 @@
+diff -ruN cheatah.cpp cheatah.cpp
+--- cheatah.cpp Thu Feb 19 21:50:28 2004
++++ cheatah.cpp Thu Feb 19 21:50:32 2004
+@@ -28,6 +28,7 @@
+ #include <gbfplain.h>
+ #include <thmlplain.h>
+ #include <string.h>
++#include <assert.h>
+
+ using namespace sword;
+ using namespace std;
diff --git a/misc/cheatah/files/patch-cheatsig.cpp b/misc/cheatah/files/patch-cheatsig.cpp
new file mode 100644
index 000000000000..05c786d36395
--- /dev/null
+++ b/misc/cheatah/files/patch-cheatsig.cpp
@@ -0,0 +1,11 @@
+iff -ruN cheatsig.cpp cheatsig.cpp
+--- cheatsig.cpp Thu Feb 19 21:50:28 2004
++++ cheatsig.cpp Thu Feb 19 21:50:39 2004
+@@ -20,6 +20,7 @@
+ */
+
+ #include <gtk/gtk.h>
++#include <assert.h>
+ #include "cheatah.h"
+ #include "cheatsig.h"
+