aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-03-10 01:15:43 +0800
committerstas <stas@FreeBSD.org>2009-03-10 01:15:43 +0800
commit08bfa7c4aa027efa35afd531304e476e4f713b80 (patch)
tree31b7120f0eb5ff46ed252641018a5ff19ff41fc3 /misc
parent982434000a36499258eff52f7032254355edca7a (diff)
downloadfreebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.tar.gz
freebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.tar.zst
freebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.zip
- Chase libusb20 rename in r189585.
- Mark sane-backends broken on current due to changes in USB stack. Reviewed by: thompsa (old version), miwi Tested by: miwi
Diffstat (limited to 'misc')
-rw-r--r--misc/gplink/Makefile17
-rw-r--r--misc/kdeedu3/Makefile11
-rw-r--r--misc/kdeedu4/Makefile8
3 files changed, 29 insertions, 7 deletions
diff --git a/misc/gplink/Makefile b/misc/gplink/Makefile
index 69464fd924b5..33636aeb4372 100644
--- a/misc/gplink/Makefile
+++ b/misc/gplink/Makefile
@@ -13,14 +13,25 @@ MASTER_SITES= http://gp2x.org/gp32/gplink/
MAINTAINER= ports@FreeBSD.org
COMMENT= A GP32 USB linker tool
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
-
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/src
PLIST_FILES= bin/gplink
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.endif
+
+post-patch:
+.if ${OSVERSION} >= 800069
+ @${REINPLACE_CMD} -E -e 's,`libusb-config --cflags`,,g' \
+ -e 's,`libusb-config --libs`,-lusb,g' \
+ ${WRKSRC}/Makefile
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gplink ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/misc/kdeedu3/Makefile b/misc/kdeedu3/Makefile
index 65c648d7541d..e6e6fd471619 100644
--- a/misc/kdeedu3/Makefile
+++ b/misc/kdeedu3/Makefile
@@ -15,8 +15,7 @@ DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
COMMENT= Collection of entertaining, educational programs for KDE
-LIB_DEPENDS= usb-0.1:${PORTSDIR}/devel/libusb \
- boost_python:${PORTSDIR}/devel/boost-python
+LIB_DEPENDS= boost_python:${PORTSDIR}/devel/boost-python
CONFLICTS+= kwordquiz-[0-9]* kgeography-[0-9]*
@@ -36,9 +35,15 @@ LDCONFIG_DIRS+= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
+.endif
+
pre-configure:
${REINPLACE_CMD} \
-e 's|pylibdir in.*|pylibdir in "${LOCALBASE}/lib" \\|g' \
${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/misc/kdeedu4/Makefile b/misc/kdeedu4/Makefile
index 6bf34c520e14..c88d61bd3d7d 100644
--- a/misc/kdeedu4/Makefile
+++ b/misc/kdeedu4/Makefile
@@ -46,7 +46,13 @@ CMAKE_ARGS+= -DCMAKE_REQUIRED_INCLUDES:STRING="${LOCALBASE}/include" \
-DBOOST_PYTHON_INCLUDES="${LOCALBASE}/include;${PYTHON_INCLUDEDIR}" \
-DBOOST_PYTHON_LIBS="-L${LOCALBASE}/lib -lboost_python -l${PYTHON_VERSION}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
+.endif
+
post-extract:
${MKDIR} ${WRKSRC}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>