aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2012-09-20 22:44:13 +0800
committerbeat <beat@FreeBSD.org>2012-09-20 22:44:13 +0800
commit14433705ef6a53c826257d344cabbbec1dccc215 (patch)
treefd48bf2944afda4d222b634b6f5acce2c4363392 /misc
parentc4c9bfcc24df321f4df1365678f97c55c997abbc (diff)
downloadfreebsd-ports-gnome-14433705ef6a53c826257d344cabbbec1dccc215.tar.gz
freebsd-ports-gnome-14433705ef6a53c826257d344cabbbec1dccc215.tar.zst
freebsd-ports-gnome-14433705ef6a53c826257d344cabbbec1dccc215.zip
- Fix with Tcl/Tk > 8.2 [1]
- Convert to OptionsNG - Drop maintainership PR: ports/171612 [1] Submitted by: gahr [1]
Diffstat (limited to 'misc')
-rw-r--r--misc/dotfile/Makefile19
-rw-r--r--misc/dotfile/files/patch-Generator_types.tcl13
-rw-r--r--misc/dotfile/files/patch-Modules-english-procmail-configure11
-rw-r--r--misc/dotfile/files/patch-af10
-rw-r--r--misc/dotfile/files/patch-ag2
-rw-r--r--misc/dotfile/files/patch-configure13
-rw-r--r--misc/dotfile/pkg-plist1
7 files changed, 42 insertions, 27 deletions
diff --git a/misc/dotfile/Makefile b/misc/dotfile/Makefile
index 16f4e0eceaa9..8bcb0f4792fe 100644
--- a/misc/dotfile/Makefile
+++ b/misc/dotfile/Makefile
@@ -11,7 +11,7 @@ PORTREVISION= 2
CATEGORIES= misc tk
MASTER_SITES= http://www.blackie.dk/dotfile/download/
-MAINTAINER= beat@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= A GUI dotfile generator program to create .config files
BUILD_DEPENDS= formail:${PORTSDIR}/mail/procmail
@@ -22,20 +22,22 @@ NO_BUILD= yes
MAN1= dotfile.1
-OPTIONS= JAPANESE "Use Japanese as default language" off
+OPTIONS_DEFINE= JAPANESE
+JAPANESE_DESC= Use Japanese as default language
-USE_TK= 82
-USE_TK_BUILD= 82
+USE_TK= yes
.include <bsd.port.pre.mk>
-.if defined(WITH_JAPANESE)
+.if ${PORT_OPTIONS:MJAPANESE}
CONFIGURE_ENV+= LANGUAGE="japanese"
.endif
post-patch:
- @${RM} ${WRKSRC}/Modules/english/procmail/configure.orig
- @${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/dotfile
+ @${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g; s|%%WISH%%|wish${TK_VER}|g; \
+ s|%%TCLSH%%|tclsh${TCL_VER}|g" ${WRKSRC}/${CONFIGURE_SCRIPT} \
+ ${WRKSRC}/Generator/makeHelp ${WRKSRC}/Modules/english/procmail/${CONFIGURE_SCRIPT}
+ ${FIND} ${WRKSRC} \( -name "*.orig" -o -name "*.bak" \) -delete
post-configure:
@(cd ${WRKSRC}/Modules/english/procmail && CC="${CC}" ac_cv_path_CC="${CC}" CFLAGS="${CFLAGS}" \
@@ -43,6 +45,9 @@ post-configure:
INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS})
+do-install:
+ cd ${WRKSRC} && ${SETENV} LC_ALL=C ${MAKE} install
+
post-install:
.ifndef(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}/dotfile
diff --git a/misc/dotfile/files/patch-Generator_types.tcl b/misc/dotfile/files/patch-Generator_types.tcl
new file mode 100644
index 000000000000..43fdcef7a526
--- /dev/null
+++ b/misc/dotfile/files/patch-Generator_types.tcl
@@ -0,0 +1,13 @@
+--- Generator/types.tcl.orig 2012-09-13 17:01:08.000000000 +0200
++++ Generator/types.tcl 2012-09-13 17:01:48.000000000 +0200
+@@ -1540,7 +1540,9 @@
+ }
+ }
+ line -
+- header {} ;# please ignore.
++ header {
++ ;# please ignore.
++ }
+ default {
+ warning "setVariable: unknow widget type: \"$type\""
+ }
diff --git a/misc/dotfile/files/patch-Modules-english-procmail-configure b/misc/dotfile/files/patch-Modules-english-procmail-configure
index b806e53e57b6..9243648de0a6 100644
--- a/misc/dotfile/files/patch-Modules-english-procmail-configure
+++ b/misc/dotfile/files/patch-Modules-english-procmail-configure
@@ -1,12 +1,11 @@
---- Modules/english/procmail/configure.orig Sat Feb 19 20:15:42 2000
-+++ Modules/english/procmail/configure Tue Mar 13 12:59:19 2007
-@@ -533,8 +533,7 @@
- echo "----------------------------------------------------------------------"
+--- Modules/english/procmail/configure.orig 2012-09-18 19:44:28.000000000 +0200
++++ Modules/english/procmail/configure 2012-09-18 19:44:42.000000000 +0200
+@@ -534,7 +534,7 @@
echo "----------------------------------------------------------------------"
--
+
-for ac_prog in tclsh7.6 tclsh7.5 tclsh7.4 tclsh
-+for ac_prog in tclsh8.2 tclsh8.1 tclsh8.0 tclsh7.6 tclsh7.5 tclsh7.4 tclsh
++for ac_prog in %%TCLSH%%
do
# Extract the first word of "$ac_prog", so it can be a program name with args.
set dummy $ac_prog; ac_word=$2
diff --git a/misc/dotfile/files/patch-af b/misc/dotfile/files/patch-af
deleted file mode 100644
index 655899763097..000000000000
--- a/misc/dotfile/files/patch-af
+++ /dev/null
@@ -1,10 +0,0 @@
---- dotfile.orig Sun Dec 21 05:40:27 1997
-+++ dotfile Sun Jan 30 19:31:01 2000
-@@ -23,6 +23,6 @@
- echo "http://www.imada.ou.dk/~blackie/dotfile/"
- echo ""
- else
-- exec /usr/local/bin/wish -f Generator/dotfile.tcl Generator Modules/$1 $2
-+ exec %%LOCALBASE%%/bin/wish8.2 -f Generator/dotfile.tcl Generator Modules/$1 $2
- fi
-
diff --git a/misc/dotfile/files/patch-ag b/misc/dotfile/files/patch-ag
index b504f1f9e803..d6eeb2455624 100644
--- a/misc/dotfile/files/patch-ag
+++ b/misc/dotfile/files/patch-ag
@@ -5,4 +5,4 @@
echo "\n\n<h1>---------------</h1>" >> helpfile.data
cat $2 >> helpfile.data
-wish $1/makeHelp.tcl helpfile.data generatedHelp $1
-+wish8.2 $1/makeHelp.tcl helpfile.data generatedHelp $1
++%%WISH%% $1/makeHelp.tcl helpfile.data generatedHelp $1
diff --git a/misc/dotfile/files/patch-configure b/misc/dotfile/files/patch-configure
index 297ea389fde1..5a1363a1f0f6 100644
--- a/misc/dotfile/files/patch-configure
+++ b/misc/dotfile/files/patch-configure
@@ -12,7 +12,16 @@
+ LANGUAGE="english";
+fi
+
-+for ac_prog in wish8.2 wish8.1 wish8.0 wish4.2jp wish4.2 wish4.1jp wish4.1 wish4.0jp wish4.0
++for ac_prog in %%WISH%%
+ do
+ # Extract the first word of "$ac_prog", so it can be a program name with args.
+ set dummy $ac_prog; ac_word=$2
+@@ -679,7 +686,7 @@
+
+
+ if test "$WISH" = ""; then
+- for ac_prog in wish8.2jp wish8.2 wish8.1jp wish8.1 wish8.0jp wish8.0 wish4.2jp wish4.2 wish4.1jp wish4.1 wish4.0jp wish4.0 wish
++ for ac_prog in %%WISH%%
do
# Extract the first word of "$ac_prog", so it can be a program name with args.
set dummy $ac_prog; ac_word=$2
@@ -21,7 +30,7 @@
fi
fi
-for ac_prog in tclsh8.2jp tclsh8.2 tclsh8.1jp tclsh8.1 tclsh8.0jp tclsh8.0 tclsh7.6jp tclsh7.6 tclsh7.5jp tclsh7.5 tclsh7.4jp tclsh7.4 tclsh
-+for ac_prog in tclsh8.2 tclsh8.2jp tclsh8.1 tclsh8.0jp tclsh8.0 tclsh7.6jp tclsh7.6 tclsh7.5jp tclsh7.5 tclsh7.4jp tclsh7.4 tclsh
++for ac_prog in %%TCLSH%%
do
# Extract the first word of "$ac_prog", so it can be a program name with args.
set dummy $ac_prog; ac_word=$2
diff --git a/misc/dotfile/pkg-plist b/misc/dotfile/pkg-plist
index eb2e766e7a55..eccdc5f3fa62 100644
--- a/misc/dotfile/pkg-plist
+++ b/misc/dotfile/pkg-plist
@@ -42,7 +42,6 @@ lib/%%DISTNAME%%/Generator/language.tcl
lib/%%DISTNAME%%/Generator/load.tcl
lib/%%DISTNAME%%/Generator/mail.tcl
lib/%%DISTNAME%%/Generator/makeHelp
-lib/%%DISTNAME%%/Generator/makeHelp.orig
lib/%%DISTNAME%%/Generator/makeHelp.tcl
lib/%%DISTNAME%%/Generator/menus.tcl
lib/%%DISTNAME%%/Generator/parse.tcl