aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-02-07 22:49:27 +0800
committermiwi <miwi@FreeBSD.org>2013-02-07 22:49:27 +0800
commit206e2fcce10248465a2aec827354527a120901eb (patch)
tree6dbe555152b7867d7e2cb6e34de07674f41b4a46 /misc
parentf8ae521649ea288e7d168fc3b16559ad40f45d98 (diff)
downloadfreebsd-ports-gnome-206e2fcce10248465a2aec827354527a120901eb.tar.gz
freebsd-ports-gnome-206e2fcce10248465a2aec827354527a120901eb.tar.zst
freebsd-ports-gnome-206e2fcce10248465a2aec827354527a120901eb.zip
- Fix build with clang
- Add LICENSE - Trim header PR: 175026 Submitted by: Ports Fury
Diffstat (limited to 'misc')
-rw-r--r--misc/wmfirew/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/misc/wmfirew/Makefile b/misc/wmfirew/Makefile
index 8b363159b17b..6740d69c2e0f 100644
--- a/misc/wmfirew/Makefile
+++ b/misc/wmfirew/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wmfirew
-# Date created: 16 May 2002
-# Whom: Alexey Dokuchaev <danfe@regency.nsu.ru>
-#
+# Created by: Alexey Dokuchaev <danfe@regency.nsu.ru>
# $FreeBSD$
-#
PORTNAME= wmfirew
PORTVERSION= 0.20
@@ -19,7 +15,11 @@ WRKSRC= ${WRKDIR}/${PORTNAME}.app/${PORTNAME}
USE_GMAKE= yes
USE_XORG= xpm
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^void main|int main|' ${WRKSRC}/wmfirew.c
+
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${PORTNAME} ${PREFIX}/bin)
.include <bsd.port.mk>