aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-10-23 05:49:21 +0800
committermarcus <marcus@FreeBSD.org>2006-10-23 05:49:21 +0800
commit3d59610899ca949bc01c0da71ea1f3b232330215 (patch)
treea36bccc1662abb060b958ee880efe9aa43740c37 /misc
parentbd6850b5b5537ade5bffa9cc21be1ce05b670be2 (diff)
downloadfreebsd-ports-gnome-3d59610899ca949bc01c0da71ea1f3b232330215.tar.gz
freebsd-ports-gnome-3d59610899ca949bc01c0da71ea1f3b232330215.tar.zst
freebsd-ports-gnome-3d59610899ca949bc01c0da71ea1f3b232330215.zip
To maintain compatibility with KDE (now that KDE relies on this port),
install a sentinel .keep_me file in each directory to prevent @dirrmtry's from removing directories owned by hicolor-icon-theme. Submitted by: Andy Fawcett <andy@athame.co.uk> Approved by: portmgr (implicit)
Diffstat (limited to 'misc')
-rw-r--r--misc/hicolor-icon-theme/Makefile28
1 files changed, 25 insertions, 3 deletions
diff --git a/misc/hicolor-icon-theme/Makefile b/misc/hicolor-icon-theme/Makefile
index 85deee7862f5..d47d3ab198d0 100644
--- a/misc/hicolor-icon-theme/Makefile
+++ b/misc/hicolor-icon-theme/Makefile
@@ -8,7 +8,7 @@
PORTNAME= hicolor-icon-theme
PORTVERSION= 0.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc gnome
MASTER_SITES= http://icon-theme.freedesktop.org/releases/
@@ -45,8 +45,18 @@ pre-install:
. for ctxt in ${ICON_CONTEXTS}
if [ "${ctxt}" = "stock" ] ; then \
for sub in ${STOCK_SUBS} ; do \
- ${ECHO_CMD} "@dirrmtry ${ICON_DIR}/${dir}/${ctxt}/$${sub}" >> ${PLIST} ; \
- done \
+ ${ECHO_CMD} "${ICON_DIR}/${dir}/${ctxt}/$${sub}/.keep_me" >> ${PLIST} ; \
+ done ; \
+ fi
+ ${ECHO_CMD} "${ICON_DIR}/${dir}/${ctxt}/.keep_me" >> ${PLIST} ;
+. endfor
+.endfor
+.for dir in ${ICON_SIZES}
+. for ctxt in ${ICON_CONTEXTS}
+ if [ "${ctxt}" = "stock" ] ; then \
+ for sub in ${STOCK_SUBS} ; do \
+ ${ECHO_CMD} "@dirrmtry ${ICON_DIR}/${dir}/${ctxt}/$${sub}" >> ${PLIST} ; \
+ done ; \
fi
${ECHO_CMD} "@dirrmtry ${ICON_DIR}/${dir}/${ctxt}" >> ${PLIST}
. endfor
@@ -55,4 +65,16 @@ pre-install:
${ECHO_CMD} "@dirrmtry ${ICON_DIR}" >> ${PLIST}
${ECHO_CMD} "@dirrmtry share/icons" >> ${PLIST}
+post-install:
+.for dir in ${ICON_SIZES}
+. for ctxt in ${ICON_CONTEXTS}
+ if [ "${ctxt}" = "stock" ] ; then \
+ for sub in ${STOCK_SUBS} ; do \
+ ${TOUCH} ${PREFIX}/${ICON_DIR}/${dir}/${ctxt}/$${sub}/.keep_me ; \
+ done ; \
+ fi
+ ${TOUCH} ${PREFIX}/${ICON_DIR}/${dir}/${ctxt}/.keep_me
+. endfor
+.endfor
+
.include <bsd.port.post.mk>