aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorstefan <stefan@FreeBSD.org>2008-10-21 22:40:45 +0800
committerstefan <stefan@FreeBSD.org>2008-10-21 22:40:45 +0800
commit4a626b88ec08b12ff7e49ce3f0d939fb5f35570b (patch)
treebc903b4c8b280f1271f67b6ca05c98b49a1100ae /misc
parent71b01b3bf2b22c18dedfdbccdb60701f47d5f461 (diff)
downloadfreebsd-ports-gnome-4a626b88ec08b12ff7e49ce3f0d939fb5f35570b.tar.gz
freebsd-ports-gnome-4a626b88ec08b12ff7e49ce3f0d939fb5f35570b.tar.zst
freebsd-ports-gnome-4a626b88ec08b12ff7e49ce3f0d939fb5f35570b.zip
Add hardware support for recent usb devices.
PR: 126839 Submitted by: Steve Franks <stevefranks@ieee.org> Approved by: maintainer timeout (2 months)
Diffstat (limited to 'misc')
-rw-r--r--misc/ezload/Makefile1
-rw-r--r--misc/ezload/files/patch-ezdownload-ezdownload.c39
2 files changed, 40 insertions, 0 deletions
diff --git a/misc/ezload/Makefile b/misc/ezload/Makefile
index 360d483d177d..feb401c37967 100644
--- a/misc/ezload/Makefile
+++ b/misc/ezload/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ezload
PORTVERSION= 0.4.0
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://proj.bpsw.biz/ezload/downloads/
diff --git a/misc/ezload/files/patch-ezdownload-ezdownload.c b/misc/ezload/files/patch-ezdownload-ezdownload.c
new file mode 100644
index 000000000000..41340f8e9a65
--- /dev/null
+++ b/misc/ezload/files/patch-ezdownload-ezdownload.c
@@ -0,0 +1,39 @@
+--- ezdownload/ezdownload.c.orig 2004-12-24 00:14:43.000000000 +0100
++++ ezdownload/ezdownload.c 2008-10-21 16:35:22.000000000 +0200
+@@ -96,7 +96,7 @@
+ /* See http://www.anchorchips.com for the
+ * EZ-USB Technical Reference Manual (EZUSB_TRM.pdf).
+ */
+-#define CPUCS 0x7f92
++static unsigned int CPUCS = 0x7f92;
+ #define USBSC 0x7fd6
+
+ /* This whole reading routine sucks. you could do it in
+@@ -340,7 +340,7 @@
+ char * progname;
+ void usage()
+ {
+- fprintf(stderr, "Syntax: %s [-r] [-v] [-f hexfile] device\n", progname);
++ fprintf(stderr, "Syntax: %s [-r] [-v] [-2] [-f hexfile] device\n", progname);
+ exit(1);
+ }
+
+@@ -363,7 +363,7 @@
+ progname = argv[0];
+
+ /* handle the arguments */
+- while((ch = getopt(argc, argv, "xrvf:")) != -1)
++ while((ch = getopt(argc, argv, "2xrvf:")) != -1)
+ switch (ch) {
+ case 'v':
+ verbose++;
+@@ -374,6 +374,9 @@
+ case 'f':
+ hexfile = optarg;
+ break;
++ case '2':
++ CPUCS = 0xe600;
++ break;
+ case 'x':
+ force = 1;
+ break;