aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2006-02-09 23:49:06 +0800
committernovel <novel@FreeBSD.org>2006-02-09 23:49:06 +0800
commitbaadc904dac8441113ac2254ae680d91650a14c1 (patch)
tree61c8ba7531b90f0a31aceed965f307e469de7da0 /misc
parent9893c630f3230e08729286cfcce82c5fdf668e8d (diff)
downloadfreebsd-ports-gnome-baadc904dac8441113ac2254ae680d91650a14c1.tar.gz
freebsd-ports-gnome-baadc904dac8441113ac2254ae680d91650a14c1.tar.zst
freebsd-ports-gnome-baadc904dac8441113ac2254ae680d91650a14c1.zip
- gdk-pixbuf and gtk12 are required only for xmms plugin, so depend
on gdk-pixbuf only if building xmms plugin and remove gtk12 dependency as it would be catched up xmms. - Don't print sed's output PR: 92347 Submitted by: novel Approved by: maintainer timeout (2 weeks)
Diffstat (limited to 'misc')
-rw-r--r--misc/xosd/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/misc/xosd/Makefile b/misc/xosd/Makefile
index 81a12593b14b..1fafca1aea58 100644
--- a/misc/xosd/Makefile
+++ b/misc/xosd/Makefile
@@ -15,14 +15,11 @@ MASTER_SITE_SUBDIR= perky
MAINTAINER= perky@FreeBSD.org
COMMENT= X On-Screen-Display Library and XMMS plug-in
-LIB_DEPENDS= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
-
XMMS_CONFIG?= ${X11BASE}/bin/xmms-config
USE_BZIP2= yes
USE_GETOPT_LONG=yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gtk12
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
@@ -44,7 +41,8 @@ OPTIONS= XMMS "Install XMMS-OSD plugin" on
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_XMMS)
-LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
+LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms \
+ gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
PLIST_SUB= WITH_XMMS=""
.else
CONFIGURE_ARGS= --disable-new-plugin
@@ -52,10 +50,10 @@ PLIST_SUB= WITH_XMMS="@comment "
.endif
pre-patch:
- ${REINPLACE_CMD} -e 's,-lc_r,-lblahblah,g' ${WRKSRC}/ltmain.sh
- ${REINPLACE_CMD} -e 's,-lpthread,${PTHREAD_LIBS},g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's,-lc_r,-lblahblah,g' ${WRKSRC}/ltmain.sh
+ @${REINPLACE_CMD} -e 's,-lpthread,${PTHREAD_LIBS},g' ${WRKSRC}/configure
.for f in src/libxosd/Makefile.in src/xmms_plugin/Makefile.in
- ${REINPLACE_CMD} -e 's,^\(CFLAGS =\)\(.*\)$$,\1 -I.. \2,g' ${WRKSRC}/$f
+ @${REINPLACE_CMD} -e 's,^\(CFLAGS =\)\(.*\)$$,\1 -I.. \2,g' ${WRKSRC}/$f
.endfor
.include <bsd.port.post.mk>