aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-09-24 12:53:11 +0800
committerswills <swills@FreeBSD.org>2014-09-24 12:53:11 +0800
commitcc6f317df4a6c97e99491323185125521d28051b (patch)
tree8367c901990e887a8610a93ac539d7a51afdb7f1 /misc
parent40e0ca8841eadd7e95427fcb6625732604389ade (diff)
downloadfreebsd-ports-gnome-cc6f317df4a6c97e99491323185125521d28051b.tar.gz
freebsd-ports-gnome-cc6f317df4a6c97e99491323185125521d28051b.tar.zst
freebsd-ports-gnome-cc6f317df4a6c97e99491323185125521d28051b.zip
misc/exercism: create port for exercism.io cli client
An easy command line interface to work with exercism.io WWW: http://exercism.io/
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/exercism/Makefile33
-rw-r--r--misc/exercism/distinfo4
-rw-r--r--misc/exercism/pkg-descr3
4 files changed, 41 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 4a98b965813b..87c7c2e69f75 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -74,6 +74,7 @@
SUBDIR += esniper
SUBDIR += estic
SUBDIR += excel-writer
+ SUBDIR += exercism
SUBDIR += explosions
SUBDIR += fbless
SUBDIR += felis
diff --git a/misc/exercism/Makefile b/misc/exercism/Makefile
new file mode 100644
index 000000000000..0da4d5dced7d
--- /dev/null
+++ b/misc/exercism/Makefile
@@ -0,0 +1,33 @@
+# Created by: Steve Wills <swills@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= exercism
+PORTVERSION= 1.7.1
+CATEGORIES= misc
+MASTER_SITES= https://github.com/${PORTNAME}/cli/archive/v${PORTVERSION}.tar.gz?dummy=/:group1 \
+ https://codeload.github.com/codegangsta/cli/legacy.tar.gz/f7ebb76?dummy=/:group2
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:group1 \
+ codegansta-cli-f7ebb76${EXTRACT_SUFX}:group2
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= CLI client for exercism.io
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/go:${PORTSDIR}/lang/go
+
+WRKSRC= ${WRKDIR}/cli-${PORTVERSION}
+
+PLIST_FILES= bin/exercism
+
+post-patch:
+ cd ${WRKSRC} ; ${MKDIR} src/github.com/codegangsta \
+ src/github.com/exercism/cli ; \
+ ${MV} ${WRKDIR}/codegangsta-cli-f7ebb76 ${WRKSRC}/src/github.com/codegangsta/cli ; \
+ ${CP} -r api handlers config src/github.com/exercism/cli
+
+do-build:
+ cd ${WRKSRC} ; ${SETENV} GOPATH=${WRKSRC} go build -o exercism
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/exercism ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/misc/exercism/distinfo b/misc/exercism/distinfo
new file mode 100644
index 000000000000..61fc728fc92e
--- /dev/null
+++ b/misc/exercism/distinfo
@@ -0,0 +1,4 @@
+SHA256 (exercism-1.7.1.tar.gz) = 47357e762f80797071311c6057724ad7b315cd5b11b9dd751fe68012e5db38b4
+SIZE (exercism-1.7.1.tar.gz) = 11877
+SHA256 (codegansta-cli-f7ebb76.tar.gz) = 216232029c7f391a9312493f4a2b66b2fffa8f4fcee5104bfff7847d5683ee6e
+SIZE (codegansta-cli-f7ebb76.tar.gz) = 15185
diff --git a/misc/exercism/pkg-descr b/misc/exercism/pkg-descr
new file mode 100644
index 000000000000..81c97e5cfd6f
--- /dev/null
+++ b/misc/exercism/pkg-descr
@@ -0,0 +1,3 @@
+An easy command line interface to work with exercism.io
+
+WWW: http://exercism.io/