aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-08-05 02:33:45 +0800
committermarcus <marcus@FreeBSD.org>2004-08-05 02:33:45 +0800
commitd29d2613e421d23a7bb48fc2dc0c47644bd2e788 (patch)
tree588cfb700513a751382db0df2a8e87a46ccaf020 /misc
parentfb0a62d8f1db4c0e5ce654d62c618ff2f0a924d8 (diff)
downloadfreebsd-ports-gnome-d29d2613e421d23a7bb48fc2dc0c47644bd2e788.tar.gz
freebsd-ports-gnome-d29d2613e421d23a7bb48fc2dc0c47644bd2e788.tar.zst
freebsd-ports-gnome-d29d2613e421d23a7bb48fc2dc0c47644bd2e788.zip
Sync the MIME search directories from gnome-vfs. This fixes some
prioritization issues with custom MIME types.
Diffstat (limited to 'misc')
-rw-r--r--misc/shared-mime-info/Makefile2
-rw-r--r--misc/shared-mime-info/files/patch-update-mime-database.c2
2 files changed, 2 insertions, 2 deletions
diff --git a/misc/shared-mime-info/Makefile b/misc/shared-mime-info/Makefile
index bfed1195e114..b4a7d1cf0a01 100644
--- a/misc/shared-mime-info/Makefile
+++ b/misc/shared-mime-info/Makefile
@@ -6,7 +6,7 @@
PORTNAME= shared-mime-info
PORTVERSION= 0.14
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= misc gnome
MASTER_SITES= http://www.freedesktop.org/software/shared-mime-info/
DISTNAME= shared-mime-info-${PORTVERSION}
diff --git a/misc/shared-mime-info/files/patch-update-mime-database.c b/misc/shared-mime-info/files/patch-update-mime-database.c
index b7f0459abec4..d312ea0295b5 100644
--- a/misc/shared-mime-info/files/patch-update-mime-database.c
+++ b/misc/shared-mime-info/files/patch-update-mime-database.c
@@ -15,7 +15,7 @@
env = getenv("XDG_DATA_DIRS");
if (!env)
- env = "/usr/local/share/:/usr/share/";
-+ env = "/usr/local/share/:%%X11BASE%%/share/:/usr/share/";
++ env = "%%X11BASE%%/share/gnome/:/usr/local/share/gnome/:%%X11BASE%%/share/:/usr/local/share/:/usr/share/";
dirs = g_strsplit(env, ":", 0);
g_return_if_fail(dirs != NULL);
for (n = 0; dirs[n]; n++)