aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2018-02-19 19:10:43 +0800
committerantoine <antoine@FreeBSD.org>2018-02-19 19:10:43 +0800
commit16a04e9b881e61b48e43444a26db1c5e401d7efc (patch)
tree94eaef37ab07d82e499ae4cafabe202ea2ed0525 /misc
parenta7c90a608e4fee40a557fa793e68d2e26c67c1ed (diff)
downloadfreebsd-ports-gnome-16a04e9b881e61b48e43444a26db1c5e401d7efc.tar.gz
freebsd-ports-gnome-16a04e9b881e61b48e43444a26db1c5e401d7efc.tar.zst
freebsd-ports-gnome-16a04e9b881e61b48e43444a26db1c5e401d7efc.zip
Reduce dependency on the python2 metaport
PR: 225752 Submitted by: Yasuhiro KIMURA
Diffstat (limited to 'misc')
-rw-r--r--misc/gimp-help-en/Makefile3
-rw-r--r--misc/py-progressbar231/Makefile3
-rw-r--r--misc/py-python-geohash/Makefile3
-rw-r--r--misc/py-yolk/Makefile4
-rw-r--r--misc/typetrainer/Makefile4
-rw-r--r--misc/wotsap/Makefile4
6 files changed, 12 insertions, 9 deletions
diff --git a/misc/gimp-help-en/Makefile b/misc/gimp-help-en/Makefile
index 6babed3c1866..403482c5a3c7 100644
--- a/misc/gimp-help-en/Makefile
+++ b/misc/gimp-help-en/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gimp-help
PORTVERSION= 2.8.2
+PORTREVISION= 1
CATEGORIES?= misc graphics
MASTER_SITES= http://gimp.mirrors.hoobly.com/pub/%SUBDIR%/ \
http://ftp.gwdg.de/pub/misc/grafik/%SUBDIR%/ \
@@ -19,7 +20,7 @@ LICENSE= GFDL
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2mod.so:textproc/py-libxml2@${PY_FLAVOR} \
${LOCALBASE}/share/xsl/docbook/xhtml/chunk.xsl:textproc/docbook-xsl
-USES= gettext-tools gmake perl5 pkgconfig python:2 shebangfix tar:bzip2
+USES= gettext-tools gmake perl5 pkgconfig python:2.7 shebangfix tar:bzip2
USE_GNOME= libxslt:build
USE_PERL5= build
GNU_CONFIGURE= yes
diff --git a/misc/py-progressbar231/Makefile b/misc/py-progressbar231/Makefile
index 8daaa003af17..5733ee606927 100644
--- a/misc/py-progressbar231/Makefile
+++ b/misc/py-progressbar231/Makefile
@@ -2,6 +2,7 @@
PORTNAME= progressbar231
PORTVERSION= 2.3.1
+PORTREVISION= 1
CATEGORIES= misc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +13,7 @@ COMMENT= Text progressbar library for python
LICENSE= BSD3CLAUSE
USE_PYTHON= autoplist distutils
-USES= python:2
+USES= python:2.7
CONFLICTS= py*-progressbar
diff --git a/misc/py-python-geohash/Makefile b/misc/py-python-geohash/Makefile
index eb5088e0ecdf..949884ce10f5 100644
--- a/misc/py-python-geohash/Makefile
+++ b/misc/py-python-geohash/Makefile
@@ -3,6 +3,7 @@
PORTNAME= python-geohash
PORTVERSION= 0.8.5
+PORTREVISION= 1
CATEGORIES= misc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +14,7 @@ COMMENT= Fast, accurate python geohashing library
LICENSE= APACHE20 MIT BSD3CLAUSE
LICENSE_COMB= multi
-USES= python:2
+USES= python:2.7
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>
diff --git a/misc/py-yolk/Makefile b/misc/py-yolk/Makefile
index 9b1698f4ba99..ffe66e08540c 100644
--- a/misc/py-yolk/Makefile
+++ b/misc/py-yolk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= yolk
PORTVERSION= 0.4.3
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= misc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +13,7 @@ COMMENT= Command-line tool for querying PyPI and Python packages installed
LICENSE= BSD3CLAUSE
-USES= python:2
+USES= python:2.7
USE_PYTHON= distutils autoplist
OPTIONS_DEFINE= EXAMPLES
diff --git a/misc/typetrainer/Makefile b/misc/typetrainer/Makefile
index eefea301e8c1..805d0642813f 100644
--- a/misc/typetrainer/Makefile
+++ b/misc/typetrainer/Makefile
@@ -2,7 +2,7 @@
PORTNAME= typetrainer
PORTVERSION= 0.5.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc python
MASTER_SITES= CHEESESHOP
@@ -12,7 +12,7 @@ COMMENT= Typing tutor trainer
LICENSE= MIT
USE_GNOME= pygtk2
-USES= python:2
+USES= python:2.7
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/misc/wotsap/Makefile b/misc/wotsap/Makefile
index 08193675701a..c764278b701c 100644
--- a/misc/wotsap/Makefile
+++ b/misc/wotsap/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wotsap
PORTVERSION= 0.7
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc
MASTER_SITES= http://www.lysator.liu.se/~jc/wotsap/download/
EXTRACT_SUFX= .tgz
@@ -13,7 +13,7 @@ COMMENT= Web of trust statistics and pathfinder
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
-USES= python:2,run shebangfix
+USES= python:2.7,run shebangfix
NO_BUILD= yes
SHEBANG_FILES= wotsap pks2wot