aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2007-01-30 02:59:51 +0800
committersobomax <sobomax@FreeBSD.org>2007-01-30 02:59:51 +0800
commit1f6dd6334f485c4249428d52a0f802611c74d385 (patch)
treedd4d51c063979187d57353e42aada973add14a0a /misc
parenta8ca249102a9e2e036e05586b54f634df5575561 (diff)
downloadfreebsd-ports-gnome-1f6dd6334f485c4249428d52a0f802611c74d385.tar.gz
freebsd-ports-gnome-1f6dd6334f485c4249428d52a0f802611c74d385.tar.zst
freebsd-ports-gnome-1f6dd6334f485c4249428d52a0f802611c74d385.zip
Fix the panic: sleeping without a mutex problem on CURRENT.
PR: ports/101958 Submitted by: Anish Mistry
Diffstat (limited to 'misc')
-rw-r--r--misc/zaptel/Makefile1
-rw-r--r--misc/zaptel/files/patch-zaptel::zaptel.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/misc/zaptel/Makefile b/misc/zaptel/Makefile
index d4d6dd8f7658..7c2bc363a5de 100644
--- a/misc/zaptel/Makefile
+++ b/misc/zaptel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= zaptel
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://www.pbxpress.com/~gonzo/
DISTNAME= ${PORTNAME}-bsd-${PORTVERSION}
diff --git a/misc/zaptel/files/patch-zaptel::zaptel.c b/misc/zaptel/files/patch-zaptel::zaptel.c
new file mode 100644
index 000000000000..6942f8fbdbe6
--- /dev/null
+++ b/misc/zaptel/files/patch-zaptel::zaptel.c
@@ -0,0 +1,11 @@
+--- zaptel/zaptel.c.orig Sun Jun 25 14:21:49 2006
++++ zaptel/zaptel.c Fri Aug 11 11:56:20 2006
+@@ -397,7 +397,7 @@
+
+ int schluffen(void *q)
+ {
+- int rc = tsleep(q, PZERO | PCATCH, "schluffen", 0);
++ int rc = tsleep(q, PZERO | PCATCH, "schluffen", 10);
+ switch(rc)
+ {
+ case EINTR: