aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-03-09 03:48:41 +0800
committermat <mat@FreeBSD.org>2018-03-09 03:48:41 +0800
commit3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /misc
parentbd4297a179c7edf0fe5800bb82c677771f17923c (diff)
downloadfreebsd-ports-gnome-3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e.tar.gz
freebsd-ports-gnome-3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e.tar.zst
freebsd-ports-gnome-3de11f75e95b0f2dda0d4e2d1bed3fca9fd4925e.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Diffstat (limited to 'misc')
-rw-r--r--misc/pear-Services_Weather/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/misc/pear-Services_Weather/Makefile b/misc/pear-Services_Weather/Makefile
index fab195acef8e..c5aa7cc7b676 100644
--- a/misc/pear-Services_Weather/Makefile
+++ b/misc/pear-Services_Weather/Makefile
@@ -11,7 +11,7 @@ COMMENT= PEAR interface to various online weather-services
LICENSE= BSD2CLAUSE
-RUN_DEPENDS= ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request
+RUN_DEPENDS= ${PEARDIR}/HTTP/Request.php:www/pear-HTTP_Request@${PHP_FLAVOR}
PORTSCOUT= skipv:1.4.7
@@ -26,10 +26,10 @@ PEAR_DB_DESC= PEAR::DB support
PEAR_SOAP_DESC= PEAR::SOAP support
PEAR_XML_SERIALIZER_DESC= PEAR::XML::Serializer support
-PEAR_NET_FTP_BUILD_DEPENDS= ${PEARDIR}/Net/FTP.php:ftp/pear-Net_FTP
-PEAR_CACHE_BUILD_DEPENDS= ${PEARDIR}/Cache.php:sysutils/pear-Cache
-PEAR_DB_BUILD_DEPENDS= ${PEARDIR}/DB.php:databases/pear-DB
-PEAR_SOAP_BUILD_DEPENDS=${PEARDIR}/SOAP/Base.php:net/pear-SOAP
-PEAR_XML_SERIALIZER_BUILD_DEPENDS= ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer
+PEAR_NET_FTP_BUILD_DEPENDS= ${PEARDIR}/Net/FTP.php:ftp/pear-Net_FTP@${PHP_FLAVOR}
+PEAR_CACHE_BUILD_DEPENDS= ${PEARDIR}/Cache.php:sysutils/pear-Cache@${PHP_FLAVOR}
+PEAR_DB_BUILD_DEPENDS= ${PEARDIR}/DB.php:databases/pear-DB@${PHP_FLAVOR}
+PEAR_SOAP_BUILD_DEPENDS=${PEARDIR}/SOAP/Base.php:net/pear-SOAP@${PHP_FLAVOR}
+PEAR_XML_SERIALIZER_BUILD_DEPENDS= ${PEARDIR}/XML/Serializer.php:devel/pear-XML_Serializer@${PHP_FLAVOR}
.include <bsd.port.mk>