aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2017-05-31 20:59:08 +0800
committerkwm <kwm@FreeBSD.org>2017-05-31 20:59:08 +0800
commit49cf57235a609521586ee736a6ba113b6430a032 (patch)
tree146195bd74077a0e74e455c3a40dafa94c2d39f8 /misc
parentd53f14f20216e7753fd9cd5fa4aafec813660356 (diff)
downloadfreebsd-ports-gnome-49cf57235a609521586ee736a6ba113b6430a032.tar.gz
freebsd-ports-gnome-49cf57235a609521586ee736a6ba113b6430a032.tar.zst
freebsd-ports-gnome-49cf57235a609521586ee736a6ba113b6430a032.zip
Add unicode-ucd.
The Unicode Character Database (UCD) consists of a number of data files listing Unicode character properties and related data. It also includes data files containing test data for conformance to several important Unicode algorithms. Also contains the data files for the Unified Han database of Hanzi/Kanji/Hanja Chinese characters.
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/unicode-ucd/Makefile30
-rw-r--r--misc/unicode-ucd/distinfo5
-rw-r--r--misc/unicode-ucd/pkg-descr9
-rw-r--r--misc/unicode-ucd/pkg-plist71
5 files changed, 116 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index dbf8e9b78ca3..2526d41ceb28 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -474,6 +474,7 @@
SUBDIR += uk-postcodes
SUBDIR += umodunpack
SUBDIR += unclutter
+ SUBDIR += unicode-ucd
SUBDIR += upclient
SUBDIR += us-zipcodes
SUBDIR += usbids
diff --git a/misc/unicode-ucd/Makefile b/misc/unicode-ucd/Makefile
new file mode 100644
index 000000000000..efe711b36223
--- /dev/null
+++ b/misc/unicode-ucd/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= unicode-ucd
+PORTVERSION= 9.0.0
+CATEGORIES= misc
+MASTER_SITES= http://www.unicode.org/Public/zipped/${PORTVERSION}/
+DISTFILES= UCD.zip \
+ Unihan.zip
+DIST_SUBDIR= unicode/${PORTVERSION}
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Unicode Character Database
+
+# https://fedoraproject.org/wiki/Licensing/MIT#Modern_Style_without_sublicense_.28Unicode.29
+LICENSE= MIT
+
+USES= zip
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/${PORTNAME}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} . \
+ ${STAGEDIR}${PREFIX}/share/${PORTNAME}/
+# we unpack Unihan.zip but gucharmap wants the Unihan.zip to be present
+ ${INSTALL_DATA} ${DISTDIR}${DIST_SUBDIR}/Unihan.zip \
+ ${STAGEDIR}${PREFIX}/share/${PORTNAME}/
+
+.include <bsd.port.mk>
diff --git a/misc/unicode-ucd/distinfo b/misc/unicode-ucd/distinfo
new file mode 100644
index 000000000000..2c94d424e414
--- /dev/null
+++ b/misc/unicode-ucd/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1470738390
+SHA256 (unicode/9.0.0/UCD.zip) = df9e028425816fd5117eaea7173704056f88f7cd030681e457c6f3827f9390ec
+SIZE (unicode/9.0.0/UCD.zip) = 5655592
+SHA256 (unicode/9.0.0/Unihan.zip) = 6afdd48fb3c5d79a527ed27ce2582b2f684c09e16f5d0837fe7e5b0204f46362
+SIZE (unicode/9.0.0/Unihan.zip) = 6558824
diff --git a/misc/unicode-ucd/pkg-descr b/misc/unicode-ucd/pkg-descr
new file mode 100644
index 000000000000..85bf44399451
--- /dev/null
+++ b/misc/unicode-ucd/pkg-descr
@@ -0,0 +1,9 @@
+The Unicode Character Database (UCD) consists of a number of data files
+listing Unicode character properties and related data. It also includes
+data files containing test data for conformance to several important
+Unicode algorithms.
+
+This package contains Unihan.zip which contains the data files for the
+Unified Han database of Hanzi/Kanji/Hanja Chinese characters.
+
+WWW: http://www.unicode.org/ucd/
diff --git a/misc/unicode-ucd/pkg-plist b/misc/unicode-ucd/pkg-plist
new file mode 100644
index 000000000000..9c25c3b8dc51
--- /dev/null
+++ b/misc/unicode-ucd/pkg-plist
@@ -0,0 +1,71 @@
+%%DATADIR%%/ArabicShaping.txt
+%%DATADIR%%/BidiBrackets.txt
+%%DATADIR%%/BidiCharacterTest.txt
+%%DATADIR%%/BidiMirroring.txt
+%%DATADIR%%/BidiTest.txt
+%%DATADIR%%/Blocks.txt
+%%DATADIR%%/CJKRadicals.txt
+%%DATADIR%%/CaseFolding.txt
+%%DATADIR%%/CompositionExclusions.txt
+%%DATADIR%%/DerivedAge.txt
+%%DATADIR%%/DerivedCoreProperties.txt
+%%DATADIR%%/DerivedNormalizationProps.txt
+%%DATADIR%%/EastAsianWidth.txt
+%%DATADIR%%/EmojiSources.txt
+%%DATADIR%%/HangulSyllableType.txt
+%%DATADIR%%/Index.txt
+%%DATADIR%%/IndicPositionalCategory.txt
+%%DATADIR%%/IndicSyllabicCategory.txt
+%%DATADIR%%/Jamo.txt
+%%DATADIR%%/LineBreak.txt
+%%DATADIR%%/NameAliases.txt
+%%DATADIR%%/NamedSequences.txt
+%%DATADIR%%/NamedSequencesProv.txt
+%%DATADIR%%/NamesList.html
+%%DATADIR%%/NamesList.txt
+%%DATADIR%%/NormalizationCorrections.txt
+%%DATADIR%%/NormalizationTest.txt
+%%DATADIR%%/PropList.txt
+%%DATADIR%%/PropertyAliases.txt
+%%DATADIR%%/PropertyValueAliases.txt
+%%DATADIR%%/ReadMe.txt
+%%DATADIR%%/ScriptExtensions.txt
+%%DATADIR%%/Scripts.txt
+%%DATADIR%%/SpecialCasing.txt
+%%DATADIR%%/StandardizedVariants.html
+%%DATADIR%%/StandardizedVariants.txt
+%%DATADIR%%/TangutSources.txt
+%%DATADIR%%/USourceData.txt
+%%DATADIR%%/USourceGlyphs.pdf
+%%DATADIR%%/UnicodeData.txt
+%%DATADIR%%/Unihan.zip
+%%DATADIR%%/Unihan_DictionaryIndices.txt
+%%DATADIR%%/Unihan_DictionaryLikeData.txt
+%%DATADIR%%/Unihan_IRGSources.txt
+%%DATADIR%%/Unihan_NumericValues.txt
+%%DATADIR%%/Unihan_OtherMappings.txt
+%%DATADIR%%/Unihan_RadicalStrokeCounts.txt
+%%DATADIR%%/Unihan_Readings.txt
+%%DATADIR%%/Unihan_Variants.txt
+%%DATADIR%%/auxiliary/GraphemeBreakProperty.txt
+%%DATADIR%%/auxiliary/GraphemeBreakTest.html
+%%DATADIR%%/auxiliary/GraphemeBreakTest.txt
+%%DATADIR%%/auxiliary/LineBreakTest.html
+%%DATADIR%%/auxiliary/LineBreakTest.txt
+%%DATADIR%%/auxiliary/SentenceBreakProperty.txt
+%%DATADIR%%/auxiliary/SentenceBreakTest.html
+%%DATADIR%%/auxiliary/SentenceBreakTest.txt
+%%DATADIR%%/auxiliary/WordBreakProperty.txt
+%%DATADIR%%/auxiliary/WordBreakTest.html
+%%DATADIR%%/auxiliary/WordBreakTest.txt
+%%DATADIR%%/extracted/DerivedBidiClass.txt
+%%DATADIR%%/extracted/DerivedBinaryProperties.txt
+%%DATADIR%%/extracted/DerivedCombiningClass.txt
+%%DATADIR%%/extracted/DerivedDecompositionType.txt
+%%DATADIR%%/extracted/DerivedEastAsianWidth.txt
+%%DATADIR%%/extracted/DerivedGeneralCategory.txt
+%%DATADIR%%/extracted/DerivedJoiningGroup.txt
+%%DATADIR%%/extracted/DerivedJoiningType.txt
+%%DATADIR%%/extracted/DerivedLineBreak.txt
+%%DATADIR%%/extracted/DerivedNumericType.txt
+%%DATADIR%%/extracted/DerivedNumericValues.txt