aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorosa <osa@FreeBSD.org>2003-10-31 22:51:08 +0800
committerosa <osa@FreeBSD.org>2003-10-31 22:51:08 +0800
commit62b283ce5de5871a4e2b42dca27ec061fa72ca7f (patch)
treefa757150042c30f511475490708c0493c3c098df /misc
parent81bebd81a6b7c702ab9db35d608858307dc7716b (diff)
downloadfreebsd-ports-gnome-62b283ce5de5871a4e2b42dca27ec061fa72ca7f.tar.gz
freebsd-ports-gnome-62b283ce5de5871a4e2b42dca27ec061fa72ca7f.tar.zst
freebsd-ports-gnome-62b283ce5de5871a4e2b42dca27ec061fa72ca7f.zip
Add a clone of the UNIX(tm) program called seq.
Spotted by: Sergey Pinaev (dfo@antex.ru)
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/seq2/Makefile26
-rw-r--r--misc/seq2/distinfo1
-rw-r--r--misc/seq2/pkg-descr5
-rw-r--r--misc/seq2/pkg-plist1
5 files changed, 34 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index a172810429c2..e9023eeaed71 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -317,6 +317,7 @@
SUBDIR += salias
SUBDIR += screen
SUBDIR += seizedesktop
+ SUBDIR += seq2
SUBDIR += sh-utils
SUBDIR += shared-mime-info
SUBDIR += shuffle
diff --git a/misc/seq2/Makefile b/misc/seq2/Makefile
new file mode 100644
index 000000000000..3fc90e4863ce
--- /dev/null
+++ b/misc/seq2/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: seq2
+# Date created: 31 Oct 2003
+# Whom: osa
+#
+# $FreeBSD$
+#
+
+PORTNAME= seq2
+PORTVERSION= 0.2
+CATEGORIES= misc
+MASTER_SITES= http://www.referee.at/unix/
+
+MAINTAINER= osa@FreeBSD.org
+COMMENT= A clone of the UNIX(tm) program called seq
+
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_SCRIPT= configure.1
+
+MAN1= seq2.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(CC) -o|$$(CC) $$(CFLAGS) -o|' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/misc/seq2/distinfo b/misc/seq2/distinfo
new file mode 100644
index 000000000000..b43d2f0d4035
--- /dev/null
+++ b/misc/seq2/distinfo
@@ -0,0 +1 @@
+MD5 (seq2-0.2.tar.gz) = 998fe57811ea149f6af1a4bf8f40b8b7
diff --git a/misc/seq2/pkg-descr b/misc/seq2/pkg-descr
new file mode 100644
index 000000000000..141675512526
--- /dev/null
+++ b/misc/seq2/pkg-descr
@@ -0,0 +1,5 @@
+seq2 is a clone of the unix program called "seq" with
+some additional options, such as specifying a delay after
+each number, or specifying your own text to prepend each
+number. Features like for, while, and executing programs
+are in development.
diff --git a/misc/seq2/pkg-plist b/misc/seq2/pkg-plist
new file mode 100644
index 000000000000..b23265966da0
--- /dev/null
+++ b/misc/seq2/pkg-plist
@@ -0,0 +1 @@
+bin/seq2