aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-03-14 16:05:52 +0800
committeryuri <yuri@FreeBSD.org>2018-03-14 16:05:52 +0800
commit682a0608235752993db23c1754fda226a2bd34ec (patch)
tree110411095547f87824d9427133c63ecb427ebd64 /misc
parent9d1177bf7271df4ad26e27c2fac4f3b300be36f8 (diff)
downloadfreebsd-ports-gnome-682a0608235752993db23c1754fda226a2bd34ec.tar.gz
freebsd-ports-gnome-682a0608235752993db23c1754fda226a2bd34ec.tar.zst
freebsd-ports-gnome-682a0608235752993db23c1754fda226a2bd34ec.zip
New port: misc/libsweep-lidar: Low-level Scanse Sweep LiDAR library
The library to communicate with the Scanse Sweep LiDAR device that is able to scan the space around it and build its point cloud representation. PR: 223433 Submitted by: Hyun Hwang <hyun@caffeinated.codes> Differential Revision: https://reviews.freebsd.org/D14691
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/libsweep-lidar/Makefile25
-rw-r--r--misc/libsweep-lidar/distinfo3
-rw-r--r--misc/libsweep-lidar/files/patch-libsweep_man_sweep-ctl.115
-rw-r--r--misc/libsweep-lidar/pkg-descr6
-rw-r--r--misc/libsweep-lidar/pkg-plist9
6 files changed, 59 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 5d8d54c295aa..a030363df0e1 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -257,6 +257,7 @@
SUBDIR += libpredict
SUBDIR += libpri
SUBDIR += libsupertone
+ SUBDIR += libsweep-lidar
SUBDIR += libutf
SUBDIR += lifelines
SUBDIR += lingoteach
diff --git a/misc/libsweep-lidar/Makefile b/misc/libsweep-lidar/Makefile
new file mode 100644
index 000000000000..07baad1b9bde
--- /dev/null
+++ b/misc/libsweep-lidar/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= libsweep-lidar
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.3.0
+CATEGORIES= misc
+
+MAINTAINER= hyun@caffeinated.codes
+COMMENT= Low-level Scanse Sweep LiDAR library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake:outsource
+USE_GITHUB= yes
+GH_ACCOUNT= scanse
+GH_PROJECT= sweep-sdk
+CMAKE_SOURCE_PATH= ${WRKSRC}/libsweep
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= NO_DEVICE
+NO_DEVICE_DESC= The library will generate dummy static point cloud
+NO_DEVICE_CMAKE_BOOL= DUMMY
+
+.include <bsd.port.mk>
diff --git a/misc/libsweep-lidar/distinfo b/misc/libsweep-lidar/distinfo
new file mode 100644
index 000000000000..85b21cc8dacf
--- /dev/null
+++ b/misc/libsweep-lidar/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1509816807
+SHA256 (scanse-sweep-sdk-v1.3.0_GH0.tar.gz) = 30b51a9f68ec64684648b54e0d704da7e38a5a0f42a6bc965f3e33f4e3a80af0
+SIZE (scanse-sweep-sdk-v1.3.0_GH0.tar.gz) = 101819
diff --git a/misc/libsweep-lidar/files/patch-libsweep_man_sweep-ctl.1 b/misc/libsweep-lidar/files/patch-libsweep_man_sweep-ctl.1
new file mode 100644
index 000000000000..eaa217e985b1
--- /dev/null
+++ b/misc/libsweep-lidar/files/patch-libsweep_man_sweep-ctl.1
@@ -0,0 +1,15 @@
+--- libsweep/man/sweep-ctl.1.orig 2017-11-04 17:36:19 UTC
++++ libsweep/man/sweep-ctl.1
+@@ -34,10 +34,10 @@ The device\[aq]s sample rate in Hz.
+ .IP
+ .nf
+ \f[C]
+-$\ sweep\-ctl\ /dev/ttyUSB0\ get\ motor_speed
++$\ sweep\-ctl\ /dev/ttyU0\ get\ motor_speed
+ 3
+
+-$\ sweep\-ctl\ /dev/ttyUSB0\ set\ motor_speed\ 5
++$\ sweep\-ctl\ /dev/ttyU0\ set\ motor_speed\ 5
+ 5
+ \f[]
+ .fi
diff --git a/misc/libsweep-lidar/pkg-descr b/misc/libsweep-lidar/pkg-descr
new file mode 100644
index 000000000000..28641e01120b
--- /dev/null
+++ b/misc/libsweep-lidar/pkg-descr
@@ -0,0 +1,6 @@
+This is a port of libsweep, part of Scanse Sweep LiDAR SDK.
+
+Sweep is a scanning hardware LiDAR sensor designed to bring
+powerful 360 degree sensing capabilities to everyone.
+
+WWW: http://scanse.io/
diff --git a/misc/libsweep-lidar/pkg-plist b/misc/libsweep-lidar/pkg-plist
new file mode 100644
index 000000000000..58ecb2789e3f
--- /dev/null
+++ b/misc/libsweep-lidar/pkg-plist
@@ -0,0 +1,9 @@
+bin/sweep-ctl
+include/sweep/config.h
+include/sweep/sweep.h
+include/sweep/sweep.hpp
+lib/cmake/sweep/SweepConfig.cmake
+lib/libsweep.so
+lib/libsweep.so.1
+lib/libsweep.so.1.3.0
+man/man1/sweep-ctl.1.gz