aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authortabthorpe <tabthorpe@FreeBSD.org>2012-06-10 09:27:14 +0800
committertabthorpe <tabthorpe@FreeBSD.org>2012-06-10 09:27:14 +0800
commit6dd484d1f4ad1e6bc026aa28baa7de66d11445d1 (patch)
treeeb9dc55aa249147087bdbe5c1fb2246c84a01218 /misc
parentbe782b07d3b001d7d86b6705fc267b22791ecd5a (diff)
downloadfreebsd-ports-gnome-6dd484d1f4ad1e6bc026aa28baa7de66d11445d1.tar.gz
freebsd-ports-gnome-6dd484d1f4ad1e6bc026aa28baa7de66d11445d1.tar.zst
freebsd-ports-gnome-6dd484d1f4ad1e6bc026aa28baa7de66d11445d1.zip
- Convert to new options framework
Diffstat (limited to 'misc')
-rw-r--r--misc/sword/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/misc/sword/Makefile b/misc/sword/Makefile
index 6f9807fccf9c..ed65b7636553 100644
--- a/misc/sword/Makefile
+++ b/misc/sword/Makefile
@@ -33,18 +33,20 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
PLIST_SUB= PORTVERSION=${PORTVERSION}
-.if defined(WITHOUT_CURL)
-CONFIGURE_ARGS+= --without-curl
-.else
+OPTIONS_DEFINE= CURL
+OPTIONS_DEFAULT=CURL
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MCURL}
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+= --with-curl
+.else
+CONFIGURE_ARGS+= --without-curl
+.endif
run-autotools:: run-autotools-aclocal
-pre-everything::
- @${ECHO_CMD} "Define WITHOUT_CURL to disable remote fetch (curl) support in the installmanager"
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
${WRKSRC}/Makefile.am ${WRKSRC}/Makefile.in