aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2003-02-04 08:13:01 +0800
committernaddy <naddy@FreeBSD.org>2003-02-04 08:13:01 +0800
commit7b7499e33bca15b5dbf12bf5f71bed6a843d501d (patch)
treeeff43eed1da84b11ae6fa8236eeaa5de1a19607b /misc
parent0228de3e596a5b6d3f003eb7282358f8715daa22 (diff)
downloadfreebsd-ports-gnome-7b7499e33bca15b5dbf12bf5f71bed6a843d501d.tar.gz
freebsd-ports-gnome-7b7499e33bca15b5dbf12bf5f71bed6a843d501d.tar.zst
freebsd-ports-gnome-7b7499e33bca15b5dbf12bf5f71bed6a843d501d.zip
Rename included eaccess() function to avoid clash with -CURRENT's
eaccess(2) system call. PR: 46363 Submitted by: Cyrille Lefevre <cyrille.lefevre@laposte.net>
Diffstat (limited to 'misc')
-rw-r--r--misc/sh-utils/Makefile4
-rw-r--r--misc/sh-utils/files/patch-src_test.c13
2 files changed, 15 insertions, 2 deletions
diff --git a/misc/sh-utils/Makefile b/misc/sh-utils/Makefile
index 6909ae391cd7..13c7531e1f3d 100644
--- a/misc/sh-utils/Makefile
+++ b/misc/sh-utils/Makefile
@@ -7,7 +7,7 @@
PORTNAME= sh-utils
PORTVERSION= 2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= sh-utils
@@ -46,7 +46,7 @@ remove-info-files:
# Patch
#
-do-patch:
+post-patch:
.if !defined(WITH_SUID)
@${REINPLACE_CMD} -e 's/u\+s/u\+w/g' ${WRKSRC}/src/Makefile.in
.endif
diff --git a/misc/sh-utils/files/patch-src_test.c b/misc/sh-utils/files/patch-src_test.c
new file mode 100644
index 000000000000..9448b25d513a
--- /dev/null
+++ b/misc/sh-utils/files/patch-src_test.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- src/test.c.orig Tue Feb 4 00:43:33 2003
++++ src/test.c Tue Feb 4 00:43:50 2003
+@@ -153,6 +153,7 @@
+ return (stat (path, finfo));
+ }
+
++#define eaccess test_access
+ /* Do the same thing access(2) does, but use the effective uid and gid,
+ and don't make the mistake of telling root that any file is executable.
+ But this loses when the containing filesystem is mounted e.g. read-only. */