aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2011-08-02 20:56:35 +0800
committerlinimon <linimon@FreeBSD.org>2011-08-02 20:56:35 +0800
commit7e96221ca709d7f78031e7f19c3c809080e7b002 (patch)
tree12ba4a22396c938e6008a086e81aca4538e614b4 /misc
parent07b163dc74caa12079a30f57a9a916fd42551ca6 (diff)
downloadfreebsd-ports-gnome-7e96221ca709d7f78031e7f19c3c809080e7b002.tar.gz
freebsd-ports-gnome-7e96221ca709d7f78031e7f19c3c809080e7b002.tar.zst
freebsd-ports-gnome-7e96221ca709d7f78031e7f19c3c809080e7b002.zip
Use the canonical way to test for the presence of FreeBSD src files.
Approved by: maintainer
Diffstat (limited to 'misc')
-rw-r--r--misc/dahdi-kmod/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/misc/dahdi-kmod/Makefile b/misc/dahdi-kmod/Makefile
index a9777d06df65..32a1d4c2fdb9 100644
--- a/misc/dahdi-kmod/Makefile
+++ b/misc/dahdi-kmod/Makefile
@@ -54,6 +54,10 @@ CONFLICTS= zaptel-[0-9]*
IGNORE= requires firmware(9) support for kernel modules with hyphens
.endif
+.if !exists(${SRC_BASE}/sys/Makefile)
+IGNORE= requires kernel source present in ${SRC_BASE}/sys
+.endif
+
.if ${ARCH} == "i386" || ${ARCH} == "amd64"
PLIST_SUB+= X86=""
_vpmadt032= VPMADT032
@@ -68,13 +72,6 @@ ${_f}_DISTFILE= ${${_f}_NAME}-${${_f}_VERSION}.tar.gz
DISTFILES+= ${${_f}_DISTFILE}:firmware
.endfor
-pre-everything::
- @if [ ! -f /usr/src/sys/Makefile ]; then \
- ${ECHO_MSG} ">> The dahdi port needs FreeBSD kernel source code to compile."; \
- ${ECHO_MSG} ">> Please install FreeBSD kernel source code in /usr/src/sys."; \
- ${FALSE}; \
- fi
-
post-extract:
@${LN} -s ../../../linux-${OSLEC_VERSION}/drivers/staging ${WRKSRC}/drivers
.for _f in ${FIRMWARES}