aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2017-02-18 17:59:30 +0800
committerdinoex <dinoex@FreeBSD.org>2017-02-18 17:59:30 +0800
commit8ba7ab72309415f257c1e1dbdd109acdfe1ad1be (patch)
tree2320c626f6c61b01a3667062a41bc2f86bfab18c /misc
parentf4a2bd3b98b9d68403764e1206a41891635d116b (diff)
downloadfreebsd-ports-gnome-8ba7ab72309415f257c1e1dbdd109acdfe1ad1be.tar.gz
freebsd-ports-gnome-8ba7ab72309415f257c1e1dbdd109acdfe1ad1be.tar.zst
freebsd-ports-gnome-8ba7ab72309415f257c1e1dbdd109acdfe1ad1be.zip
- fix warnings
- make portlint happier
Diffstat (limited to 'misc')
-rw-r--r--misc/magicpoint/Makefile3
-rw-r--r--misc/magicpoint/files/patch-configure6
-rw-r--r--misc/magicpoint/files/patch-ctlwords.c7
-rw-r--r--misc/magicpoint/files/patch-default.mgp4
-rw-r--r--misc/magicpoint/files/patch-draw.c6
-rw-r--r--misc/magicpoint/files/patch-dsimple.c21
-rw-r--r--misc/magicpoint/files/patch-grammar.y11
-rw-r--r--misc/magicpoint/files/patch-main.c13
-rw-r--r--misc/magicpoint/files/patch-mgp.h12
-rw-r--r--misc/magicpoint/files/patch-new.c4
-rw-r--r--misc/magicpoint/files/patch-path.c11
-rw-r--r--misc/magicpoint/files/patch-png.c8
-rw-r--r--misc/magicpoint/files/patch-rlelib.c4
-rw-r--r--misc/magicpoint/files/patch-window.c11
-rw-r--r--misc/magicpoint/files/patch-xwintoppm.c72
15 files changed, 171 insertions, 22 deletions
diff --git a/misc/magicpoint/Makefile b/misc/magicpoint/Makefile
index 9dcb75126e95..fe08b76caab3 100644
--- a/misc/magicpoint/Makefile
+++ b/misc/magicpoint/Makefile
@@ -3,7 +3,7 @@
PORTNAME= magicpoint
PORTVERSION= 1.13a
-PORTREVISION= 18
+PORTREVISION= 19
CATEGORIES?= misc
MASTER_SITES= ftp://sh.wide.ad.jp/WIDE/free-ware/mgp/
@@ -81,6 +81,7 @@ post-install:
${STAGEDIR}${PREFIX}/man/man1/
${INSTALL} ${WRKSRC}/contrib/xmindpath/xmindpath \
${STAGEDIR}${PREFIX}/bin/
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/xmindpath
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/misc/magicpoint/files/patch-configure b/misc/magicpoint/files/patch-configure
index 62c8bd591955..434af788af1f 100644
--- a/misc/magicpoint/files/patch-configure
+++ b/misc/magicpoint/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Wed Aug 4 09:23:35 2004
-+++ configure Fri Nov 5 13:36:43 2004
-@@ -4134,6 +4134,8 @@
+--- configure.orig 2007-12-28 20:31:26 UTC
++++ configure
+@@ -5106,6 +5106,8 @@ echo $ECHO_N "checking for freetype1 lib
fi
if test -d $dir/include -a -f $dir/include/freetype.h; then
ac_cv_ft_include="$dir/include"
diff --git a/misc/magicpoint/files/patch-ctlwords.c b/misc/magicpoint/files/patch-ctlwords.c
index 6d381e1fe7bb..f344b747b7f7 100644
--- a/misc/magicpoint/files/patch-ctlwords.c
+++ b/misc/magicpoint/files/patch-ctlwords.c
@@ -1,10 +1,11 @@
---- ctlwords.c.orig 1999-02-15 00:02:25.000000000 +0100
-+++ ctlwords.c 2013-11-08 09:05:06.000000000 +0100
-@@ -24,6 +24,7 @@
+--- ctlwords.c.orig 1999-02-14 23:02:25 UTC
++++ ctlwords.c
+@@ -24,6 +24,8 @@ BEGIN {
#include <stdio.h>
#include <string.h>
+#include <stdlib.h>
++#include <ctype.h>
main(int argc, char *argv[])
{
diff --git a/misc/magicpoint/files/patch-default.mgp b/misc/magicpoint/files/patch-default.mgp
index fb6b46a28a99..1d5bb6dfc7c0 100644
--- a/misc/magicpoint/files/patch-default.mgp
+++ b/misc/magicpoint/files/patch-default.mgp
@@ -1,5 +1,5 @@
---- sample/default.mgp.orig Sat Aug 11 01:40:54 2001
-+++ sample/default.mgp Tue Jan 25 13:56:12 2005
+--- sample/default.mgp.orig 2001-08-10 16:40:54 UTC
++++ sample/default.mgp
@@ -12,9 +12,9 @@
%% into the "tfdir" directory above:
%% ftp://ftp.mew.org/pub/mgp/ttf-jp.tar.gz
diff --git a/misc/magicpoint/files/patch-draw.c b/misc/magicpoint/files/patch-draw.c
index c2e711a07490..9ef166e355cf 100644
--- a/misc/magicpoint/files/patch-draw.c
+++ b/misc/magicpoint/files/patch-draw.c
@@ -1,6 +1,6 @@
---- draw.c.orig 2008-01-24 16:43:17.000000000 +0100
-+++ draw.c 2013-09-03 06:48:44.000000000 +0200
-@@ -5471,12 +5471,12 @@
+--- draw.c.orig 2008-01-24 15:43:17 UTC
++++ draw.c
+@@ -5471,12 +5471,12 @@ xft_setfont(xfontarg, csize, registry)
XFT_FAMILY, XftTypeString, font,
XFT_ENCODING, XftTypeString, registry,
XFT_STYLE, XftTypeString, style,
diff --git a/misc/magicpoint/files/patch-dsimple.c b/misc/magicpoint/files/patch-dsimple.c
new file mode 100644
index 000000000000..86219828a4b9
--- /dev/null
+++ b/misc/magicpoint/files/patch-dsimple.c
@@ -0,0 +1,21 @@
+--- contrib/xwintoppm/dsimple.c.orig 1998-02-13 07:48:29 UTC
++++ contrib/xwintoppm/dsimple.c
+@@ -55,6 +55,10 @@ void out();
+ void blip();
+ Window Window_With_Name();
+ void Fatal_Error();
++void usage(void);
++
++/* forward */
++void outl();
+
+ /*
+ * Just_display: A group of routines designed to make the writting of simple
+@@ -495,6 +499,7 @@ Window Window_With_Name(dpy, top, name)
+ * printf with up to 7 arguments.
+ */
+ /* VARARGS1 */
++void
+ outl(msg, arg0,arg1,arg2,arg3,arg4,arg5,arg6)
+ char *msg;
+ char *arg0, *arg1, *arg2, *arg3, *arg4, *arg5, *arg6;
diff --git a/misc/magicpoint/files/patch-grammar.y b/misc/magicpoint/files/patch-grammar.y
new file mode 100644
index 000000000000..c306349d4e33
--- /dev/null
+++ b/misc/magicpoint/files/patch-grammar.y
@@ -0,0 +1,11 @@
+--- grammar.y.orig 2008-01-18 17:43:20 UTC
++++ grammar.y
+@@ -70,6 +70,8 @@
+ static struct qual qerr = { Q_UNDEF, Q_UNDEF, Q_UNDEF, Q_UNDEF };
+ #endif
+
++extern int yylex (void);
++
+ int n_errors = 0;
+ struct ctrl *root;
+ char *yyfilename;
diff --git a/misc/magicpoint/files/patch-main.c b/misc/magicpoint/files/patch-main.c
new file mode 100644
index 000000000000..59a3937df70c
--- /dev/null
+++ b/misc/magicpoint/files/patch-main.c
@@ -0,0 +1,13 @@
+--- contrib/xmindpath/main.c.orig 1998-09-30 23:58:17 UTC
++++ contrib/xmindpath/main.c
+@@ -42,6 +42,10 @@
+ #include <X11/X.h>
+ #include <X11/extensions/XTest.h>
+ #include <X11/keysym.h>
++#include <string.h>
++#include <err.h>
++#include <sys/types.h>
++#include <libutil.h>
+
+ #ifdef X_DISPLAY_MISSING
+ # error this program cannot be compiled without X11.
diff --git a/misc/magicpoint/files/patch-mgp.h b/misc/magicpoint/files/patch-mgp.h
index 27baa88bb34d..b5e5e0ccc554 100644
--- a/misc/magicpoint/files/patch-mgp.h
+++ b/misc/magicpoint/files/patch-mgp.h
@@ -1,5 +1,5 @@
---- mgp.h.orig 2013-12-25 10:03:40.000000000 +0100
-+++ mgp.h 2013-12-25 10:05:28.000000000 +0100
+--- mgp.h.orig 2008-01-18 17:43:20 UTC
++++ mgp.h
@@ -91,7 +91,7 @@
#endif /* end of VFLIB */
@@ -9,3 +9,11 @@
#ifndef FREETYPEFONTDIR
#define FREETYPEFONTDIR "/usr/local/share/fonts/ttf"
+@@ -853,3 +853,7 @@ extern void M17N_process_direc __P((char
+ extern void M17N_draw_string __P((struct render_state *, struct ctrl *cp));
+ extern void M17N_draw_object __P((struct render_object *, Drawable, int, int));
+ #endif
++
++extern void mngload(char *mngfile, int x, int y, int width, int height);
++extern void mngpreload(struct render_state *state, char *mngfile, int *width, int *height);
++
diff --git a/misc/magicpoint/files/patch-new.c b/misc/magicpoint/files/patch-new.c
index 047351cd4aea..3ef94b86a40f 100644
--- a/misc/magicpoint/files/patch-new.c
+++ b/misc/magicpoint/files/patch-new.c
@@ -1,5 +1,5 @@
---- image/new.c.orig Tue Aug 31 20:50:32 2004
-+++ image/new.c Fri Nov 5 13:53:17 2004
+--- image/new.c.orig 2004-09-01 03:50:32 UTC
++++ image/new.c
@@ -11,7 +11,7 @@
#include "copyright.h"
#include "image.h"
diff --git a/misc/magicpoint/files/patch-path.c b/misc/magicpoint/files/patch-path.c
new file mode 100644
index 000000000000..e699d1cb9792
--- /dev/null
+++ b/misc/magicpoint/files/patch-path.c
@@ -0,0 +1,11 @@
+--- image/path.c.orig 2004-07-28 15:47:31 UTC
++++ image/path.c
+@@ -20,7 +20,7 @@
+ #if 1 /* SYSV */
+ #include <unistd.h>
+ #endif
+-#ifdef __APPLE__
++#if 1
+ #include <stdlib.h>
+ #endif
+
diff --git a/misc/magicpoint/files/patch-png.c b/misc/magicpoint/files/patch-png.c
index 59d7537f2734..ba1bf19ac6da 100644
--- a/misc/magicpoint/files/patch-png.c
+++ b/misc/magicpoint/files/patch-png.c
@@ -1,6 +1,6 @@
---- image/png.c.orig 2001-04-11 10:37:00.000000000 +0200
-+++ image/png.c 2012-05-05 08:48:02.000000000 +0200
-@@ -86,7 +86,7 @@
+--- image/png.c.orig 2001-04-11 08:37:00 UTC
++++ image/png.c
+@@ -86,7 +86,7 @@ pngLoad(fullname, name, verbose)
return NULL;
}
@@ -9,7 +9,7 @@
png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
fclose(fp);
return NULL;
-@@ -134,7 +134,7 @@
+@@ -134,7 +134,7 @@ pngLoad(fullname, name, verbose)
}
if (colortype == PNG_COLOR_TYPE_GRAY && bitdepth < 8){
diff --git a/misc/magicpoint/files/patch-rlelib.c b/misc/magicpoint/files/patch-rlelib.c
index 9fdb508e98fa..96fea20fd346 100644
--- a/misc/magicpoint/files/patch-rlelib.c
+++ b/misc/magicpoint/files/patch-rlelib.c
@@ -1,5 +1,5 @@
---- image/rlelib.c.bak 2007-05-18 01:47:33.000000000 +0900
-+++ image/rlelib.c 2008-11-06 23:38:04.000000000 +0900
+--- image/rlelib.c.orig 2007-05-17 16:47:33 UTC
++++ image/rlelib.c
@@ -13,7 +13,7 @@
#include <stdio.h>
#include <math.h>
diff --git a/misc/magicpoint/files/patch-window.c b/misc/magicpoint/files/patch-window.c
new file mode 100644
index 000000000000..215d6b9a268a
--- /dev/null
+++ b/misc/magicpoint/files/patch-window.c
@@ -0,0 +1,11 @@
+--- image/window.c.orig 2004-07-28 15:47:31 UTC
++++ image/window.c
+@@ -32,7 +32,7 @@
+ #if HAVE_SYS_SELECT_H
+ # include <sys/select.h>
+ #endif
+-#ifdef __APPLE__
++#if 1
+ #include <unistd.h>
+ #endif
+
diff --git a/misc/magicpoint/files/patch-xwintoppm.c b/misc/magicpoint/files/patch-xwintoppm.c
new file mode 100644
index 000000000000..9c9f6a562d46
--- /dev/null
+++ b/misc/magicpoint/files/patch-xwintoppm.c
@@ -0,0 +1,72 @@
+--- contrib/xwintoppm/xwintoppm.c.orig 1998-08-26 05:30:16 UTC
++++ contrib/xwintoppm/xwintoppm.c
+@@ -139,6 +139,15 @@ long add_pixel_value = 0;
+ extern int (*_XErrorFunction)();
+ extern int _XDefaultError();
+
++extern void outl();
++
++/* forwards */
++void usage(void);
++void Error(char *string);
++void Window_Dump(Window window, FILE *out);
++int Image_Size(XImage *image);
++int Get_XColors(XWindowAttributes *win_info, XColor **colors);
++
+ static long parse_long (s)
+ char *s;
+ {
+@@ -155,11 +164,12 @@ static long parse_long (s)
+ return (thesign * retval);
+ }
+
++int
+ main(argc, argv)
+ int argc;
+ char **argv;
+ {
+- register i;
++ register int i;
+ Window target_win;
+ FILE *out_file = stdout;
+ Bool frame_only = False;
+@@ -281,6 +291,7 @@ XColor **colors ;
+ * writting.
+ */
+
++void
+ Window_Dump(window, out)
+ Window window;
+ FILE *out;
+@@ -609,6 +620,7 @@ Window_Dump(window, out)
+ /*
+ * Report the syntax for calling xwd.
+ */
++void
+ usage()
+ {
+ fprintf (stderr,
+@@ -623,6 +635,7 @@ usage()
+ * Error - Fatal xwd error.
+ */
+
++void
+ Error(string)
+ char *string; /* Error description string. */
+ {
+@@ -716,6 +729,7 @@ int Get_XColors(win_info, colors)
+ return ncolors ;
+ }
+
++void
+ _swapshort (bp, n)
+ register char *bp;
+ register unsigned n;
+@@ -731,6 +745,7 @@ _swapshort (bp, n)
+ }
+ }
+
++void
+ _swaplong (bp, n)
+ register char *bp;
+ register unsigned n;