aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2010-09-01 23:22:32 +0800
committerfjoe <fjoe@FreeBSD.org>2010-09-01 23:22:32 +0800
commit96d1f796f127bfd6c7caaf3e1e69489bf4914c7a (patch)
tree658465bf00afee07bd2f4e48449cdcb3fed5a700 /misc
parent78c0b4c778bdeb5fe50a83d7f588c1b13353eb07 (diff)
downloadfreebsd-ports-gnome-96d1f796f127bfd6c7caaf3e1e69489bf4914c7a.tar.gz
freebsd-ports-gnome-96d1f796f127bfd6c7caaf3e1e69489bf4914c7a.tar.zst
freebsd-ports-gnome-96d1f796f127bfd6c7caaf3e1e69489bf4914c7a.zip
Fix wctdm driver parameters declaration.
Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'misc')
-rw-r--r--misc/dahdi-kmod/Makefile2
-rw-r--r--misc/dahdi-kmod/files/patch-freebsd-drivers-dahdi-wctdm.c36
-rw-r--r--misc/dahdi/Makefile2
-rw-r--r--misc/dahdi/files/patch-freebsd-drivers-dahdi-wctdm.c36
4 files changed, 74 insertions, 2 deletions
diff --git a/misc/dahdi-kmod/Makefile b/misc/dahdi-kmod/Makefile
index c8af029fb3ab..f77482bf6580 100644
--- a/misc/dahdi-kmod/Makefile
+++ b/misc/dahdi-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dahdi
PORTVERSION= ${DAHDI_VERSION:S/-//g}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc kld
MASTER_SITES= ${MASTER_SITE_LOCAL}\
http://downloads.digium.com/pub/telephony/firmware/releases/:firmware
diff --git a/misc/dahdi-kmod/files/patch-freebsd-drivers-dahdi-wctdm.c b/misc/dahdi-kmod/files/patch-freebsd-drivers-dahdi-wctdm.c
new file mode 100644
index 000000000000..ae8499a5aba5
--- /dev/null
+++ b/misc/dahdi-kmod/files/patch-freebsd-drivers-dahdi-wctdm.c
@@ -0,0 +1,36 @@
+--- freebsd/drivers/dahdi/wctdm.c.orig 2010-09-01 22:06:31.000000000 +0700
++++ freebsd/drivers/dahdi/wctdm.c 2010-09-01 22:17:48.000000000 +0700
+@@ -341,7 +341,11 @@
+ static int boostringer = 0;
+ static int fastringer = 0;
+ static int _opermode = 0;
++#if defined(__FreeBSD__)
++static char opermode[16] = "FCC";
++#else
+ static char *opermode = "FCC";
++#endif
+ static int fxshonormode = 0;
+ static int alawoverride = 0;
+ static int fastpickup = 0;
+@@ -3141,6 +3145,7 @@
+ {
+ pci_unregister_driver(&wctdm_driver);
+ }
++#endif /* !__FreeBSD__ */
+
+ module_param(debug, int, 0600);
+ module_param(fxovoltage, int, 0600);
+@@ -3166,6 +3171,7 @@
+ module_param(fxstxgain, int, 0600);
+ module_param(fxsrxgain, int, 0600);
+
++#if !defined(__FreeBSD__)
+ MODULE_DESCRIPTION("Wildcard TDM400P Driver");
+ MODULE_AUTHOR("Mark Spencer <markster@digium.com>");
+ MODULE_ALIAS("wcfxs");
+@@ -3173,4 +3179,4 @@
+
+ module_init(wctdm_init);
+ module_exit(wctdm_cleanup);
+-#endif /* !__FreeBSD__ */
++#endif
diff --git a/misc/dahdi/Makefile b/misc/dahdi/Makefile
index c8af029fb3ab..f77482bf6580 100644
--- a/misc/dahdi/Makefile
+++ b/misc/dahdi/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dahdi
PORTVERSION= ${DAHDI_VERSION:S/-//g}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc kld
MASTER_SITES= ${MASTER_SITE_LOCAL}\
http://downloads.digium.com/pub/telephony/firmware/releases/:firmware
diff --git a/misc/dahdi/files/patch-freebsd-drivers-dahdi-wctdm.c b/misc/dahdi/files/patch-freebsd-drivers-dahdi-wctdm.c
new file mode 100644
index 000000000000..ae8499a5aba5
--- /dev/null
+++ b/misc/dahdi/files/patch-freebsd-drivers-dahdi-wctdm.c
@@ -0,0 +1,36 @@
+--- freebsd/drivers/dahdi/wctdm.c.orig 2010-09-01 22:06:31.000000000 +0700
++++ freebsd/drivers/dahdi/wctdm.c 2010-09-01 22:17:48.000000000 +0700
+@@ -341,7 +341,11 @@
+ static int boostringer = 0;
+ static int fastringer = 0;
+ static int _opermode = 0;
++#if defined(__FreeBSD__)
++static char opermode[16] = "FCC";
++#else
+ static char *opermode = "FCC";
++#endif
+ static int fxshonormode = 0;
+ static int alawoverride = 0;
+ static int fastpickup = 0;
+@@ -3141,6 +3145,7 @@
+ {
+ pci_unregister_driver(&wctdm_driver);
+ }
++#endif /* !__FreeBSD__ */
+
+ module_param(debug, int, 0600);
+ module_param(fxovoltage, int, 0600);
+@@ -3166,6 +3171,7 @@
+ module_param(fxstxgain, int, 0600);
+ module_param(fxsrxgain, int, 0600);
+
++#if !defined(__FreeBSD__)
+ MODULE_DESCRIPTION("Wildcard TDM400P Driver");
+ MODULE_AUTHOR("Mark Spencer <markster@digium.com>");
+ MODULE_ALIAS("wcfxs");
+@@ -3173,4 +3179,4 @@
+
+ module_init(wctdm_init);
+ module_exit(wctdm_cleanup);
+-#endif /* !__FreeBSD__ */
++#endif