aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-12-18 01:19:48 +0800
committermat <mat@FreeBSD.org>2015-12-18 01:19:48 +0800
commit9e7703aff1c96dce4c11180df6bfd80c536b777a (patch)
treecc6e929ebf67eee2cc8ce1692ea0663387b3a559 /misc
parentfbcb74cea8547a229eabdb6530aecdeb2689cf82 (diff)
downloadfreebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.tar.gz
freebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.tar.zst
freebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.zip
Fix usage of ${PERL5}.
${PERL5} points to a specific version of perl, say, perl5.22.1, it is fine to use it in a ports Makefile to do Perly things, but ports using it must use ${PERL}, that points to /usr/local/bin/perl so that if the minor version is updated, the shebang keep working. While there, make some ports use shebangfix, regen a few patches, and bump PORTREVISION where a shebang went from PERL5 to PERL. PR: 205367 With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'misc')
-rw-r--r--misc/biblical-curse/Makefile11
-rw-r--r--misc/kenny/Makefile7
-rw-r--r--misc/rfc/Makefile9
3 files changed, 13 insertions, 14 deletions
diff --git a/misc/biblical-curse/Makefile b/misc/biblical-curse/Makefile
index ec02adbb8a7a..42ccd864f25a 100644
--- a/misc/biblical-curse/Makefile
+++ b/misc/biblical-curse/Makefile
@@ -10,18 +10,15 @@ DISTFILES= # none
MAINTAINER= tobez@FreeBSD.org
COMMENT= Fake biblical curse generator
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= run
+SHEBANG_FILES= biblical-curse
NO_BUILD= yes
-WRKSRC= ${WRKDIR}/src
SRC= ${.CURDIR}/src
-pre-patch:
- @${CP} -R ${SRC} ${WRKDIR}
-
-post-patch:
- @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/biblical-curse
+do-extract:
+ @${CP} -R ${SRC}/ ${WRKSRC}
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/biblical-curse ${STAGEDIR}${PREFIX}/bin/biblical-curse
diff --git a/misc/kenny/Makefile b/misc/kenny/Makefile
index 32fd136ef934..2c0cb55a9862 100644
--- a/misc/kenny/Makefile
+++ b/misc/kenny/Makefile
@@ -17,13 +17,13 @@ LICENSE= ART10
CONFLICTS= filters-*
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= extract build run
+SHEBANG_FILES= ${PORTNAME}
EXTRACT_CMD= ${GZCAT}
EXTRACT_BEFORE_ARGS=
EXTRACT_AFTER_ARGS= > ${WRKSRC}/${PORTNAME}
NO_ARCH= yes
-NO_BUILD= yes
NO_WRKSUBDIR= yes
PLIST_FILES= bin/kenny \
@@ -31,8 +31,7 @@ PLIST_FILES= bin/kenny \
POD2MAN?= ${LOCALBASE}/bin/pod2man
-post-extract:
- @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/${PORTNAME}
+do-build:
@${POD2MAN} ${WRKSRC}/${PORTNAME} > ${WRKSRC}/${PORTNAME}.1
do-install:
diff --git a/misc/rfc/Makefile b/misc/rfc/Makefile
index 5c9b42c231ec..999ef7f8030a 100644
--- a/misc/rfc/Makefile
+++ b/misc/rfc/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rfc
PORTVERSION= 3.2.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc
MASTER_SITES= http://www.dewn.com/rfc/
@@ -13,6 +13,9 @@ COMMENT= Perl script to search for RFC's
RUN_DEPENDS= w3m:${PORTSDIR}/www/w3m
NO_BUILD= yes
+USES= perl5 shebangfix
+USE_PERL5= run
+SHEBANG_FILES= ${PORTNAME}-${PORTVERSION}
PLIST_FILES= bin/rfc man/man1/rfc.1.gz
@@ -21,8 +24,8 @@ do-configure:
s|/usr/local/etc/nmap|${PREFIX}/share/misc/nmap| ; \
s|400k|1024k| ; \
s|http://ftp.isi.edu/in-notes|http://www.ietf.org/rfc| ; \
- s|http://www.iana|ftp://ftp.iana| ; \
- s|/usr/bin/perl|${PERL}|' ${WRKSRC}/${PORTNAME}-${PORTVERSION}
+ s|http://www.iana|ftp://ftp.iana|' \
+ ${WRKSRC}/${PORTNAME}-${PORTVERSION}
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}-${PORTVERSION} \