aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-06-13 00:35:07 +0800
committerpawel <pawel@FreeBSD.org>2014-06-13 00:35:07 +0800
commitb4beff50761cce0b26b2725a8bebe71f87e5a6eb (patch)
tree78db67238b2b3a4a880e6bb45a168642da4f401d /misc
parent679691031f19781a390995b691a12fc76b86e5fe (diff)
downloadfreebsd-ports-gnome-b4beff50761cce0b26b2725a8bebe71f87e5a6eb.tar.gz
freebsd-ports-gnome-b4beff50761cce0b26b2725a8bebe71f87e5a6eb.tar.zst
freebsd-ports-gnome-b4beff50761cce0b26b2725a8bebe71f87e5a6eb.zip
- Add staging support
- Use gmake as build dependency to eliminate do-build target
Diffstat (limited to 'misc')
-rw-r--r--misc/gkrellmbgchg2/Makefile17
1 files changed, 5 insertions, 12 deletions
diff --git a/misc/gkrellmbgchg2/Makefile b/misc/gkrellmbgchg2/Makefile
index 7ec5fa9330e0..2ab510577031 100644
--- a/misc/gkrellmbgchg2/Makefile
+++ b/misc/gkrellmbgchg2/Makefile
@@ -15,22 +15,15 @@ LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/include/gkrellm2/gkrellm.h:${PORTSDIR}/sysutils/gkrellm2
RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm2
-USES= pkgconfig
+USES= gmake pkgconfig
USE_GNOME= gtk20
PLIST_FILES= libexec/gkrellm2/plugins/gkrellmbgchg.so
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-do-build:
- cd ${BUILD_WRKSRC} && ${CC} -shared ${CFLAGS} -fPIC \
- `pkg-config --cflags --libs gkrellm` gkrellmbgchg.c \
- -o gkrellmbgchg.so
+PLUGINDIR= ${STAGEDIR}${PREFIX}/libexec/gkrellm2/plugins
do-install:
- @${MKDIR} ${PREFIX}/libexec/gkrellm2/plugins
- ${INSTALL_DATA} ${WRKSRC}/gkrellmbgchg.so \
- ${PREFIX}/libexec/gkrellm2/plugins
+ @${MKDIR} ${PLUGINDIR}
+ ${INSTALL_LIB} ${WRKSRC}/gkrellmbgchg.so ${PLUGINDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>