aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-11-12 19:55:10 +0800
committerpav <pav@FreeBSD.org>2005-11-12 19:55:10 +0800
commitbd5cf72940eb018dc83a9247d00783010cf2b64f (patch)
treee9d1162072ad2bb9ea2289069ade5a5949bda520 /misc
parentb38f96ea699a2caae5f6d1f0dd1b92fed18ffa0c (diff)
downloadfreebsd-ports-gnome-bd5cf72940eb018dc83a9247d00783010cf2b64f.tar.gz
freebsd-ports-gnome-bd5cf72940eb018dc83a9247d00783010cf2b64f.tar.zst
freebsd-ports-gnome-bd5cf72940eb018dc83a9247d00783010cf2b64f.zip
A shell programming utility that prints to stdout a series of numbers from
`start' to `end' PR: ports/88391 Submitted by: Murray Nesbitt <freebsd@nesbitt.ca>
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/loop/Makefile20
-rw-r--r--misc/loop/distinfo3
-rw-r--r--misc/loop/files/patch-Makefile13
-rw-r--r--misc/loop/pkg-descr6
5 files changed, 43 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index edeb101eb284..5bc4380be1d4 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -289,6 +289,7 @@
SUBDIR += linux-opengroupware
SUBDIR += localedata
SUBDIR += logsurfer
+ SUBDIR += loop
SUBDIR += lr
SUBDIR += lv
SUBDIR += magicpoint
diff --git a/misc/loop/Makefile b/misc/loop/Makefile
new file mode 100644
index 000000000000..ef5dacde0f6f
--- /dev/null
+++ b/misc/loop/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: loop
+# Date created: 12 November 2005
+# Whom: Murray Nesbitt <freebsd@nesbitt.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= loop
+PORTVERSION= 1.0
+CATEGORIES= misc
+MASTER_SITES= http://www.nesbitt.ca/downloads/loop/
+
+MAINTAINER= freebsd@nesbitt.ca
+COMMENT= Prints to stdout a series of numbers from `start' to `end'
+
+MAN1= loop.1
+MANCOMPRESSED= yes
+PLIST_FILES= bin/loop
+
+.include <bsd.port.mk>
diff --git a/misc/loop/distinfo b/misc/loop/distinfo
new file mode 100644
index 000000000000..f3c77fa7b75e
--- /dev/null
+++ b/misc/loop/distinfo
@@ -0,0 +1,3 @@
+MD5 (loop-1.0.tar.gz) = 4655feb51abfb082a06035a3e7e36d4a
+SHA256 (loop-1.0.tar.gz) = 6cae60f7114f4d643ae6f2fa4a36e3ed96fa356dde22742d0969527f64a24b7f
+SIZE (loop-1.0.tar.gz) = 2007
diff --git a/misc/loop/files/patch-Makefile b/misc/loop/files/patch-Makefile
new file mode 100644
index 000000000000..419b416632e0
--- /dev/null
+++ b/misc/loop/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig Wed Nov 2 01:23:17 2005
++++ Makefile Wed Nov 2 01:18:17 2005
+@@ -1,7 +1,7 @@
+
+-CC = gcc
+-CFLAGS = -Wall -O
+-DESTDIR = /usr/local
++CC ?= gcc
++CFLAGS += -Wall
++DESTDIR = ${PREFIX}
+
+ loop:
+ ${CC} ${CFLAGS} -o loop loop.c
diff --git a/misc/loop/pkg-descr b/misc/loop/pkg-descr
new file mode 100644
index 000000000000..da166bb5506a
--- /dev/null
+++ b/misc/loop/pkg-descr
@@ -0,0 +1,6 @@
+Prints to stdout a series of numbers from `start' to `end', with
+optional increment and zero-padded field width. Hex (-x) or octal
+(-o) output formats are available. Negative numbers are allowed,
+and a negative `increment' does the expected thing.
+
+WWW: http://www.nesbitt.ca/downloads/loop/