aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2018-01-09 04:53:35 +0800
committerpi <pi@FreeBSD.org>2018-01-09 04:53:35 +0800
commitc887eea72b797d6d68169f4b45855116d16e75e3 (patch)
treef744ca7e4b323e4e98ff38a948551fe0aceae4c2 /misc
parent905f8c5e090e7e9776d38d0c3fb04191c106aa31 (diff)
downloadfreebsd-ports-gnome-c887eea72b797d6d68169f4b45855116d16e75e3.tar.gz
freebsd-ports-gnome-c887eea72b797d6d68169f4b45855116d16e75e3.tar.zst
freebsd-ports-gnome-c887eea72b797d6d68169f4b45855116d16e75e3.zip
New port: misc/liblxi
liblxi is an open source software library which offers a simple API for communicating with LXI compatible instruments. The API allows applications to discover instruments on your network, send SCPI commands, and receive responses. WWW: https://lxi-tools.github.io PR: 224713, D13685 Submitted by: Dmitri Goutnik <dg@syrec.org>
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/liblxi/Makefile37
-rw-r--r--misc/liblxi/distinfo3
-rw-r--r--misc/liblxi/pkg-descr6
-rw-r--r--misc/liblxi/pkg-plist10
5 files changed, 57 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 0cb460da6c41..b390135d7e8a 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -249,6 +249,7 @@
SUBDIR += libeatmydata
SUBDIR += libisocodes
SUBDIR += libkdeedu
+ SUBDIR += liblxi
SUBDIR += libmetalink
SUBDIR += libpostal
SUBDIR += libpredict
diff --git a/misc/liblxi/Makefile b/misc/liblxi/Makefile
new file mode 100644
index 000000000000..6bdae38904de
--- /dev/null
+++ b/misc/liblxi/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= liblxi
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.9-2
+DISTVERSIONSUFFIX= -g6b98d93
+CATEGORIES= misc
+
+MAINTAINER= dg@syrec.org
+COMMENT= Library for communicating with LXI compatible instruments
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libxml2.so:textproc/libxml2
+
+USES= autoreconf libtool localbase pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= lxi-tools
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
+INSTALL_TARGET= install-strip
+USE_LDCONFIG= yes
+
+PORTDOCS= README
+
+OPTIONS_DEFINE= AVAHI DOCS
+OPTIONS_SUB= yes
+
+AVAHI_CONFIGURE_ENABLE= avahi
+AVAHI_LIB_DEPENDS= libavahi-client.so:net/avahi-app
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/misc/liblxi/distinfo b/misc/liblxi/distinfo
new file mode 100644
index 000000000000..4ef4700efb5b
--- /dev/null
+++ b/misc/liblxi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1514718407
+SHA256 (lxi-tools-liblxi-v1.9-2-g6b98d93_GH0.tar.gz) = 3bfc305b1643f68f9c16c918267b24eb1f5fd2670bedb5b01ebee98f349279e5
+SIZE (lxi-tools-liblxi-v1.9-2-g6b98d93_GH0.tar.gz) = 18533
diff --git a/misc/liblxi/pkg-descr b/misc/liblxi/pkg-descr
new file mode 100644
index 000000000000..bb86ca3ffbab
--- /dev/null
+++ b/misc/liblxi/pkg-descr
@@ -0,0 +1,6 @@
+liblxi is an open source software library which offers a simple API for
+communicating with LXI compatible instruments. The API allows applications
+to discover instruments on your network, send SCPI commands, and receive
+responses.
+
+WWW: https://lxi-tools.github.io
diff --git a/misc/liblxi/pkg-plist b/misc/liblxi/pkg-plist
new file mode 100644
index 000000000000..75cf561611cf
--- /dev/null
+++ b/misc/liblxi/pkg-plist
@@ -0,0 +1,10 @@
+include/lxi.h
+lib/liblxi.so
+lib/liblxi.so.1
+lib/liblxi.so.1.0.0
+man/man3/lxi_connect.3.gz
+man/man3/lxi_disconnect.3.gz
+man/man3/lxi_discover.3.gz
+man/man3/lxi_init.3.gz
+man/man3/lxi_receive.3.gz
+man/man3/lxi_send.3.gz