aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-07-19 15:21:17 +0800
committeredwin <edwin@FreeBSD.org>2004-07-19 15:21:17 +0800
commitf1c00c3deebbcaadd95a5199b2b9eaf5eba41d6a (patch)
tree2884002215d6c368f9ed43bee4281a31c2d662ab /misc
parentf1c287d60da4956d9af22019b41e79a4c0259b9d (diff)
downloadfreebsd-ports-gnome-f1c00c3deebbcaadd95a5199b2b9eaf5eba41d6a.tar.gz
freebsd-ports-gnome-f1c00c3deebbcaadd95a5199b2b9eaf5eba41d6a.tar.zst
freebsd-ports-gnome-f1c00c3deebbcaadd95a5199b2b9eaf5eba41d6a.zip
[PATCH] misc/screen: Utilize EXAMPLESDIR
Utilize EXAMPLESDIR to improves layout; i.e., configuration file -> ${PREFIX}/etc sample configuration file -> ${PREFIX}/share/examples/${PORTNAME} This change helps if many configuration files and sample ones exist. PR: ports/58385 Submitted by: Hideyuki KURASHINA <rushani@FreeBSD.org> Approved by: maintainer timeout
Diffstat (limited to 'misc')
-rw-r--r--misc/screen/Makefile6
-rw-r--r--misc/screen/pkg-plist5
2 files changed, 7 insertions, 4 deletions
diff --git a/misc/screen/Makefile b/misc/screen/Makefile
index 41e3eca0bc79..00e0c073286b 100644
--- a/misc/screen/Makefile
+++ b/misc/screen/Makefile
@@ -7,6 +7,7 @@
PORTNAME= screen
PORTVERSION= 4.0.2
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= ftp://ftp.uni-erlangen.de/pub/utilities/screen/ \
${MASTER_SITE_GNU}
@@ -31,9 +32,10 @@ post-patch:
@${RM} ${WRKSRC}/doc/screen.info*
post-install:
- @${CP} ${WRKSRC}/etc/etcscreenrc ${PREFIX}/etc/screenrc.sample
+ @${MKDIR} ${EXAMPLESDIR}
+ @${CP} ${WRKSRC}/etc/etcscreenrc ${EXAMPLESDIR}/screenrc
@if [ ! -f ${PREFIX}/etc/screenrc ]; then \
- ${CP} ${PREFIX}/etc/screenrc.sample ${PREFIX}/etc/screenrc ; \
+ ${CP} ${EXAMPLESDIR}/screenrc ${PREFIX}/etc/screenrc ; \
fi
.include <bsd.port.post.mk>
diff --git a/misc/screen/pkg-plist b/misc/screen/pkg-plist
index 5bb876cf63a9..32112173b2b7 100644
--- a/misc/screen/pkg-plist
+++ b/misc/screen/pkg-plist
@@ -16,8 +16,9 @@ bin/screen
%%DATADIR%%/utf8encodings/cc
%%DATADIR%%/utf8encodings/cd
%%DATADIR%%/utf8encodings/d6
-@unexec if cmp -s %D/etc/screenrc %D/etc/screenrc.sample; then rm -f %D/etc/screenrc; else echo If permanently deleting this package, %%PREFIX%%/etc/screenrc must be removed manually; fi
-etc/screenrc.sample
+@unexec if cmp -s %D/etc/screenrc %%EXAMPLESDIR%%/screenrc; then rm -f %D/etc/screenrc; else echo If permanently deleting this package, %%PREFIX%%/etc/screenrc must be removed manually; fi
+%%EXAMPLESDIR%%/screenrc
@exec [ -f %B/screenrc ] || cp %B/%f %B/screenrc
+@dirrm %%EXAMPLESDIR%%
@dirrm %%DATADIR%%/utf8encodings
@dirrm %%DATADIR%%