aboutsummaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-10-20 14:44:44 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-10-20 14:44:44 +0800
commitf2932e76c640fafcde4db101f16450f66f75a22e (patch)
treeca35637715d66bd7217bd7fef4f54242e1e778c8 /misc
parent96ec9a70db7b5cf7a367708624449d3c067e845f (diff)
downloadfreebsd-ports-gnome-f2932e76c640fafcde4db101f16450f66f75a22e.tar.gz
freebsd-ports-gnome-f2932e76c640fafcde4db101f16450f66f75a22e.tar.zst
freebsd-ports-gnome-f2932e76c640fafcde4db101f16450f66f75a22e.zip
- Add p5-Geo-Coder-Multimap 0.01
Geo::Coder::Multimap provides an interface to the geocoding functionality of the Multimap Open API. WWW: http://search.cpan.org/dist/Geo-Coder-Multimap/
Diffstat (limited to 'misc')
-rw-r--r--misc/Makefile1
-rw-r--r--misc/p5-Geo-Coder-Multimap/Makefile36
-rw-r--r--misc/p5-Geo-Coder-Multimap/distinfo2
-rw-r--r--misc/p5-Geo-Coder-Multimap/pkg-descr4
-rw-r--r--misc/p5-Geo-Coder-Multimap/pkg-plist7
5 files changed, 50 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index d16009b32953..0e379af65c97 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -405,6 +405,7 @@
SUBDIR += p5-Geo-Coder-Google
SUBDIR += p5-Geo-Coder-Googlev3
SUBDIR += p5-Geo-Coder-Mapquest
+ SUBDIR += p5-Geo-Coder-Multimap
SUBDIR += p5-Geo-Coder-Multiple
SUBDIR += p5-Geo-Postcodes
SUBDIR += p5-Geo-Postcodes-DK
diff --git a/misc/p5-Geo-Coder-Multimap/Makefile b/misc/p5-Geo-Coder-Multimap/Makefile
new file mode 100644
index 000000000000..7411001d274a
--- /dev/null
+++ b/misc/p5-Geo-Coder-Multimap/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-Geo-Coder-Multimap
+# Date created: 2011-10-13
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-Coder-Multimap
+PORTVERSION= 0.01
+CATEGORIES= misc geography perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Geocode addresses with the Multimap Open API
+
+BUILD_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-JSON-XS>=2:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= p5-JSON>=2:${PORTSDIR}/converters/p5-JSON \
+ p5-JSON-XS>=2:${PORTSDIR}/converters/p5-JSON-XS \
+ p5-URI>=1.36:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= yes
+
+MAN3= Geo::Coder::Multimap.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+TEST_DEPENDS+= p5-Test-Simple>=0.82:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/misc/p5-Geo-Coder-Multimap/distinfo b/misc/p5-Geo-Coder-Multimap/distinfo
new file mode 100644
index 000000000000..4f34ac4da53b
--- /dev/null
+++ b/misc/p5-Geo-Coder-Multimap/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Geo-Coder-Multimap-0.01.tar.gz) = d8804b27f306329216163211b85f3cc1c54238bf0e580ddbb2a35f60e7267f7c
+SIZE (Geo-Coder-Multimap-0.01.tar.gz) = 4928
diff --git a/misc/p5-Geo-Coder-Multimap/pkg-descr b/misc/p5-Geo-Coder-Multimap/pkg-descr
new file mode 100644
index 000000000000..c7207bfb1f00
--- /dev/null
+++ b/misc/p5-Geo-Coder-Multimap/pkg-descr
@@ -0,0 +1,4 @@
+Geo::Coder::Multimap provides an interface to the geocoding functionality of the
+Multimap Open API.
+
+WWW: http://search.cpan.org/dist/Geo-Coder-Multimap/
diff --git a/misc/p5-Geo-Coder-Multimap/pkg-plist b/misc/p5-Geo-Coder-Multimap/pkg-plist
new file mode 100644
index 000000000000..1ad262c0ede6
--- /dev/null
+++ b/misc/p5-Geo-Coder-Multimap/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Geo/Coder/Multimap.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/Multimap/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder/Multimap
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/Coder
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo
+@dirrmtry %%SITE_PERL%%/Geo/Coder
+@dirrmtry %%SITE_PERL%%/Geo